epel9
Irina Boverman 6 years ago
parent e7ba897496
commit 92b40d1dc8

1
.gitignore vendored

@ -20,3 +20,4 @@
/qpid-proton-0.21.0.tar.gz
/qpid-proton-0.24.0.tar.gz
/qpid-proton-0.26.0.tar.gz
/qpid-proton-0.28.0.tar.gz

@ -3,7 +3,7 @@
<dependencies>
<dependency>
<packageName>qpid-proton</packageName>
<version>0.26.0</version>
<version>0.28.0</version>
<licenses>
<license>
<name>ASL 2.0</name>

@ -1,55 +0,0 @@
From 133a1c350c949c5f997706c1b7f71e24559b6718 Mon Sep 17 00:00:00 2001
From: vagrant <vagrant@localhost.localdomain>
Date: Thu, 29 Nov 2018 22:34:01 +0000
Subject: [PATCH] PROTON-1974: Correctly detect libraries with earlier versions
of CMake
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Patch-from: Jiri Daněk
---
tools/cmake/Modules/FindCyrusSASL.cmake | 1 +
tools/cmake/Modules/FindJsonCpp.cmake | 1 +
tools/cmake/Modules/FindLibuv.cmake | 1 +
3 files changed, 3 insertions(+)
diff --git a/tools/cmake/Modules/FindCyrusSASL.cmake b/tools/cmake/Modules/FindCyrusSASL.cmake
index ebd0eab..eeb3dbf 100644
--- a/tools/cmake/Modules/FindCyrusSASL.cmake
+++ b/tools/cmake/Modules/FindCyrusSASL.cmake
@@ -47,6 +47,7 @@ set (CyrusSASL_VERSION ${PC_CyrusSASL_VERSION})
include (FindPackageHandleStandardArgs)
find_package_handle_standard_args (CyrusSASL
+ FOUND_VAR CyrusSASL_FOUND
REQUIRED_VARS CyrusSASL_LIBRARY CyrusSASL_INCLUDE_DIR
VERSION_VAR CyrusSASL_VERSION
)
diff --git a/tools/cmake/Modules/FindJsonCpp.cmake b/tools/cmake/Modules/FindJsonCpp.cmake
index 083d3fc..242718d 100644
--- a/tools/cmake/Modules/FindJsonCpp.cmake
+++ b/tools/cmake/Modules/FindJsonCpp.cmake
@@ -49,6 +49,7 @@ set(JsonCpp_VERSION ${PC_JsonCpp_VERSION})
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(JsonCpp
+ FOUND_VAR JsonCpp_FOUND
REQUIRED_VARS JsonCpp_LIBRARY JsonCpp_INCLUDE_DIR
VERSION_VAR JsonCpp_VERSION)
diff --git a/tools/cmake/Modules/FindLibuv.cmake b/tools/cmake/Modules/FindLibuv.cmake
index 422e124..e38cfaf 100644
--- a/tools/cmake/Modules/FindLibuv.cmake
+++ b/tools/cmake/Modules/FindLibuv.cmake
@@ -49,6 +49,7 @@ set(Libuv_VERSION ${PC_Libuv_VERSION})
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(Libuv
+ FOUND_VAR Libuv_FOUND
REQUIRED_VARS Libuv_LIBRARY Libuv_INCLUDE_DIR
VERSION_VAR Libuv_VERSION)
--
1.8.3.1

@ -19,14 +19,14 @@
%{!?__python2:%global pythonx python}
Name: qpid-proton
Version: 0.26.0
Release: 2%{?dist}
Version: 0.28.0
Release: 1%{?dist}
Summary: A high performance, lightweight messaging library
License: ASL 2.0
URL: http://qpid.apache.org/proton/
Source0: %{name}-%{version}.tar.gz
Patch0: proton.patch
#Patch0: proton.patch
Source1: licenses.xml
@ -243,7 +243,7 @@ BuildArch: noarch
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
#%patch0 -p1
%build
@ -400,6 +400,9 @@ rm -f %{buildroot}%{proton_datadir}/CMakeLists.txt
%check
%changelog
* Tue May 14 2019 Irina Boverman <iboverma@redhat.com> - 0.28.0-1
- Rebased to 0.28.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1 +1 @@
SHA512 (qpid-proton-0.26.0.tar.gz) = e7c028aa4cabb0925c9e6f648a9c9fcfcbb66102aa4e1a82aa801153491db211c5154f95d21928a9c80cb5ef18f0038df0036fbb880ea6083f1b8cc91bd1e888
SHA512 (qpid-proton-0.28.0.tar.gz) = 98c82db9a13543f81ccf0b5d6e4d2f18cb8446016969f3582fb7a50604a189b27c124eb9899887ba10405cce5d9ccb65fa385d57c60a511e5e067b77d74a3fa1

Loading…
Cancel
Save