epel9
Irina Boverman 4 years ago
parent 5e56730e63
commit 7b8931c232

@ -0,0 +1,82 @@
From c575fbe6646fa37ed5759d0011ac7cd0d4cea22b Mon Sep 17 00:00:00 2001
From: Andrew Stitcher <astitcher@apache.org>
Date: Thu, 28 May 2020 12:34:58 -0400
Subject: [PATCH] Temporary patch to enable installed examples to build.
---
c/examples/CMakeLists.txt | 22 ----------------------
cpp/examples/CMakeLists.txt | 31 -------------------------------
2 files changed, 53 deletions(-)
diff --git a/c/examples/CMakeLists.txt b/c/examples/CMakeLists.txt
index 9771ec59..1f448e9e 100644
--- a/c/examples/CMakeLists.txt
+++ b/c/examples/CMakeLists.txt
@@ -32,25 +32,3 @@ foreach (name broker send receive direct send-abort send-ssl)
set_target_properties(c-${name} PROPERTIES
OUTPUT_NAME ${name})
endforeach()
-
-
-find_package (PythonInterp) # For test-driver script
-if (PYTHON_EXECUTABLE)
- if(WIN32)
- # NOTE: need to escape semicolons as cmake uses them as list separators.
- set(test_path "$<TARGET_FILE_DIR:c-broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-proactor>")
- else()
- set(test_path "$<TARGET_FILE_DIR:c-broker>:$ENV{PATH}")
- endif()
-
- set(test_env
- "PATH=${test_path}"
- "PYTHONPATH=../../tests/py")
-
- pn_add_test(
- UNWRAPPED
- NAME c-example-tests
- PREPEND_ENVIRONMENT "${test_env}"
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND ${PYTHON_EXECUTABLE} testme -v)
-endif()
diff --git a/cpp/examples/CMakeLists.txt b/cpp/examples/CMakeLists.txt
index 4c6dc9f4..74e41de4 100644
--- a/cpp/examples/CMakeLists.txt
+++ b/cpp/examples/CMakeLists.txt
@@ -102,34 +102,3 @@ if(HAS_ENOUGH_CPP11)
endforeach()
endif()
endif()
-
-find_package (PythonInterp) # For test-driver script
-if (PYTHON_EXECUTABLE)
- if(WIN32)
- # NOTE: need to escape semicolons as cmake uses them as list separators.
- set(test_path "$<TARGET_FILE_DIR:broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-cpp>")
- else()
- set(test_path "$<TARGET_FILE_DIR:broker>:$ENV{PATH}")
- endif()
-
- set(test_env
- "PATH=${test_path}"
- "PYTHONPATH=../../tests/py"
- "HAS_CPP11=$<$<BOOL:${HAS_ENOUGH_CPP11}>:1>")
-
- pn_add_test(
- UNWRAPPED
- NAME cpp-example-container
- PREPEND_ENVIRONMENT "${test_env}"
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleTest)
-
- if (NOT SSL_IMPL STREQUAL none)
- pn_add_test(
- UNWRAPPED
- NAME cpp-example-container-ssl
- PREPEND_ENVIRONMENT "${test_env}"
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleSSLTest)
- endif()
-endif()
--
2.26.2

@ -14,13 +14,14 @@
Name: qpid-proton
Version: 0.32.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: A high performance, lightweight messaging library
License: ASL 2.0
URL: http://qpid.apache.org/proton/
Source0: %{name}-%{version}.tar.gz
Patch0: proton.patch
Patch1: 0001-Temporary-patch-to-enable-installed-examples-to-buil.patch
Source1: licenses.xml
@ -242,6 +243,7 @@ standard.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
%patch1 -p1
%build
@ -354,6 +356,9 @@ rm -f %{buildroot}%{proton_datadir}/CMakeLists.txt
%check
%changelog
* Fri Oct 2 2020 Irina Boverman <iboverma@redhat.com> - 0.32.0-2
- Added temp fix to allow building c/cpp examples
* Thu Sep 24 2020 Irina Boverman <iboverma@redhat.com> - 0.32.0-1
- Rebased to 0.32.0

Loading…
Cancel
Save