parent
5e56730e63
commit
7b8931c232
@ -0,0 +1,82 @@
|
|||||||
|
From c575fbe6646fa37ed5759d0011ac7cd0d4cea22b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Stitcher <astitcher@apache.org>
|
||||||
|
Date: Thu, 28 May 2020 12:34:58 -0400
|
||||||
|
Subject: [PATCH] Temporary patch to enable installed examples to build.
|
||||||
|
|
||||||
|
---
|
||||||
|
c/examples/CMakeLists.txt | 22 ----------------------
|
||||||
|
cpp/examples/CMakeLists.txt | 31 -------------------------------
|
||||||
|
2 files changed, 53 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/c/examples/CMakeLists.txt b/c/examples/CMakeLists.txt
|
||||||
|
index 9771ec59..1f448e9e 100644
|
||||||
|
--- a/c/examples/CMakeLists.txt
|
||||||
|
+++ b/c/examples/CMakeLists.txt
|
||||||
|
@@ -32,25 +32,3 @@ foreach (name broker send receive direct send-abort send-ssl)
|
||||||
|
set_target_properties(c-${name} PROPERTIES
|
||||||
|
OUTPUT_NAME ${name})
|
||||||
|
endforeach()
|
||||||
|
-
|
||||||
|
-
|
||||||
|
-find_package (PythonInterp) # For test-driver script
|
||||||
|
-if (PYTHON_EXECUTABLE)
|
||||||
|
- if(WIN32)
|
||||||
|
- # NOTE: need to escape semicolons as cmake uses them as list separators.
|
||||||
|
- set(test_path "$<TARGET_FILE_DIR:c-broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-proactor>")
|
||||||
|
- else()
|
||||||
|
- set(test_path "$<TARGET_FILE_DIR:c-broker>:$ENV{PATH}")
|
||||||
|
- endif()
|
||||||
|
-
|
||||||
|
- set(test_env
|
||||||
|
- "PATH=${test_path}"
|
||||||
|
- "PYTHONPATH=../../tests/py")
|
||||||
|
-
|
||||||
|
- pn_add_test(
|
||||||
|
- UNWRAPPED
|
||||||
|
- NAME c-example-tests
|
||||||
|
- PREPEND_ENVIRONMENT "${test_env}"
|
||||||
|
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||||
|
- COMMAND ${PYTHON_EXECUTABLE} testme -v)
|
||||||
|
-endif()
|
||||||
|
diff --git a/cpp/examples/CMakeLists.txt b/cpp/examples/CMakeLists.txt
|
||||||
|
index 4c6dc9f4..74e41de4 100644
|
||||||
|
--- a/cpp/examples/CMakeLists.txt
|
||||||
|
+++ b/cpp/examples/CMakeLists.txt
|
||||||
|
@@ -102,34 +102,3 @@ if(HAS_ENOUGH_CPP11)
|
||||||
|
endforeach()
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
-
|
||||||
|
-find_package (PythonInterp) # For test-driver script
|
||||||
|
-if (PYTHON_EXECUTABLE)
|
||||||
|
- if(WIN32)
|
||||||
|
- # NOTE: need to escape semicolons as cmake uses them as list separators.
|
||||||
|
- set(test_path "$<TARGET_FILE_DIR:broker>\;$<TARGET_FILE_DIR:qpid-proton-core>\;$<TARGET_FILE_DIR:qpid-proton-cpp>")
|
||||||
|
- else()
|
||||||
|
- set(test_path "$<TARGET_FILE_DIR:broker>:$ENV{PATH}")
|
||||||
|
- endif()
|
||||||
|
-
|
||||||
|
- set(test_env
|
||||||
|
- "PATH=${test_path}"
|
||||||
|
- "PYTHONPATH=../../tests/py"
|
||||||
|
- "HAS_CPP11=$<$<BOOL:${HAS_ENOUGH_CPP11}>:1>")
|
||||||
|
-
|
||||||
|
- pn_add_test(
|
||||||
|
- UNWRAPPED
|
||||||
|
- NAME cpp-example-container
|
||||||
|
- PREPEND_ENVIRONMENT "${test_env}"
|
||||||
|
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||||
|
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleTest)
|
||||||
|
-
|
||||||
|
- if (NOT SSL_IMPL STREQUAL none)
|
||||||
|
- pn_add_test(
|
||||||
|
- UNWRAPPED
|
||||||
|
- NAME cpp-example-container-ssl
|
||||||
|
- PREPEND_ENVIRONMENT "${test_env}"
|
||||||
|
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||||
|
- COMMAND ${PYTHON_EXECUTABLE} testme -v ContainerExampleSSLTest)
|
||||||
|
- endif()
|
||||||
|
-endif()
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
Loading…
Reference in new issue