epel9
Irina Boverman 4 years ago
parent 67af16f808
commit 75ac506b5f

@ -1,105 +0,0 @@
From db90a2b3becdcd9a7fa98186c10b86e45212dac8 Mon Sep 17 00:00:00 2001
From: Jiri Danek <jdanek@redhat.com>
Date: Sat, 20 Mar 2021 16:45:49 +0100
Subject: [PATCH 2/5] PROTON-2342 Upgrade Catch to v1.12.2
https://github.com/catchorg/Catch2/releases/tag/v1.12.2
---
tests/include/catch.hpp | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/tests/include/catch.hpp b/tests/include/catch.hpp
index f619f23..fdb046f 100644
--- a/tests/include/catch.hpp
+++ b/tests/include/catch.hpp
@@ -1,6 +1,6 @@
/*
- * Catch v1.12.1
- * Generated: 2018-03-02 21:17:41.036711
+ * Catch v1.12.2
+ * Generated: 2018-05-14 15:10:01.112442
* ----------------------------------------------------------
* This file has been merged from multiple headers. Please don't edit it directly
* Copyright (c) 2012 Two Blue Cubes Ltd. All rights reserved.
@@ -6599,6 +6599,7 @@ namespace Catch {
#endif // not Windows
+#include <cassert>
#include <set>
#include <string>
@@ -8466,7 +8467,7 @@ namespace Catch {
}
inline Version libraryVersion() {
- static Version version( 1, 12, 1, "", 0 );
+ static Version version( 1, 12, 2, "", 0 );
return version;
}
@@ -9171,6 +9172,8 @@ std::string toString( std::nullptr_t ) {
// #included from: catch_result_builder.hpp
#define TWOBLUECUBES_CATCH_RESULT_BUILDER_HPP_INCLUDED
+#include <cassert>
+
namespace Catch {
ResultBuilder::ResultBuilder( char const* macroName,
@@ -10664,6 +10667,7 @@ namespace Catch {
// #included from: ../reporters/catch_reporter_console.hpp
#define TWOBLUECUBES_CATCH_REPORTER_CONSOLE_HPP_INCLUDED
+#include <cassert>
#include <cfloat>
#include <cstdio>
--
1.8.3.1
From 3deea551c9fe61adefae5eb8fd77e919850a213d Mon Sep 17 00:00:00 2001
From: Jiri Danek <jdanek@redhat.com>
Date: Sat, 20 Mar 2021 16:48:13 +0100
Subject: [PATCH 3/5] PROTON-2342 Apply patch for non-constant SIGSTKSZ from
Fedora to Catch
https://src.fedoraproject.org/rpms/catch1/c/059104ba87494c0b5ebe16844ec190f253e51cac?branch=rawhide
---
tests/include/catch.hpp | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/tests/include/catch.hpp b/tests/include/catch.hpp
index fdb046f..d64fd1a 100644
--- a/tests/include/catch.hpp
+++ b/tests/include/catch.hpp
@@ -6540,7 +6540,7 @@ namespace Catch {
static bool isSet;
static struct sigaction oldSigActions [sizeof(signalDefs)/sizeof(SignalDefs)];
static stack_t oldSigStack;
- static char altStackMem[SIGSTKSZ];
+ static char altStackMem[32768];
static void handleSignal( int sig ) {
std::string name = "<unknown signal>";
@@ -6560,7 +6560,7 @@ namespace Catch {
isSet = true;
stack_t sigStack;
sigStack.ss_sp = altStackMem;
- sigStack.ss_size = SIGSTKSZ;
+ sigStack.ss_size = 32768;
sigStack.ss_flags = 0;
sigaltstack(&sigStack, &oldSigStack);
struct sigaction sa = { 0 };
@@ -6591,7 +6591,7 @@ namespace Catch {
bool FatalConditionHandler::isSet = false;
struct sigaction FatalConditionHandler::oldSigActions[sizeof(signalDefs)/sizeof(SignalDefs)] = {};
stack_t FatalConditionHandler::oldSigStack = {};
- char FatalConditionHandler::altStackMem[SIGSTKSZ] = {};
+ char FatalConditionHandler::altStackMem[32768] = {};
} // namespace Catch
--
1.8.3.1

@ -3,7 +3,7 @@
<dependencies>
<dependency>
<packageName>qpid-proton</packageName>
<version>0.33.0</version>
<version>0.34.0</version>
<licenses>
<license>
<name>ASL 2.0</name>

@ -1,6 +1,6 @@
From 0553600784903773655c98b8ca41847c1ce8b9e1 Mon Sep 17 00:00:00 2001
From: Kim van der Riet <kvdr@localhost.localdomain>
Date: Tue, 10 Dec 2019 10:56:30 -0500
From c2256a4ed949bad6b85086113dc570472a0f7c11 Mon Sep 17 00:00:00 2001
From: Irina Boverman <iboverma@redhat.com>
Date: Tue, 4 May 2021 14:12:53 -0400
Subject: [PATCH] Changed Sphinx invocation from sphinx to sphinx-build for
RHEL7
@ -9,14 +9,14 @@ Subject: [PATCH] Changed Sphinx invocation from sphinx to sphinx-build for
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/python/CMakeLists.txt b/python/CMakeLists.txt
index bdd2b4c..0991da1 100644
index 44bc36a..e7d0f10 100644
--- a/python/CMakeLists.txt
+++ b/python/CMakeLists.txt
@@ -127,7 +127,7 @@ else ()
@@ -125,7 +125,7 @@ else ()
COMMAND ${PN_ENV_SCRIPT} --
PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}:${CMAKE_CURRENT_SOURCE_DIR}
LD_LIBRARY_PATH="${CMAKE_CURRENT_BINARY_DIR}/c"
- ${PYTHON_EXECUTABLE} -m sphinx "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
- ${Python_EXECUTABLE} -m sphinx "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
+ sphinx-build "${CMAKE_CURRENT_SOURCE_DIR}/docs" "${CMAKE_CURRENT_BINARY_DIR}/docs")
add_dependencies(docs docs-py)
install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/docs/"

@ -5,23 +5,15 @@
%global __provides_exclude_from ^%{proton_datadir}/examples/.*$
%global __requires_exclude_from ^%{proton_datadir}/examples/.*$
# for older rpm, like el6, https://fedoraproject.org/wiki/EPEL:Packaging_Autoprovides_and_Requires_Filtering#Perl
%{?filter_setup:
%filter_provides_in %{proton_datadir}/examples/
%filter_requires_in %{proton_datadir}/examples/
%filter_setup
}
Name: qpid-proton
Version: 0.33.0
Release: 4%{?dist}
Version: 0.34.0
Release: 1%{?dist}
Summary: A high performance, lightweight messaging library
License: ASL 2.0
URL: http://qpid.apache.org/proton/
Source0: %{name}-%{version}.tar.gz
Patch0: proton.patch
Patch1: catch.patch
Source1: licenses.xml
@ -235,7 +227,6 @@ standard.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1
%patch1 -p1
%build
@ -342,6 +333,9 @@ rm -f %{buildroot}%{proton_datadir}/CMakeLists.txt
%check
%changelog
* Tue May 4 2021 Irina Boverman <iboverma@redhat.com> - 0.34.0-1
- Rebased to 0.34.0
* Wed Mar 31 2021 Jonathan Wakely <jwakely@redhat.com> - 0.33.0-4
- Rebuilt for removed libstdc++ symbols (#1937698)

@ -1 +1 @@
SHA512 (qpid-proton-0.33.0.tar.gz) = d82cade354fd01f2cf7a3e0c17d48cdfa3bde263c8571762cdeb0b4da6ef2d6fd6f97cdba4fa4e8fc1b5368c54ccd2ca860fb56f46f58091c91deab843a17cf2
SHA512 (qpid-proton-0.34.0.tar.gz) = 6a72540b662ac121838d8cc32b9480e948f9953f87036c3bcb72d9e77b07ea41973ccd3c2513b64c56b4f53077708a893e42e13fd5792cf8c4bcbbc4d2384e23

Loading…
Cancel
Save