epel9
Irina Boverman 8 years ago
parent 27a6e4c249
commit 2aa95cca7f

@ -0,0 +1,25 @@
diff --git a/proton-c/bindings/perl/CMakeLists.txt b/proton-c/bindings/perl/CMakeLists.txt
index 1356ccea..ed61d864 100644
--- a/proton-c/bindings/perl/CMakeLists.txt
+++ b/proton-c/bindings/perl/CMakeLists.txt
@@ -56,18 +56,9 @@ list(APPEND SWIG_MODULE_cproton_perl_EXTRA_DEPS
swig_add_module(cproton_perl perl perl.i)
swig_link_libraries(cproton_perl ${BINDING_DEPS} ${PERL_LIBRARY})
-if ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.so
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.so
DESTINATION ${PERL_VENDORARCH_DIR}/auto/cproton_perl
- COMPONENT Perl
- )
-else()
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libcproton_perl.so
- RENAME cproton_perl.so
- DESTINATION ${PERL_VENDORARCH_DIR}/auto/cproton_perl
- COMPONENT Perl
- )
-endif ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
+ COMPONENT Perl)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.pm
DESTINATION ${PERL_VENDORARCH_DIR}

@ -17,7 +17,7 @@
Name: qpid-proton Name: qpid-proton
Version: 0.17.0 Version: 0.17.0
Release: 7%{?dist} Release: 6%{?dist}
Group: System Environment/Libraries Group: System Environment/Libraries
Summary: A high performance, lightweight messaging library Summary: A high performance, lightweight messaging library
@ -58,6 +58,7 @@ BuildRequires: perl(Test::More)
BuildRequires: cyrus-sasl-devel BuildRequires: cyrus-sasl-devel
Patch0: 0001-PROTON-1466-proton-c-mixing-up-links-with-names-that.patch Patch0: 0001-PROTON-1466-proton-c-mixing-up-links-with-names-that.patch
Patch1: preliminary.patch
%description %description
Proton is a high performance, lightweight messaging library. It can be used in Proton is a high performance, lightweight messaging library. It can be used in
@ -274,6 +275,7 @@ Requires: qpid-proton-c = %{version}-%{release}
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
%patch0 -p1 %patch0 -p1
%patch1 -p1
%build %build
@ -399,14 +401,9 @@ popd
%endif %endif
%changelog %changelog
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-7 * Tue Aug 8 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Mon Jul 31 2017 Irina Boverman <iboverma@redhat.com> - 0.17.0-6
- Added missing *.hpp files in qpid-proton-cpp-devel package - Added missing *.hpp files in qpid-proton-cpp-devel package
- Added preliminary patch to resolve install issue
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.17.0-5 * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.17.0-5
- Rebuild due to bug in RPM (RHBZ #1468476) - Rebuild due to bug in RPM (RHBZ #1468476)

Loading…
Cancel
Save