Updated to version 0.3.0.

epel9
Vitaly Zaitsev 3 years ago
parent 70107bf160
commit d31c312a81
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A

1
.gitignore vendored

@ -1 +1,2 @@
/qcoro-0.2.0.tar.gz /qcoro-0.2.0.tar.gz
/qcoro-0.3.0.tar.gz

@ -1,60 +0,0 @@
From f6aaf59f9b4bd116dbc24a6eaae426ac13067078 Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Sat, 2 Oct 2021 17:10:02 +0200
Subject: [PATCH] Added SOVERSION field for shared libraries.
Signed-off-by: Vitaly Zaitsev <vitaly@easycoding.org>
---
CMakeLists.txt | 1 +
qcoro/core/CMakeLists.txt | 1 +
qcoro/dbus/CMakeLists.txt | 1 +
qcoro/network/CMakeLists.txt | 1 +
4 files changed, 4 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ad576e..937997c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
cmake_minimum_required(VERSION 3.19)
set(qcoro_VERSION 0.2.0)
+set(qcoro_SOVERSION 0)
project(qcoro LANGUAGES CXX VERSION ${qcoro_VERSION})
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
diff --git a/qcoro/core/CMakeLists.txt b/qcoro/core/CMakeLists.txt
index 125f9f0..02f8c06 100644
--- a/qcoro/core/CMakeLists.txt
+++ b/qcoro/core/CMakeLists.txt
@@ -21,6 +21,7 @@ target_include_directories(QCoroCore
PUBLIC $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/QCoro>
)
set_target_properties(QCoroCore PROPERTIES WINDOWS_EXPORT_ALL_SYMBOLS 1)
+set_target_properties(QCoroCore PROPERTIES VERSION ${qcoro_VERSION} SOVERSION ${qcoro_SOVERSION})
generate_headers(
qcoro_core_CamelCase_HEADERS
diff --git a/qcoro/dbus/CMakeLists.txt b/qcoro/dbus/CMakeLists.txt
index b3af912..87f05a1 100644
--- a/qcoro/dbus/CMakeLists.txt
+++ b/qcoro/dbus/CMakeLists.txt
@@ -21,6 +21,7 @@ target_include_directories(QCoroDBus
PUBLIC $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/QCoro>
)
set_target_properties(QCoroDBus PROPERTIES WINDOWS_EXPORT_ALL_SYMBOLS 1)
+set_target_properties(QCoroDBus PROPERTIES VERSION ${qcoro_VERSION} SOVERSION ${qcoro_SOVERSION})
generate_headers(
qcoro_dbus_CamelCase_HEADERS
diff --git a/qcoro/network/CMakeLists.txt b/qcoro/network/CMakeLists.txt
index 28c27a7..3c3b35c 100644
--- a/qcoro/network/CMakeLists.txt
+++ b/qcoro/network/CMakeLists.txt
@@ -22,6 +22,7 @@ target_include_directories(QCoroNetwork
PUBLIC $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/QCoro>
)
set_target_properties(QCoroNetwork PROPERTIES WINDOWS_EXPORT_ALL_SYMBOLS 1)
+set_target_properties(QCoroNetwork PROPERTIES VERSION ${qcoro_VERSION} SOVERSION ${qcoro_SOVERSION})
generate_headers(
qcoro_network_CamelCase_HEADERS

@ -3,7 +3,7 @@
%global tests 1 %global tests 1
Name: qcoro Name: qcoro
Version: 0.2.0 Version: 0.3.0
Release: 1%{?dist} Release: 1%{?dist}
License: MIT License: MIT
@ -25,9 +25,6 @@ BuildRequires: cmake(Qt5Test)
BuildRequires: dbus-x11 BuildRequires: dbus-x11
%endif %endif
# https://github.com/danvratil/qcoro/pull/17
Patch100: %{name}-add-soversion.patch
%description %description
The QCoro library provides set of tools to make use of the C++20 coroutines The QCoro library provides set of tools to make use of the C++20 coroutines
in connection with certain asynchronous Qt actions. in connection with certain asynchronous Qt actions.
@ -78,5 +75,8 @@ Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
%{_libdir}/lib%{appname}*.so %{_libdir}/lib%{appname}*.so
%changelog %changelog
* Mon Oct 25 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 0.3.0-1
- Updated to version 0.3.0.
* Sat Oct 02 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 0.2.0-1 * Sat Oct 02 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 0.2.0-1
- Initial SPEC release. - Initial SPEC release.

@ -1 +1 @@
SHA512 (qcoro-0.2.0.tar.gz) = 72ba6b3c5a7b0bd28f96e47dfdd6aeb5436acacfb7056d0941c2f705cfd8f611c59815b1a24777b8f755ed453fd7e7683b2d6936f210c86830b218e5b3d258b8 SHA512 (qcoro-0.3.0.tar.gz) = 16d8aa4ec0f6f45e5c7d716e18636a506524e44d6ed43612326911df2331f01a5b10f86a7b7d0ed307c1220b1b60aca3047143a5e6376f81ed9a081f7c922a38

Loading…
Cancel
Save