- 1.1.1 release - support QT4_BUILD option - fix dso patch - Provides: libqaccessibilityclient(-devel)epel9
parent
9215e5e7af
commit
74d3e8f6f6
@ -1 +1 @@
|
||||
/qaccessibilityclient-0.1.0-20121113git.tar.xz
|
||||
/libqaccessibilityclient-0.1.1.tar.bz2
|
||||
|
@ -0,0 +1,22 @@
|
||||
diff -up libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 libqaccessibilityclient-0.1.1/CMakeLists.txt
|
||||
--- libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 2014-02-07 10:24:10.000000000 -0600
|
||||
+++ libqaccessibilityclient-0.1.1/CMakeLists.txt 2014-02-12 22:13:56.002246423 -0600
|
||||
@@ -14,15 +14,17 @@ set(CMAKE_AUTOMOC TRUE)
|
||||
|
||||
# override the KDE defaults and build tests unless explicitly disabled
|
||||
option(KDE4_BUILD_TESTS "Build the tests" ON)
|
||||
+option(QT4_BUILD "Force building with Qt4 even if Qt5 is found")
|
||||
|
||||
include_directories(
|
||||
${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}
|
||||
${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR}
|
||||
)
|
||||
|
||||
+if (NOT QT4_BUILD)
|
||||
find_package(Qt5Widgets QUIET)
|
||||
find_package(Qt5DBus QUIET)
|
||||
-
|
||||
+endif()
|
||||
|
||||
if (${Qt5Widgets_FOUND} AND ${Qt5DBus_FOUND})
|
||||
set(QT5_BUILD True)
|
Loading…
Reference in new issue