pull in upstream fixes

initial support for Qt5 build (not enabled yet)
.spec cosmetics: update URL, use %license
epel9
Rex Dieter 8 years ago
parent 7af417d91a
commit 5e3542c2e7

12
.gitignore vendored

@ -1 +1,13 @@
/libqaccessibilityclient-0.1.1.tar.bz2
/0001-introduce-QT4_BUILD-option-default-OFF.patch
/0002-Revert-NoInterface-is-the-same-as-InvalidInterface-r.patch
/0003-Add-textWithBoundaries.patch
/0004-Change-dbus-timeouts-to-return-much-faster.patch
/0005-Improve-test-stability.patch
/0006-Remove-debug-output.patch
/0007-Improve-updating-of-the-current-object.patch
/0008-Add-name-to-object-debug-output.patch
/0009-Fix-Qt4-build.patch
/0010-qt4-link-to-QtGui.patch
/0011-Fix-missing-return-values-of-methods.patch
/0012-Add-suffix-to-the-Qt5-build-to-allow-co-installabili.patch

@ -1,22 +0,0 @@
diff -up libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 libqaccessibilityclient-0.1.1/CMakeLists.txt
--- libqaccessibilityclient-0.1.1/CMakeLists.txt.qt4 2014-02-07 10:24:10.000000000 -0600
+++ libqaccessibilityclient-0.1.1/CMakeLists.txt 2014-02-12 22:13:56.002246423 -0600
@@ -14,15 +14,17 @@ set(CMAKE_AUTOMOC TRUE)
# override the KDE defaults and build tests unless explicitly disabled
option(KDE4_BUILD_TESTS "Build the tests" ON)
+option(QT4_BUILD "Force building with Qt4 even if Qt5 is found")
include_directories(
${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR}
)
+if (NOT QT4_BUILD)
find_package(Qt5Widgets QUIET)
find_package(Qt5DBus QUIET)
-
+endif()
if (${Qt5Widgets_FOUND} AND ${Qt5DBus_FOUND})
set(QT5_BUILD True)

@ -1,13 +0,0 @@
diff -up qaccessibilityclient-0.1.0/CMakeLists.txt.dso qaccessibilityclient-0.1.0/CMakeLists.txt
diff -up qaccessibilityclient-0.1.0/src/CMakeLists.txt.dso qaccessibilityclient-0.1.0/src/CMakeLists.txt
--- qaccessibilityclient-0.1.0/src/CMakeLists.txt.dso 2012-11-13 15:08:16.000000000 -0600
+++ qaccessibilityclient-0.1.0/src/CMakeLists.txt 2013-03-13 21:48:57.780775276 -0500
@@ -24,7 +24,7 @@ add_library(qaccessibilityclient SHARED
if (QT5_BUILD)
target_link_libraries(qaccessibilityclient ${Qt5Core_LIBRARIES} ${Qt5Widgets_LIBRARIES} ${Qt5DBus_LIBRARIES})
else (QT5_BUILD)
- target_link_libraries(qaccessibilityclient ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY})
+ target_link_libraries(qaccessibilityclient ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTDBUS_LIBRARY})
endif(QT5_BUILD)
set(QACCESSIBILITYCLIENT_SOVERSION ${QACCESSIBILITYCLIENT_VERSION_MAJOR})

@ -1,12 +1,15 @@
## Initial work to support both qt5 builds, but needswork
#global qt5 1
Name: qaccessibilityclient
Summary: Accessibility client library for Qt
Version: 0.1.1
Release: 7%{?dist}
Release: 8%{?dist}
# KDE e.V. may determine that future LGPL versions are accepted
License: LGPLv2 or LGPLv3
URL: https://projects.kde.org/projects/playground/accessibility/libkdeaccessibilityclient
URL: https://cgit.kde.org/libkdeaccessibilityclient.git/
%if 0%{?snap}
Source0: qaccessibilityclient-%{version}-%{snap}.tar.xz
%else
@ -14,11 +17,20 @@ Source0: http://download.kde.org/stable/libqaccessibilityclient/libqaccessibilit
%endif
Source1: qaccessibilityclient_snapshot.sh
## upstreamable patches
# link QtGui for undefined symbols
Patch50: qaccessibilityclient-0.1.0-dso.patch
# QT4_BUILD option
Patch51: libqaccessibilityclient-0.1.1-QT4_BUILD.patch
## upstream patches
Patch1: 0001-introduce-QT4_BUILD-option-default-OFF.patch
## already applied -- rex
#Patch2: 0002-Revert-NoInterface-is-the-same-as-InvalidInterface-r.patch
Patch3: 0003-Add-textWithBoundaries.patch
Patch4: 0004-Change-dbus-timeouts-to-return-much-faster.patch
Patch5: 0005-Improve-test-stability.patch
Patch6: 0006-Remove-debug-output.patch
Patch7: 0007-Improve-updating-of-the-current-object.patch
Patch8: 0008-Add-name-to-object-debug-output.patch
Patch9: 0009-Fix-Qt4-build.patch
Patch10: 0010-qt4-link-to-QtGui.patch
Patch11: 0011-Fix-missing-return-values-of-methods.patch
Patch12: 0012-Add-suffix-to-the-Qt5-build-to-allow-co-installabili.patch
BuildRequires: cmake >= 2.8.6
BuildRequires: pkgconfig(QtDBus) pkgconfig(QtGui)
@ -38,24 +50,34 @@ Requires: qt4-devel
%prep
%setup -q -n libqaccessibilityclient-%{version}
%autosetup -n libqaccessibilityclient-%{version} -p1
%patch50 -p1 -b .dso
%patch51 -p1 -b .QT4_BUILD
%build
mkdir -p %{_target_platform}
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake} \
-DQT4_BUILD:BOOL=ON \
..
%{cmake} .. \
-DQT4_BUILD:BOOL=ON
popd
make %{?_smp_mflags} -C %{_target_platform}
%if 0%{?qt5}
mkdir %{_target_platform}-qt5
pushd %{_target_platform}-qt5
%{cmake} .. \
-DQT4_BUILD:BOOL=OFF
popd
make %{?_smp_mflags} -C %{_target_platform}-qt5
%endif
%install
%if 0%{?qt5}
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}-qt5
%endif
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
## unpackaged files
@ -67,7 +89,8 @@ rm -f %{buildroot}%{_bindir}/accessibleapps
%postun -p /sbin/ldconfig
%files
%doc AUTHORS ChangeLog COPYING README
%doc AUTHORS ChangeLog README
%license COPYING
%{_libdir}/libqaccessibilityclient.so.0*
%files devel
@ -78,6 +101,11 @@ rm -f %{buildroot}%{_bindir}/accessibleapps
%changelog
* Thu Jul 20 2017 Rex Dieter <rdieter@fedoraproject.org> - 0.1.1-8
- pull in upstream fixes
- initial support for Qt5 build (not enabled yet)
- .spec cosmetics: update URL, use %%license
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

@ -1 +1,13 @@
757ab7c4844c1a6220176b0f1a1bd08c libqaccessibilityclient-0.1.1.tar.bz2
SHA512 (libqaccessibilityclient-0.1.1.tar.bz2) = 2b596b269386c5f076509f0a8ebf330705d58f1f9adb29335509a01b4a4f9a91544cab0b6ba2ae1551316aa6abbf40f8f7e81da20ab1b2abf47a31dfbb4e78cd
SHA512 (0001-introduce-QT4_BUILD-option-default-OFF.patch) = a6cb3ac3833b04924ea5bd901b52bb92af9343df34006aabcd4577430161f15e688c2082926273090b3dd968f077009651b5fb6ba046aed483d7873d7cd60dbb
SHA512 (0002-Revert-NoInterface-is-the-same-as-InvalidInterface-r.patch) = d32fff3a91d84b1e14f02ff439d4078e5995659e8c3fe83e250c7ff3c1c5735bcbeb6b6d2b9654fe735183714a4a70223cc232f08923f2f9e1168110068cb873
SHA512 (0003-Add-textWithBoundaries.patch) = 8e26b8def0f964076b650f56b272d4ba6cbc08528c5ee6a9bd0570a58cbee6e7b875c7ab1595669df288b239182704c496f74855df62e243c058f8a69d0d591e
SHA512 (0004-Change-dbus-timeouts-to-return-much-faster.patch) = d34f2eeeae31206f1e6def9b8b8b07f644b18fa8598cd458f95334463b57dde820ba0b8eb694626ed4ecfedb5f9c34ec40ba77952272e9341b5fb0a41027becb
SHA512 (0005-Improve-test-stability.patch) = dc8f230306831da4f0ba8f68a6de7e9967a9905fca442f518ba1ed6dbda73c495d80082b34fa73bd92473986891bad9f0d45f59f4d7534195a153a3e7a9d07bf
SHA512 (0006-Remove-debug-output.patch) = b9c3b13fb6f68650691707ba06b99c48925bd61c86472d598928766448fe441a103a918dc2b7932d38255625c7917a9b715ef7444e910df08fa57e05cabc291e
SHA512 (0007-Improve-updating-of-the-current-object.patch) = f69fe676c4489f15133a17f6754852434ebed2b36d34e50bd43228caabe936d6c675cfdcde214d177fc8171b2144f3af4a6465b0fe31e9b1d9c8666c17d33e71
SHA512 (0008-Add-name-to-object-debug-output.patch) = 86dde52e5ec07fffab343e3bb2111eff8b19d7e5a048540f49db3d4a2279071ce85822f591c3e23592a7b49496426fca0625cc94136afe3b02748b89b9b9c912
SHA512 (0009-Fix-Qt4-build.patch) = d9c62010cbbd34933271b76a0ae4bb6d0646128e13d6b9198c2b904e2d5a8c99a18a6f1b20f272e81be10d8edadc24ff2419d66393408321d48f8b4ccaae72b3
SHA512 (0010-qt4-link-to-QtGui.patch) = e860a8dff1bd7da8ad7145986cfcf83c7ef267ef16917220f1561fad55894a6825501a3da8d47ebae7f2ba116216349482b4695f008cc73701d0529c34865ce9
SHA512 (0011-Fix-missing-return-values-of-methods.patch) = 5e2fff704c7c1396663c8d454f05f44f51c53e1e94d0cd5faeacc099fc06d0869d8d5e16ce50bc37488d2227275576cf1123b20af7b8645b8c699cfb647ba484
SHA512 (0012-Add-suffix-to-the-Qt5-build-to-allow-co-installabili.patch) = 92e33a8933989edf66efa5c94a01545e4e01d582c6f88989f60a2163ad3831906e9bca7dd38c1d1fd073ef092096277c992b24788454bf95045e05fb70074882

Loading…
Cancel
Save