python-zope-interface-3.0.1-6.src.rpmepel8
parent
ed93c7f0fd
commit
87a78126e6
@ -0,0 +1 @@
|
|||||||
|
ZopeInterface-3.0.1.tgz
|
@ -0,0 +1,40 @@
|
|||||||
|
Zope Public License (ZPL) Version 2.1
|
||||||
|
|
||||||
|
A copyright notice accompanies this license document that identifies the
|
||||||
|
copyright holders.
|
||||||
|
|
||||||
|
This license has been certified as open source. It has also been designated
|
||||||
|
as GPL compatible by the Free Software Foundation (FSF).
|
||||||
|
|
||||||
|
Redistribution and use in source and binary forms, with or without
|
||||||
|
modification, are permitted provided that the following conditions are met:
|
||||||
|
|
||||||
|
1. Redistributions in source code must retain the accompanying copyright
|
||||||
|
notice, this list of conditions, and the following disclaimer.
|
||||||
|
2. Redistributions in binary form must reproduce the accompanying copyright
|
||||||
|
notice, this list of conditions, and the following disclaimer in the
|
||||||
|
documentation and/or other materials provided with the distribution.
|
||||||
|
3. Names of the copyright holders must not be used to endorse or promote
|
||||||
|
products derived from this software without prior written permission from
|
||||||
|
the copyright holders.
|
||||||
|
4. The right to distribute this software or to use it for any purpose does
|
||||||
|
not give you the right to use Servicemarks (sm) or Trademarks (tm) of the
|
||||||
|
copyright holders. Use of them is covered by separate agreement with the
|
||||||
|
copyright holders.
|
||||||
|
5. If any files are modified, you must cause the modified files to carry
|
||||||
|
prominent notices stating that you changed the files and the date of any
|
||||||
|
change.
|
||||||
|
|
||||||
|
Disclaimer
|
||||||
|
|
||||||
|
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS ``AS IS'' AND ANY EXPRESSED
|
||||||
|
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT,
|
||||||
|
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||||
|
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
|
||||||
|
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
|
||||||
|
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
|
||||||
|
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -urN ZopeInterface-3.0.1/Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c ZopeInterface-3.0.1-declbug/Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c
|
||||||
|
--- ZopeInterface-3.0.1/Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c 2004-08-04 18:03:17.000000000 +0800
|
||||||
|
+++ ZopeInterface-3.0.1-declbug/Dependencies/zope.interface-ZopeInterface-3.0.1/zope.interface/_zope_interface_coptimizations.c 2005-08-23 08:05:27.376784740 +0800
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
-extern PyTypeObject SpecType; /* Forward */
|
||||||
|
+static PyTypeObject SpecType; /* Forward */
|
||||||
|
|
||||||
|
static PyObject *
|
||||||
|
implementedByFallback(PyObject *cls)
|
@ -0,0 +1,68 @@
|
|||||||
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
|
Name: python-zope-interface
|
||||||
|
Version: 3.0.1
|
||||||
|
Release: 6%{?dist}
|
||||||
|
Summary: Zope interfaces package
|
||||||
|
Group: Development/Libraries
|
||||||
|
License: Zope Public License
|
||||||
|
URL: http://zope.org/Products/ZopeInterface
|
||||||
|
Source0: http://zope.org/Products/ZopeInterface/3.0.1final/ZopeInterface-%{version}.tgz
|
||||||
|
Source1: ZPL-2.1.txt
|
||||||
|
Patch0: ZopeInterface-3.0.1-declbug.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
BuildRequires: python-devel
|
||||||
|
|
||||||
|
%description
|
||||||
|
This is a separate distribution of the zope.interface package used in Zope 3.
|
||||||
|
|
||||||
|
It includes a patch to fix compilation on gcc 4.x, as described here:
|
||||||
|
http://www.zope.org/Collectors/Zope3-dev/366/
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -n ZopeInterface-%{version} -q
|
||||||
|
%{__cp} -a %{SOURCE1} .
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%{__rm} -rf %{buildroot}
|
||||||
|
%{__python} setup.py install -O1 --skip-build --root %{buildroot}
|
||||||
|
|
||||||
|
%check
|
||||||
|
cd ./build/lib.* && PYTHONPATH=$(pwd) %{__python} ./zope/testing/tests.py
|
||||||
|
|
||||||
|
%clean
|
||||||
|
%{__rm} -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc README.txt ZPL-2.1.txt
|
||||||
|
%{python_sitearch}/zope/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 31 2006 Paul Howarth <paul@city-fan.org> 3.0.1-6
|
||||||
|
- add %%check section
|
||||||
|
|
||||||
|
* Wed Sep 20 2006 Paul Howarth <paul@city-fan.org> 3.0.1-5
|
||||||
|
- dispense with %%{pybasever} macro and python-abi dependency, not needed from
|
||||||
|
FC4 onwards
|
||||||
|
- include ZPL 2.1 license text
|
||||||
|
- add reference in %%description to origin of patch
|
||||||
|
- change License: tag from "ZPL 2.1" to "Zope Public License" to shut rpmlint up
|
||||||
|
|
||||||
|
* Thu Aug 31 2006 Paul Howarth <paul@city-fan.org> 3.0.1-4
|
||||||
|
- files list simplified as .pyo files are no longer %%ghost-ed
|
||||||
|
|
||||||
|
* Tue May 9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-3
|
||||||
|
- import from PyVault Repository
|
||||||
|
- rewrite in Fedora Extras style
|
||||||
|
|
||||||
|
* Tue Aug 23 2005 Jeff Pitman <symbiont+pyvault@berlios.de> 3.0.1-2
|
||||||
|
- add bug fix for gcc 4
|
||||||
|
|
||||||
|
* Mon Feb 07 2005 Jeff Pitman <symbiont+pyvault@berlios.de> 3.0.1-1
|
||||||
|
- new rpm
|
||||||
|
|
Loading…
Reference in new issue