- catch read errors so they trigger the failure callback. helps catch bad

cds
epel9
Jeremy Katz 19 years ago
parent 48d1d4e0b0
commit e1012e44e7

@ -3,8 +3,9 @@
Summary: A high-level cross-protocol url-grabber
Name: python-urlgrabber
Version: 2.9.8
Release: 1
Release: 2
Source0: urlgrabber-%{version}.tar.gz
Patch0: urlgrabber-read-error.patch
License: LGPL
Group: Development/Libraries
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
@ -20,6 +21,7 @@ authentication, proxies and more.
%prep
%setup -n urlgrabber-%{version}
%patch0 -p0
%build
python setup.py build
@ -39,6 +41,9 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/urlgrabber
%changelog
* Tue Mar 14 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-2
- catch read errors so they trigger the failure callback. helps catch bad cds
* Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
- update to new version fixing progress bars in yum on regets

@ -0,0 +1,11 @@
--- urlgrabber/grabber.py~ 2006-02-22 13:26:46.000000000 -0500
+++ urlgrabber/grabber.py 2006-03-14 14:17:59.000000000 -0500
@@ -1140,6 +1140,8 @@
raise URLGrabError(4, _('Socket Error: %s') % (e, ))
except TimeoutError, e:
raise URLGrabError(12, _('Timeout: %s') % (e, ))
+ except IOError, e:
+ raise URLGrabError(4, _('IOError: %s') %(e,))
newsize = len(new)
if not newsize: break # no more to read
Loading…
Cancel
Save