add urlgrabber-reset and rebuild

epel9
Seth Vidal 15 years ago
parent d4d9f67b51
commit c3eb320495

@ -3,9 +3,10 @@
Summary: A high-level cross-protocol url-grabber
Name: python-urlgrabber
Version: 3.9.1
Release: 4%{?dist}
Release: 5%{?dist}
Source0: urlgrabber-%{version}.tar.gz
Patch1: urlgrabber-HEAD.patch
Patch2: urlgrabber-reset.patch
License: LGPLv2+
Group: Development/Libraries
@ -24,6 +25,7 @@ authentication, proxies and more.
%prep
%setup -q -n urlgrabber-%{version}
%patch1 -p1
%patch2 -p1
%build
python setup.py build
@ -43,6 +45,9 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/urlgrabber
%changelog
* Fri Feb 19 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-5
- add patch to allow reset_curl_obj() to close and reload the cached curl obj
* Thu Nov 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-4
- reset header values when we redirect and make sure debug output will work

@ -0,0 +1,15 @@
--- a/urlgrabber/grabber.py 2010-02-19 14:50:45.000000000 -0500
+++ b/urlgrabber/grabber.py 2010-02-19 14:51:28.000000000 -0500
@@ -1626,6 +1626,12 @@
_curl_cache = pycurl.Curl() # make one and reuse it over and over and over
+def reset_curl_obj():
+ """To make sure curl has reread the network/dns info we force a reload"""
+ global _curl_cache
+ _curl_cache.close()
+ _curl_cache = pycurl.Curl()
+
#####################################################################
# DEPRECATED FUNCTIONS
Loading…
Cancel
Save