- Fix the ftp byterange port problem:

- Resolves: bug#419241
- Fixup the progress UI:
- add function for total progress
- add total progress percentagee current download line
- add rate to current download line
- use dead space when finished downloading
- don't confuse download rate on regets.
epel9
James Antill 17 years ago
parent 850f513283
commit 544e2baa80

@ -28,8 +28,8 @@ authentication, proxies and more.
%patch0 -p0
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch3 -p0
%patch4 -p0
%build
python setup.py build

@ -0,0 +1,16 @@
Index: urlgrabber/byterange.py
===================================================================
RCS file: /home/groups/urlgrabber/cvs-root/urlgrabber/urlgrabber/byterange.py,v
retrieving revision 1.12
diff -u -r1.12 byterange.py
--- urlgrabber/byterange.py 20 Jul 2006 20:15:58 -0000 1.12
+++ urlgrabber/byterange.py 13 Mar 2008 18:48:56 -0000
@@ -272,6 +272,8 @@
host, port = splitport(host)
if port is None:
port = ftplib.FTP_PORT
+ else:
+ port = int(port)
# username/password handling
user, host = splituser(host)

@ -1,10 +1,10 @@
Index: progress.py
Index: urlgrabber/progress.py
===================================================================
RCS file: /home/groups/urlgrabber/cvs-root/urlgrabber/urlgrabber/progress.py,v
retrieving revision 1.7
diff -u -r1.7 progress.py
--- progress.py 19 Aug 2005 21:59:07 -0000 1.7
+++ progress.py 7 Apr 2008 16:33:30 -0000
diff -u -r1.7 urlgrabber/progress.py
--- urlgrabber/progress.py 19 Aug 2005 21:59:07 -0000 1.7
+++ urlgrabber/progress.py 7 Apr 2008 16:33:30 -0000
@@ -83,6 +83,17 @@
def _do_end(self, amount_read, now=None):
pass

Loading…
Cancel
Save