i10cs
changed/i10cs/python-trove-classifiers-2023.10.18-4.el10
commit
a98908b84a
@ -0,0 +1 @@
|
|||||||
|
SOURCES/trove-classifiers-2023.10.18.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
70e4dbf86b699126e13db18a549d152044cd340e SOURCES/trove-classifiers-2023.10.18.tar.gz
|
@ -0,0 +1,95 @@
|
|||||||
|
From 49510fec2cddeb796ab4078be4577eee624833f0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
|
||||||
|
Date: Tue, 21 Feb 2023 18:22:42 +0100
|
||||||
|
Subject: [PATCH] Move to PEP 621 declarative metadata
|
||||||
|
|
||||||
|
---
|
||||||
|
pyproject.toml | 31 ++++++++++++++++++++++++++++++-
|
||||||
|
setup.py | 33 ---------------------------------
|
||||||
|
2 files changed, 30 insertions(+), 34 deletions(-)
|
||||||
|
delete mode 100644 setup.py
|
||||||
|
|
||||||
|
diff --git a/pyproject.toml b/pyproject.toml
|
||||||
|
index 05374a2..1134247 100644
|
||||||
|
--- a/pyproject.toml
|
||||||
|
+++ b/pyproject.toml
|
||||||
|
@@ -1,7 +1,36 @@
|
||||||
|
[build-system]
|
||||||
|
-requires = ["setuptools", "calver"]
|
||||||
|
+requires = ["setuptools >= 61.0"]
|
||||||
|
build-backend = "setuptools.build_meta"
|
||||||
|
|
||||||
|
+[project]
|
||||||
|
+name = "trove-classifiers"
|
||||||
|
+version = "@@VERSION@@"
|
||||||
|
+readme = "README.md"
|
||||||
|
+description = "Canonical source for classifiers on PyPI (pypi.org)."
|
||||||
|
+authors = [{name = "The PyPI Admins", email = "admin@pypi.org"}]
|
||||||
|
+classifiers = [
|
||||||
|
+ "Development Status :: 5 - Production/Stable",
|
||||||
|
+ "Intended Audience :: Developers",
|
||||||
|
+ "License :: OSI Approved :: Apache Software License",
|
||||||
|
+ "Programming Language :: Python :: 3",
|
||||||
|
+ "Typing :: Typed",
|
||||||
|
+]
|
||||||
|
+keywords = ["classifiers"]
|
||||||
|
+
|
||||||
|
+[project.urls]
|
||||||
|
+Homepage = "https://github.com/pypa/trove-classifiers"
|
||||||
|
+
|
||||||
|
+[tool.setuptools]
|
||||||
|
+package-dir = {"" = "src"}
|
||||||
|
+include-package-data = false
|
||||||
|
+
|
||||||
|
+[tool.setuptools.packages.find]
|
||||||
|
+where = ["src"]
|
||||||
|
+namespaces = false
|
||||||
|
+
|
||||||
|
+[tool.setuptools.package-data]
|
||||||
|
+"*" = ["py.typed"]
|
||||||
|
+
|
||||||
|
[tool.mypy]
|
||||||
|
strict = true
|
||||||
|
warn_unreachable = true
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
deleted file mode 100644
|
||||||
|
index 826eac7..0000000
|
||||||
|
--- a/setup.py
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,33 +0,0 @@
|
||||||
|
-from io import open
|
||||||
|
-from os import path
|
||||||
|
-
|
||||||
|
-from setuptools import setup, find_packages
|
||||||
|
-
|
||||||
|
-here = path.abspath(path.dirname(__file__))
|
||||||
|
-
|
||||||
|
-# Get the long description from the README file
|
||||||
|
-with open(path.join(here, "README.md"), encoding="utf-8") as f:
|
||||||
|
- long_description = f.read()
|
||||||
|
-
|
||||||
|
-setup(
|
||||||
|
- name="trove-classifiers",
|
||||||
|
- description="Canonical source for classifiers on PyPI (pypi.org).",
|
||||||
|
- long_description=long_description,
|
||||||
|
- long_description_content_type="text/markdown",
|
||||||
|
- url="https://github.com/pypa/trove-classifiers",
|
||||||
|
- author="The PyPI Admins",
|
||||||
|
- author_email="admin@pypi.org",
|
||||||
|
- classifiers=[
|
||||||
|
- "Development Status :: 5 - Production/Stable",
|
||||||
|
- "Intended Audience :: Developers",
|
||||||
|
- "License :: OSI Approved :: Apache Software License",
|
||||||
|
- "Programming Language :: Python :: 3",
|
||||||
|
- "Typing :: Typed",
|
||||||
|
- ],
|
||||||
|
- keywords="classifiers",
|
||||||
|
- package_dir={"": "src"},
|
||||||
|
- packages=find_packages(where="src"),
|
||||||
|
- package_data={"": ["py.typed"]},
|
||||||
|
- use_calver=True,
|
||||||
|
- setup_requires=["calver"],
|
||||||
|
-)
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
@ -0,0 +1,101 @@
|
|||||||
|
Name: python-trove-classifiers
|
||||||
|
Version: 2023.10.18
|
||||||
|
Release: 4%{?dist}
|
||||||
|
Summary: Canonical source for classifiers on PyPI (pypi.org)
|
||||||
|
|
||||||
|
License: Apache-2.0
|
||||||
|
URL: https://github.com/pypa/trove-classifiers
|
||||||
|
Source: %{pypi_source trove-classifiers}
|
||||||
|
|
||||||
|
# Drop dependency on calver which is not packaged in Fedora.
|
||||||
|
# This patch is rebased version of upstream PR:
|
||||||
|
# https://github.com/pypa/trove-classifiers/pull/126/commits/809156bb35852bcaa1c753e0165f1814f2bcedf6
|
||||||
|
Patch: Move-to-PEP-621-declarative-metadata.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-pytest
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Canonical source for classifiers on PyPI.
|
||||||
|
Classifiers categorize projects per PEP 301. Use this package to validate
|
||||||
|
classifiers in packages for PyPI upload or download.
|
||||||
|
}
|
||||||
|
|
||||||
|
%description %_description
|
||||||
|
|
||||||
|
%package -n python3-trove-classifiers
|
||||||
|
Summary: %{summary}
|
||||||
|
|
||||||
|
%description -n python3-trove-classifiers %_description
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n trove-classifiers-%{version}
|
||||||
|
# Replace @@VERSION@@ with %%version
|
||||||
|
%writevars -f pyproject.toml version
|
||||||
|
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%pyproject_buildrequires
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%pyproject_wheel
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%pyproject_install
|
||||||
|
%pyproject_save_files trove_classifiers
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
%pytest
|
||||||
|
|
||||||
|
|
||||||
|
%files -n python3-trove-classifiers -f %{pyproject_files}
|
||||||
|
%doc README.*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Oct 25 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2023.10.18-4
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2023.10.18-4
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2023.10.18-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2023.10.18-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Oct 19 2023 Maxwell G <maxwell@gtmx.me> - 2023.10.18-1
|
||||||
|
- Update to 2023.10.18. Fixes rhbz#2244676.
|
||||||
|
|
||||||
|
* Wed Oct 4 2023 Maxwell G <maxwell@gtmx.me> - 2023.9.19-1
|
||||||
|
- Update to 2023.9.19. Fixes rhbz#2239555.
|
||||||
|
|
||||||
|
* Mon Aug 7 2023 Maxwell G <maxwell@gtmx.me> - 2023.8.7-1
|
||||||
|
- Update to 2023.8.7. Fixes rhbz#2229834.
|
||||||
|
|
||||||
|
* Thu Jul 27 2023 Maxwell G <maxwell@gtmx.me> - 2023.7.6-1
|
||||||
|
- Update to 2023.7.6. Fixes rhbz#2220945.
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2023.5.24-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 2023.5.24-2
|
||||||
|
- Rebuilt for Python 3.12
|
||||||
|
|
||||||
|
* Wed Jun 7 2023 Maxwell G <maxwell@gtmx.me> - 2023.5.24-1
|
||||||
|
- Update to 2023.5.24. Fixes rhbz#2189711.
|
||||||
|
|
||||||
|
* Wed Apr 26 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 2023.4.25-1
|
||||||
|
- Update to 2023.4.25
|
||||||
|
Fixes: rhbz#2177081
|
||||||
|
Fixes: rhbz#2187710
|
||||||
|
|
||||||
|
* Tue Feb 21 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 2023.2.20-1
|
||||||
|
Initial package
|
||||||
|
|
Loading…
Reference in new issue