i9ce
import/i9/python-trove-classifiers-2023.7.6-1.el9
commit
0d47e4f012
@ -0,0 +1 @@
|
|||||||
|
SOURCES/trove-classifiers-2023.7.6.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
c63e1722e3415ab9d75fecb40118ad00b65962f8 SOURCES/trove-classifiers-2023.7.6.tar.gz
|
@ -0,0 +1,36 @@
|
|||||||
|
From 96197a07e974275f75f7814169f9213e4cca0b7d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Maxwell G <maxwell@gtmx.me>
|
||||||
|
Date: Thu, 27 Jul 2023 16:12:03 +0000
|
||||||
|
Subject: [PATCH] setup.py: remove usage of unpackaged `calver`
|
||||||
|
|
||||||
|
---
|
||||||
|
pyproject.toml | 2 +-
|
||||||
|
setup.py | 3 +--
|
||||||
|
2 files changed, 2 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pyproject.toml b/pyproject.toml
|
||||||
|
index 05374a2..1e0fdcc 100644
|
||||||
|
--- a/pyproject.toml
|
||||||
|
+++ b/pyproject.toml
|
||||||
|
@@ -1,5 +1,5 @@
|
||||||
|
[build-system]
|
||||||
|
-requires = ["setuptools", "calver"]
|
||||||
|
+requires = ["setuptools"]
|
||||||
|
build-backend = "setuptools.build_meta"
|
||||||
|
|
||||||
|
[tool.mypy]
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 826eac7..1e5f12e 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -28,6 +28,5 @@ setup(
|
||||||
|
package_dir={"": "src"},
|
||||||
|
packages=find_packages(where="src"),
|
||||||
|
package_data={"": ["py.typed"]},
|
||||||
|
- use_calver=True,
|
||||||
|
- setup_requires=["calver"],
|
||||||
|
+ version="@@VERSION@@",
|
||||||
|
)
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -0,0 +1,81 @@
|
|||||||
|
Name: python-trove-classifiers
|
||||||
|
Version: 2023.7.6
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Canonical source for classifiers on PyPI (pypi.org)
|
||||||
|
|
||||||
|
License: Apache-2.0
|
||||||
|
URL: https://github.com/pypa/trove-classifiers
|
||||||
|
Source: %{pypi_source trove-classifiers}
|
||||||
|
|
||||||
|
# Drop dependency on calver which is not packaged in Fedora.
|
||||||
|
Patch: setup.py-remove-usage-of-unpackaged-calver.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-pytest
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Canonical source for classifiers on PyPI.
|
||||||
|
Classifiers categorize projects per PEP 301. Use this package to validate
|
||||||
|
classifiers in packages for PyPI upload or download.
|
||||||
|
}
|
||||||
|
|
||||||
|
%description %_description
|
||||||
|
|
||||||
|
%package -n python3-trove-classifiers
|
||||||
|
Summary: %{summary}
|
||||||
|
|
||||||
|
%description -n python3-trove-classifiers %_description
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n trove-classifiers-%{version}
|
||||||
|
# Replace @@VERSION@@ with %%version
|
||||||
|
%writevars -f setup.py version
|
||||||
|
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%pyproject_buildrequires
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%pyproject_wheel
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%pyproject_install
|
||||||
|
%pyproject_save_files trove_classifiers
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
%pytest
|
||||||
|
|
||||||
|
|
||||||
|
%files -n python3-trove-classifiers -f %{pyproject_files}
|
||||||
|
%doc README.*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Aug 24 2023 Sergey Cherevko <s.cherevko@msvsphere.ru> - 2023.7.6-1
|
||||||
|
- Rebuilt for MSVSphere 9.2
|
||||||
|
|
||||||
|
* Thu Jul 27 2023 Maxwell G <maxwell@gtmx.me> - 2023.7.6-1
|
||||||
|
- Update to 2023.7.6. Fixes rhbz#2220945.
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2023.5.24-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 2023.5.24-2
|
||||||
|
- Rebuilt for Python 3.12
|
||||||
|
|
||||||
|
* Wed Jun 7 2023 Maxwell G <maxwell@gtmx.me> - 2023.5.24-1
|
||||||
|
- Update to 2023.5.24. Fixes rhbz#2189711.
|
||||||
|
|
||||||
|
* Wed Apr 26 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 2023.4.25-1
|
||||||
|
- Update to 2023.4.25
|
||||||
|
Fixes: rhbz#2177081
|
||||||
|
Fixes: rhbz#2187710
|
||||||
|
|
||||||
|
* Tue Feb 21 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 2023.2.20-1
|
||||||
|
Initial package
|
||||||
|
|
Loading…
Reference in new issue