Initial import from EPEL 9 upstream

i9ce imports/i9c/python-service-identity-21.1.0-5.el9
Sergey Cherevko 2 years ago
commit ba2e8b5598
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/service-identity-21.1.0.tar.gz

@ -0,0 +1 @@
df09d7e64220f5485d3f4ac43e35fee217e83e8e SOURCES/service-identity-21.1.0.tar.gz

@ -0,0 +1,56 @@
From 18b24292779f8548198d3e4ada2e52d7669607e8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
Date: Mon, 24 May 2021 13:58:40 +0200
Subject: [PATCH] Revert theme change"
---
docs/conf.py | 11 +++++++++--
setup.py | 2 +--
2 files changed, 10 insertions(+), 3 deletions(-)
diff --git a/docs/conf.py b/docs/conf.py
index 1517620..e9745c6 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -117,7 +117,7 @@ exclude_patterns = ["_build"]
# show_authors = False
# The name of the Pygments (syntax highlighting) style to use.
-# pygments_style = "sphinx"
+pygments_style = "sphinx"
# A list of ignored prefixes for module index sorting.
# modindex_common_prefix = []
@@ -131,7 +131,14 @@ exclude_patterns = ["_build"]
# The theme to use for HTML and HTML Help pages. See the documentation for
# a list of builtin themes.
-html_theme = "furo"
+html_theme = "alabaster"
+html_theme_options = {
+ "font_family": '"Avenir Next", Calibri, "PT Sans", sans-serif',
+ "head_font_family": '"Avenir Next", Calibri, "PT Sans", sans-serif',
+ "font_size": "18px",
+ "page_width": "980px",
+ "show_relbars": True,
+}
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
diff --git a/setup.py b/setup.py
index 921725a..29012ef 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +46,7 @@ INSTALL_REQUIRES = [
EXTRAS_REQUIRE = {
"idna": ["idna"],
"tests": ["coverage[toml]>=5.0.2", "pytest"],
- "docs": ["sphinx", "furo"],
+ "docs": ["sphinx"],
}
EXTRAS_REQUIRE["dev"] = (
EXTRAS_REQUIRE["tests"] + EXTRAS_REQUIRE["docs"] + ["idna", "pyOpenSSL"]
--
2.31.1

@ -0,0 +1,187 @@
%bcond_without check
%global modname service-identity
Name: python-%{modname}
Version: 21.1.0
Release: 5%{?dist}
Summary: Service identity verification for pyOpenSSL
License: MIT
URL: https://github.com/pyca/service-identity
Source0: %{url}/archive/%{version}/%{modname}-%{version}.tar.gz
# Revert theme change as "furo" theme is not packaged
Patch0: 0001-Revert-theme-change.patch
BuildArch: noarch
%global common_description %{expand:
Use this package if you use pyOpenSSL and dont want to be MITMed, or if you
want to verify that a PyCA cryptography certificate is valid for a certain
hostname or IP address. service-identity aspires to give you all the tools you
need for verifying whether a certificate is valid for the intended purposes.
In the simplest case, this means host name verification. However,
service-identity implements RFC 6125 fully and plans to add other relevant RFCs
too.}
%description %{common_description}
%package -n python3-%{modname}
Summary: %{summary}
BuildRequires: python3-devel
BuildRequires: %{py3_dist sphinx}
%if %{with check}
BuildRequires: %{py3_dist pytest}
%endif
%description -n python3-%{modname} %{common_description}
%package -n python-%{modname}-doc
Summary: Service-identity documentation
%description -n python-%{modname}-doc
Documentation for service-identity.
%pyproject_extras_subpkg -n python3-%{modname} idna
%prep
%autosetup -p1 -n %{modname}-%{version}
%generate_buildrequires
%if %{with check}
%pyproject_buildrequires -x idna
%endif
%build
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files service_identity
# generate html docs
PYTHONPATH=%{buildroot}%{python3_sitelib} sphinx-build-3 docs html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}
%if %{with check}
%check
%pytest -v
%endif
%files -n python3-%{modname} -f %{pyproject_files}
%doc README.rst
%files -n python-%{modname}-doc
%doc html
%license LICENSE docs/license.rst
%changelog
* Fri Apr 28 2023 Sergey Cherevko <s.cherevko@msvsphere.ru> - 21.1.0-5
- Rebuilt for MSVSphere 9.1
* Fri Jan 28 2022 Carl George <carl@george.computer> - 21.1.0-5
- Add idna extras subpackage
- Switch to pyproject macros
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 21.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 21.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Thu Jun 03 2021 Python Maint <python-maint@redhat.com> - 21.1.0-2
- Rebuilt for Python 3.10
* Mon May 24 13:50:05 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 21.1.0-1
- Update to 21.1.0
- Close: rhbz#1958639
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 18.1.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 18.1.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 18.1.0-7
- Rebuilt for Python 3.9
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 18.1.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Mon Sep 09 2019 Miro Hrončok <mhroncok@redhat.com> - 18.1.0-5
- Subpackage python2-service-identity has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 18.1.0-4
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 18.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Wed Jul 03 2019 Miro Hrončok <mhroncok@redhat.com> - 18.1.0-2
- Rebuilt to update automatic Python dependencies
* Wed Apr 10 18:38:06 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 18.1.0-1
- Release 18.1.0 (#1454995)
- Fix FTBFS with pytest 4.3 (#1693822)
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 16.0.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.0.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Sun Jun 17 2018 Miro Hrončok <mhroncok@redhat.com> - 16.0.0-10
- Rebuilt for Python 3.7
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.0.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.0.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 16.0.0-6
- Rebuild for Python 3.6
* Mon Dec 19 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 16.0.0-5
- Modernize spec
* Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 16.0.0-4
- Enable tests
* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 16.0.0-3
- Rebuild for Python 3.6
- Disable python3 tests for now
* Mon Oct 17 2016 Tom Prince <tom.prince@twistedmatrix.com> - 16.0.0-2
- Use python3 to test python3 package.
- Fix dependencies.
* Mon Oct 17 2016 Tom Prince <tom.prince@twistedmatrix.com> - 16.0.0-1
- Update source URL for pypi migration. (#1361604)
- Build new version
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 14.0.0-5
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 14.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 14.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 14.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Thu Jan 22 2015 robyduck@fedoraproject.org - 14.0.0-1
- Build new version
* Sat Jul 12 2014 tom.prince@twistedmatrix.com - 1.0.0-2
- Add python-idna dependency.
* Sat Jul 12 2014 tom.prince@twistedmatrix.com - 1.0.0-1
- Initial package.
Loading…
Cancel
Save