commit
ee6da0a28f
@ -0,0 +1 @@
|
|||||||
|
SOURCES/referencing-0.31.1.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
695b0effb1a6a817562400bb2ed3ab86f807e7c1 SOURCES/referencing-0.31.1.tar.gz
|
@ -0,0 +1,33 @@
|
|||||||
|
From 20ea9c6ff9c334d76466f10cb97c93eb4b91672b Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Ond=C5=99ej=20Budai?= <ondrej@budai.cz>
|
||||||
|
Date: Wed, 26 Jun 2024 17:48:46 +0200
|
||||||
|
Subject: [PATCH] Remove hatch-vcs
|
||||||
|
|
||||||
|
It apparently has no effect on the built RPM (I checked manually),
|
||||||
|
so let's drop it from pyproject.toml, so we can remove it from RHEL.
|
||||||
|
---
|
||||||
|
pyproject.toml | 6 ++----
|
||||||
|
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pyproject.toml b/pyproject.toml
|
||||||
|
index c0044e7..91d5035 100644
|
||||||
|
--- a/pyproject.toml
|
||||||
|
+++ b/pyproject.toml
|
||||||
|
@@ -1,12 +1,10 @@
|
||||||
|
[build-system]
|
||||||
|
-requires = ["hatchling", "hatch-vcs"]
|
||||||
|
+requires = ["hatchling"]
|
||||||
|
build-backend = "hatchling.build"
|
||||||
|
|
||||||
|
-[tool.hatch.version]
|
||||||
|
-source = "vcs"
|
||||||
|
-
|
||||||
|
[project]
|
||||||
|
name = "referencing"
|
||||||
|
+version = "0.31.1"
|
||||||
|
description = "JSON Referencing + Python"
|
||||||
|
readme = "README.rst"
|
||||||
|
license = {text = "MIT"}
|
||||||
|
--
|
||||||
|
2.45.2
|
||||||
|
|
@ -0,0 +1,94 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.6.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 5;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
%global srcname referencing
|
||||||
|
|
||||||
|
Name: python-%{srcname}
|
||||||
|
Version: 0.31.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: An implementation-agnostic implementation of JSON reference resolution
|
||||||
|
License: MIT
|
||||||
|
URL: https://pypi.python.org/pypi/%{srcname}
|
||||||
|
Source: %{pypi_source referencing}
|
||||||
|
Patch0: 0001-Remove-hatch-vcs.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
|
||||||
|
# For tests
|
||||||
|
BuildRequires: python3dist(pytest)
|
||||||
|
BuildRequires: python3dist(pytest-subtests)
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
An implementation-agnostic implementation of JSON reference resolution.
|
||||||
|
In other words, a way for e.g. JSON Schema tooling to resolve the $ref
|
||||||
|
keyword across all drafts without needing to implement support themselves.}
|
||||||
|
|
||||||
|
%description %_description
|
||||||
|
|
||||||
|
|
||||||
|
%package -n python3-%{srcname}
|
||||||
|
Summary: %{summary}
|
||||||
|
|
||||||
|
%description -n python3-%{srcname} %_description
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{srcname}-%{version} -p1
|
||||||
|
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%pyproject_buildrequires
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%pyproject_wheel
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%pyproject_install
|
||||||
|
%pyproject_save_files %{srcname}
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
%pyproject_check_import -e referencing.tests*
|
||||||
|
%pytest referencing/tests
|
||||||
|
|
||||||
|
|
||||||
|
%files -n python3-%{srcname} -f %{pyproject_files}
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Wed Jun 26 2024 Ondřej Budai <ondrej@budai.cz> - 0.31.1-5
|
||||||
|
- Drop unneeded build dependencies
|
||||||
|
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 0.31.1-4
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.31.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.31.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 28 2023 Mattia Verga <mattia.verga@proton.me> - 0.31.1-1
|
||||||
|
- Update to 0.31.1
|
||||||
|
|
||||||
|
* Wed Nov 15 2023 Joel Capitao <jcapitao@redhat.com> - 0.31.0-1
|
||||||
|
- Update to 0.31.0 (close RHBZ#2249681)
|
||||||
|
|
||||||
|
* Sat Aug 05 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.30.2-1
|
||||||
|
- Update to 0.30.2 (close RHBZ#2229137)
|
||||||
|
|
||||||
|
* Wed Jul 26 2023 Mattia Verga <mattia.verga@proton.me> - 0.30.0-1
|
||||||
|
- Initial import (fedora#2223179)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue