Re-add the unit-tests

epel9
Pierre-Yves Chibon 13 years ago
parent 7584bd6ab7
commit 2f832ef623

@ -0,0 +1,37 @@
From 3e183cd71f8588a2b5d0958aa09d1b8dcb0eb86d Mon Sep 17 00:00:00 2001
From: Pierre-Yves Chibon <pingou@pingoured.fr>
Date: Tue, 24 Jan 2012 20:29:13 +0100
Subject: [PATCH] Skip test if it can not join the network
---
test/test_n3.py | 7 ++++++-
1 files changed, 6 insertions(+), 1 deletions(-)
diff --git a/test/test_n3.py b/test/test_n3.py
index 2fa54af..c419acf 100644
--- test/test_n3.py
+++ test/test_n3.py
@@ -60,6 +60,7 @@ n3:context a rdf:Property; rdfs:domain n3:statement;
import unittest
+from urllib2 import URLError
from rdflib.graph import Graph, ConjunctiveGraph
@@ -160,7 +161,11 @@ foo-bar:Ex foo-bar:name "Test" . """
def testParse(self):
g = ConjunctiveGraph()
- g.parse("http://groups.csail.mit.edu/dig/2005/09/rein/examples/troop42-policy.n3", format="n3")
+ try:
+ g.parse("http://groups.csail.mit.edu/dig/2005/09/rein/examples/troop42-policy.n3", format="n3")
+ except URLError:
+ from nose import SkipTest
+ raise SkipTest('No network to retrieve the information, skipping test')
cases = ['no quotes',
"single ' quote",
--
1.7.7.6

@ -1,22 +1,21 @@
# The upstream test suite does not pass on recent versions of Fedora
# See package review (bug 378841)
# For now, we disable running the test suite:
%define run_tests 0
%define run_tests 1
Name: python-rdflib
Version: 3.2.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Python library for working with RDF
Group: Development/Languages
License: BSD
URL: http://code.google.com/p/rdflib/
Source0: http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
Patch0: 0001-Skip-test-if-it-can-not-join-the-network.patch
BuildArch: noarch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
Requires: python-isodate
BuildRequires: python-isodate
BuildRequires: python-devel
%if 0%{?fedora} >= 8
BuildRequires: python-setuptools-devel
@ -40,6 +39,8 @@ memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
%prep
%setup -q -n rdflib-%{version}
%patch0 -p0 -b .test
%build
%{__python} setup.py build
@ -62,6 +63,7 @@ chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
%check
%if %{run_tests}
sed -i -e "s|'--with-doctest'|#'--with-doctest'|" run_tests.py
%{__python} run_tests.py
%endif
@ -74,6 +76,10 @@ rm -rf $RPM_BUILD_ROOT
%{python_sitelib}/*
%changelog
* Tue Jan 24 2012 Pierre-Yves Chibon <pingou@pingoured.fr> - 3.2.0-4
- Re-add the unittests, for that, patch one and disable the run of
the tests in the documentation of the code.
* Mon Jan 23 2012 Pierre-Yves Chibon <pingou@pingoured.fr> - 3.2.0-3
- Add python-isodate as R (RHBZ#784027)

Loading…
Cancel
Save