import python-pytest-cov-4.0.0-2.el9

i9ce changed/i9ce/python-pytest-cov-4.0.0-2.el9
MSVSphere Packaging Team 1 year ago
commit 26af7ad5f8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/pytest-cov-4.0.0.tar.gz

@ -0,0 +1 @@
e077203b376dc922fd5dfd0da79cd68304624b16 SOURCES/pytest-cov-4.0.0.tar.gz

@ -0,0 +1,12 @@
diff -up pytest-cov-3.0.0/tests/test_pytest_cov.py.cov62 pytest-cov-3.0.0/tests/test_pytest_cov.py
--- pytest-cov-3.0.0/tests/test_pytest_cov.py.cov62 2021-12-09 13:54:38.736407865 -0500
+++ pytest-cov-3.0.0/tests/test_pytest_cov.py 2021-12-09 13:54:41.432423997 -0500
@@ -968,7 +968,7 @@ def test_invalid_coverage_source(testdir
'*10 passed*'
])
result.stderr.fnmatch_lines([
- 'Coverage.py warning: No data was collected.*'
+ '*No data was collected.*'
])
result.stdout.fnmatch_lines([
'*Failed to generate report: No data to report.',

@ -0,0 +1,94 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 2;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
%global srcname pytest-cov
%global slugname pytest_cov
%global forgeurl https://github.com/pytest-dev/%{srcname}
%global common_description %{expand:
This plugin produces coverage reports. Compared to just using coverage run this
plugin does some extras:
• Subprocess support: you can fork or run stuff in a subprocess and will get
covered without any fuss.
• Xdist support: you can use all of pytest-xdists features and still get
coverage.
• Consistent pytest behavior. If you run coverage run -m pytest you will have
slightly different sys.path (CWD will be in it, unlike when running
pytest).
All features offered by the coverage package should work, either through
pytest-covs command line options or through coverages config file.
}
# During python mass rebuild we need to build python-pytest-cov without
# tests because some dependencies are not yet available
%bcond_without tests
Name: python-%{srcname}
Version: 4.0.0
%forgemeta
Release: %autorelease
Summary: Coverage plugin for pytest
License: MIT
URL: %{forgeurl}
Source: %{forgesource}
BuildArch: noarch
BuildRequires: python3-devel
BuildRequires: pyproject-rpm-macros
%description %{common_description}
%package -n python3-%{srcname}
Summary: %{summary}
%description -n python3-%{srcname} %{common_description}
%prep
%forgeautosetup -p1
# The “hunter” testing dependency (https://github.com/ionelmc/python-hunter) is
# not packaged, but it also does not seem to be used.
sed -r -i '/^[[:blank:]]*.hunter.,[[:blank:]]*$/d' setup.py
%generate_buildrequires
%pyproject_buildrequires -r %{?with_tests:-x testing}
%build
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files %{slugname}
%if %{with tests}
%check
k="$(awk 'NR>1 {pre=" and " } { printf "%snot %s", pre, $0 }' <<EOF
test_append_coverage_subprocess
test_central_subprocess
test_cleanup_on_sigterm
test_dist_missing_data
test_dist_subprocess_collocated
test_dist_subprocess_not_collocated
test_subprocess_with_path_aliasing
EOF
)"
%pytest -k "${k}"
%endif
%files -n python3-%{srcname} -f %{pyproject_files}
%license LICENSE
%doc *.rst
%{python3_sitelib}/%{srcname}.pth
%changelog
* Wed Jan 10 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.0.0-2
- Rebuilt for MSVSphere 9.3
* Thu Sep 29 2022 chedi toueiti <chedi.toueiti@gmail.com> 4.0.0-2
- RPMAUTOSPEC: unresolvable merge
Loading…
Cancel
Save