import python-pynacl-1.4.0-6.el9

i9ce changed/i9ce/python-pynacl-1.4.0-6.el9
Sergey Cherevko 6 months ago
commit 5531e6da81
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/pynacl-1.4.0.tar.gz

@ -0,0 +1 @@
e18c3803dd7944afd7b00c8c43c3c61fcb75136f SOURCES/pynacl-1.4.0.tar.gz

@ -0,0 +1,58 @@
From 1a14a865a27467914be183f5465c29b36fd27f88 Mon Sep 17 00:00:00 2001
From: Scott Kitterman <scott@kitterman.com>
Date: Tue, 26 May 2020 17:03:17 -0400
Subject: [PATCH 1/2] Remove spurious requirement for wheel
---
pyproject.toml | 1 -
setup.py | 3 +--
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index ed437acd..94baf50c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,7 +2,6 @@
# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
"setuptools>=40.8.0",
- "wheel",
"cffi>=1.4.1; python_implementation != 'PyPy'",
]
build-backend = "setuptools.build_meta"
diff --git a/setup.py b/setup.py
index 9319c1cb..d82a7fe3 100644
--- a/setup.py
+++ b/setup.py
@@ -35,8 +35,7 @@
requirements = ["six"]
-setup_requirements = ["setuptools",
- "wheel"]
+setup_requirements = ["setuptools"]
test_requirements = ["pytest>=3.2.1,!=3.3.0",
"hypothesis>=3.27.0"]
docs_requirements = ["sphinx>=1.6.5",
From 5eb5f1e70580a386d9a95b74eda1a54af13f5e3a Mon Sep 17 00:00:00 2001
From: Scott Kitterman <scott@kitterman.com>
Date: Tue, 26 May 2020 18:44:33 -0400
Subject: [PATCH 2/2] Put wheel back in pyproject.toml
---
pyproject.toml | 1 +
1 file changed, 1 insertion(+)
diff --git a/pyproject.toml b/pyproject.toml
index 94baf50c..ed437acd 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,6 +2,7 @@
# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
"setuptools>=40.8.0",
+ "wheel",
"cffi>=1.4.1; python_implementation != 'PyPy'",
]
build-backend = "setuptools.build_meta"

@ -0,0 +1,160 @@
%bcond_without check
%global modname pynacl
Name: python-%{modname}
Version: 1.4.0
Release: 6%{?dist}
Summary: Python binding to the Networking and Cryptography (NaCl) library
License: ASL 2.0
URL: https://github.com/pyca/pynacl
Source0: %{url}/archive/%{version}/%{modname}-%{version}.tar.gz
# remove spurious wheel dependency
Patch1: %{url}/pull/596.patch
BuildRequires: gcc
BuildRequires: libsodium-devel
%global _description %{expand:
PyNaCl is a Python binding to the Networking and Cryptography library,
a crypto library with the stated goal of improving usability, security
and speed.}
%description %{_description}
%package -n python3-%{modname}
Summary: %{summary}
BuildRequires: python3-devel
%description -n python3-%{modname} %{_description}
Python 3 version.
%prep
%autosetup -p1 -n %{modname}-%{version}
# Remove bundled libsodium, to be sure
rm -vrf src/libsodium/
# ARM and s390x is too slow for upstream tests
# See https://bugzilla.redhat.com/show_bug.cgi?id=1594901
# And https://github.com/pyca/pynacl/issues/370
%ifarch s390x %{arm}
sed -i 's/@settings(deadline=1500, max_examples=5)/@settings(deadline=4000, max_examples=5)/' tests/test_pwhash.py
%endif
%generate_buildrequires
%pyproject_buildrequires %{?with_check:-x tests}
%build
export SODIUM_INSTALL=system
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files nacl
%check
%if %{with check}
%pytest
%else
%pyproject_check_import
%endif
%files -n python3-%{modname} -f %{pyproject_files}
%doc README.rst
%changelog
* Tue Jul 30 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 1.4.0-6
- Rebuilt for MSVSphere 9.4
* Wed May 11 2022 Carl George <carl@george.computer> - 1.4.0-6
- Convert to pyproject macros
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 1.4.0-3
- Rebuilt for Python 3.10
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Aug 26 2020 Damien Ciabrini <dciabrin@redhat.com> - 1.4.0-1
- Update to 1.4.0 (#1840424)
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sun May 24 2020 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-8
- Rebuilt for Python 3.9
* Mon May 11 2020 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-7
- Fix build with hypothesis 5 (#1830961)
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sun Oct 13 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-5
- Subpackage python2-pynacl has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-4
- Rebuilt for Python 3.8.0rc1 (#1748018)
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-3
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 15 2019 Yatin Karel <ykarel@redhat.com> - 1.3.0-1
- Update to 1.3.0
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.1-2
- Rebuilt for Python 3.7
- Prolong the deadline for tests on s390x
- Don't ignore the test results on arm, do the same as on s390x
* Tue Mar 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Nov 02 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0
* Mon Oct 02 2017 Remi Collet <remi@fedoraproject.org> - 1.1.2-4
- rebuild for libsodium
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Apr 01 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.1.2-1
- Update to 1.1.2
* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.1.1-1
- Update to 1.1.1
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-2
- Rebuild for Python 3.6
* Mon Dec 19 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.0.1-1
- Initial package
Loading…
Cancel
Save