import python-pynacl-1.5.0-10.el10

i10ce changed/i10ce/python-pynacl-1.5.0-10.el10
Arkady L. Shane 1 month ago
parent 1d2ba56581
commit 48abfeea0a
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/pynacl-1.3.0.tar.gz SOURCES/pynacl-1.5.0.tar.gz

@ -1 +1 @@
f0b09d0168e8f6fbefb0cff0d6eb26ae484bee4e SOURCES/pynacl-1.3.0.tar.gz 716e2e60c0b4695cb47b2e57275239175dc46578 SOURCES/pynacl-1.5.0.tar.gz

@ -1,29 +0,0 @@
From af2d8c241872318baba42d7f5fbfb1869de91baa Mon Sep 17 00:00:00 2001
From: Valentin Heidelberger <github@valentinsblog.com>
Date: Thu, 27 Sep 2018 22:36:34 +0200
Subject: [PATCH] Remove average_size hypothesis setting from test_bindings.py
---
tests/test_bindings.py | 2 --
1 file changed, 2 deletions(-)
diff --git a/tests/test_bindings.py b/tests/test_bindings.py
index 22930cc7..d7951a21 100644
--- a/tests/test_bindings.py
+++ b/tests/test_bindings.py
@@ -306,7 +306,6 @@ def test_unpad_not_padded():
@given(binary(min_size=0,
- average_size=128,
max_size=2049),
integers(min_value=16,
max_value=256)
@@ -320,7 +319,6 @@ def test_pad_sizes(msg, bl_sz):
@given(binary(min_size=0,
- average_size=128,
max_size=2049),
integers(min_value=16,
max_value=256)

@ -1,42 +1,30 @@
%{?python_enable_dependency_generator}
%bcond_without check %bcond_without check
%global modname pynacl %global modname pynacl
Name: python-%{modname} Name: python-%{modname}
Version: 1.3.0 Version: 1.5.0
Release: 5%{?dist} Release: 10%{?dist}
Summary: Python binding to the Networking and Cryptography (NaCl) library Summary: Python binding to the Networking and Cryptography (NaCl) library
License: ASL 2.0 # Automatically converted from old format: ASL 2.0 - review is highly recommended.
License: Apache-2.0
URL: https://github.com/pyca/pynacl URL: https://github.com/pyca/pynacl
Source0: %{url}/archive/%{version}/%{modname}-%{version}.tar.gz Source0: %{url}/archive/%{version}/%{modname}-%{version}.tar.gz
# hypothesis 4 support
Patch1: %{url}/pull/480.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: libsodium-devel BuildRequires: libsodium-devel
BuildRequires: sed
%global _description \ %global _description %{expand:
PyNaCl is a Python binding to the Networking and Cryptography library,\ PyNaCl is a Python binding to the Networking and Cryptography library,
a crypto library with the stated goal of improving usability, security\ a crypto library with the stated goal of improving usability, security
and speed. and speed.}
%description %{_description} %description %{_description}
%package -n python3-%{modname} %package -n python3-%{modname}
Summary: %{summary} Summary: %{summary}
%{?python_provide:%python_provide python3-%{modname}}
BuildRequires: python3-devel BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-cffi >= 1.4.1
%if %{with check}
BuildRequires: python3-six
BuildRequires: python3-pytest >= 3.2.1
BuildRequires: python3-hypothesis >= 3.27.0
%endif
%description -n python3-%{modname} %{_description} %description -n python3-%{modname} %{_description}
@ -54,30 +42,100 @@ rm -vrf src/libsodium/
sed -i 's/@settings(deadline=1500, max_examples=5)/@settings(deadline=4000, max_examples=5)/' tests/test_pwhash.py sed -i 's/@settings(deadline=1500, max_examples=5)/@settings(deadline=4000, max_examples=5)/' tests/test_pwhash.py
%endif %endif
%generate_buildrequires
%pyproject_buildrequires %{?with_check:-x tests}
%build %build
export SODIUM_INSTALL=system export SODIUM_INSTALL=system
%py3_build %pyproject_wheel
%install %install
%py3_install %pyproject_install
%pyproject_save_files nacl
%if %{with check}
%check %check
PYTHONPATH=%{buildroot}%{python3_sitearch} py.test-3 -v %if %{with check}
%pytest
%else
%pyproject_check_import
%endif %endif
%files -n python3-%{modname} %files -n python3-%{modname} -f %{pyproject_files}
%license LICENSE
%doc README.rst %doc README.rst
%{python3_sitearch}/PyNaCl-*.egg-info/
%{python3_sitearch}/nacl/
%changelog %changelog
* Fri Jul 12 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.3.0-5 * Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.5.0-10
- Rebuilt for MSVSphere 8.10 - Rebuilt for MSVSphere 10
* Wed Jul 24 2024 Miroslav Suchý <msuchy@redhat.com> - 1.5.0-10
- convert license to SPDX
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 1.5.0-8
- Rebuilt for Python 3.13
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Oct 05 2023 Remi Collet <remi@remirepo.net> - 1.5.0-5
- rebuild for new libsodium
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Thu Jun 15 2023 Python Maint <python-maint@redhat.com> - 1.5.0-3
- Rebuilt for Python 3.12
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Wed Aug 31 2022 Major Hayden <major@mhtx.net> - 1.5.0-1
- Update to 1.5.0 (#2038614)
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 1.4.0-7
- Rebuilt for Python 3.11
* Wed May 11 2022 Carl George <carl@george.computer> - 1.4.0-6
- Convert to pyproject macros
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 1.4.0-3
- Rebuilt for Python 3.10
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Aug 26 2020 Damien Ciabrini <dciabrin@redhat.com> - 1.4.0-1
- Update to 1.4.0 (#1840424)
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sun May 24 2020 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-8
- Rebuilt for Python 3.9
* Mon May 11 2020 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-7
- Fix build with hypothesis 5 (#1830961)
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Oct 11 2019 Paul Howarth <paul@city-fan.org> - 1.3.0-5 * Sun Oct 13 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-5
- Drop Python 2 support - Subpackage python2-pynacl has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-4 * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.0-4
- Rebuilt for Python 3.8.0rc1 (#1748018) - Rebuilt for Python 3.8.0rc1 (#1748018)

Loading…
Cancel
Save