parent
ad3d189698
commit
50df1dcf9d
@ -1 +1 @@
|
|||||||
SOURCES/pycryptodomex-3.14.0.tar.gz
|
SOURCES/pycryptodomex-3.20.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
c5208148bc6ad94577d0f982f664e7315817ff14 SOURCES/pycryptodomex-3.14.0.tar.gz
|
97e5ce536f285a91835d8df3a25dea711757e7ef SOURCES/pycryptodomex-3.20.0.tar.gz
|
||||||
|
@ -0,0 +1,3 @@
|
|||||||
|
# python-pycryptodomex
|
||||||
|
|
||||||
|
The python-pycryptodomex package
|
@ -1,21 +0,0 @@
|
|||||||
diff -up ./Doc/conf.py.bak ./Doc/conf.py
|
|
||||||
--- ./Doc/conf.py.bak 2021-07-05 08:16:40.083571171 +0000
|
|
||||||
+++ ./Doc/conf.py 2021-07-05 08:17:17.754162806 +0000
|
|
||||||
@@ -15,7 +15,7 @@ import sys, os
|
|
||||||
|
|
||||||
# Modules to document with autodoc are in another directory
|
|
||||||
sys.path.insert(0, os.path.abspath('../lib'))
|
|
||||||
-print sys.path
|
|
||||||
+print(sys.path)
|
|
||||||
|
|
||||||
# Mock existence of native modules
|
|
||||||
from Crypto.Util import _raw_api
|
|
||||||
@@ -155,7 +155,7 @@ html_static_path = ['_static']
|
|
||||||
# Ensure that text wrapping works in a table, by overring some CSS.
|
|
||||||
# See https://github.com/rtfd/sphinx_rtd_theme/issues/117
|
|
||||||
def setup(app):
|
|
||||||
- app.add_stylesheet('theme_overrides.css')
|
|
||||||
+ app.add_css_file('theme_overrides.css')
|
|
||||||
|
|
||||||
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
|
|
||||||
# using the given strftime format.
|
|
@ -1,37 +1,30 @@
|
|||||||
diff -up ./setup.py.bak ./setup.py
|
diff -up ./setup.py.bak ./setup.py
|
||||||
--- ./setup.py.bak 2021-02-08 22:14:54.000000000 +0100
|
--- ./setup.py.bak 2022-06-22 20:21:37.000000000 +0200
|
||||||
+++ ./setup.py 2021-02-09 15:55:53.785892041 +0100
|
+++ ./setup.py 2022-06-23 11:09:44.260182023 +0200
|
||||||
@@ -367,12 +367,14 @@ ext_modules = [
|
@@ -369,10 +369,12 @@ ext_modules = [
|
||||||
sources=["src/CAST.c"],
|
|
||||||
py_limited_api=True),
|
|
||||||
Extension("Crypto.Cipher._raw_des",
|
Extension("Crypto.Cipher._raw_des",
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
include_dirs=['src/', 'src/libtom/'],
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/DES.c"],
|
sources=["src/DES.c"],
|
||||||
+ extra_link_args=["-ltomcrypt"],
|
+ extra_link_args=["-ltomcrypt"],
|
||||||
py_limited_api=True),
|
py_limited_api=True),
|
||||||
Extension("Crypto.Cipher._raw_des3",
|
Extension("Crypto.Cipher._raw_des3",
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
include_dirs=['src/', 'src/libtom/'],
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/DES3.c"],
|
sources=["src/DES3.c"],
|
||||||
+ extra_link_args=["-ltomcrypt"],
|
+ extra_link_args=["-ltomcrypt"],
|
||||||
py_limited_api=True),
|
py_limited_api=True),
|
||||||
Extension("Crypto.Util._cpuid_c",
|
Extension("Crypto.Util._cpuid_c",
|
||||||
include_dirs=['src/'],
|
include_dirs=['src/'],
|
||||||
@@ -410,8 +412,9 @@ ext_modules = [
|
@@ -417,6 +419,7 @@ ext_modules = [
|
||||||
sources=["src/ARC4.c"],
|
|
||||||
py_limited_api=True),
|
|
||||||
Extension("Crypto.Cipher._Salsa20",
|
Extension("Crypto.Cipher._Salsa20",
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
include_dirs=['src/', 'src/libtom/'],
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/Salsa20.c"],
|
sources=["src/Salsa20.c"],
|
||||||
+ extra_link_args=["-ltomcrypt"],
|
+ extra_link_args=["-ltomcrypt"],
|
||||||
py_limited_api=True),
|
py_limited_api=True),
|
||||||
Extension("Crypto.Cipher._chacha20",
|
Extension("Crypto.Cipher._chacha20",
|
||||||
include_dirs=['src/'],
|
include_dirs=['src/'],
|
||||||
diff -up ./src/DES.c.bak ./src/DES.c
|
diff -up ./src/DES.c.bak ./src/DES.c
|
||||||
--- ./src/DES.c.bak 2021-02-08 22:14:54.000000000 +0100
|
--- ./src/DES.c.bak 2022-06-22 20:21:37.000000000 +0200
|
||||||
+++ ./src/DES.c 2021-02-09 15:55:53.785892041 +0100
|
+++ ./src/DES.c 2022-06-23 11:10:58.166711358 +0200
|
||||||
@@ -39,7 +39,7 @@ FAKE_INIT(raw_des3)
|
@@ -39,7 +39,7 @@ FAKE_INIT(raw_des3)
|
||||||
|
|
||||||
/* Include the actial DES implementation */
|
/* Include the actial DES implementation */
|
Loading…
Reference in new issue