|
|
|
@ -1,6 +1,6 @@
|
|
|
|
|
diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
--- Pillow-9.4.0/setup.py 2023-01-02 00:29:07.000000000 +0100
|
|
|
|
|
+++ Pillow-9.4.0-new/setup.py 2023-01-02 10:44:32.109518818 +0100
|
|
|
|
|
diff -rupN --no-dereference Pillow-9.5.0/setup.py Pillow-9.5.0-new/setup.py
|
|
|
|
|
--- Pillow-9.5.0/setup.py 2023-04-01 09:49:41.000000000 +0200
|
|
|
|
|
+++ Pillow-9.5.0-new/setup.py 2023-04-03 09:25:21.948393861 +0200
|
|
|
|
|
@@ -135,7 +135,7 @@ class RequiredDependencyException(Except
|
|
|
|
|
pass
|
|
|
|
|
|
|
|
|
@ -10,7 +10,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
PLATFORM_PYPY = hasattr(sys, "pypy_version_info")
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
@@ -501,7 +501,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -504,7 +504,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
#
|
|
|
|
|
# add platform directories
|
|
|
|
|
|
|
|
|
@ -19,7 +19,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
pass
|
|
|
|
|
|
|
|
|
|
elif sys.platform == "cygwin":
|
|
|
|
|
@@ -593,7 +593,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -594,7 +594,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
# FIXME: check /opt/stuff directories here?
|
|
|
|
|
|
|
|
|
|
# standard locations
|
|
|
|
@ -28,7 +28,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
_add_directory(library_dirs, "/usr/local/lib")
|
|
|
|
|
_add_directory(include_dirs, "/usr/local/include")
|
|
|
|
|
|
|
|
|
|
@@ -839,7 +839,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -840,7 +840,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
if feature.xcb:
|
|
|
|
|
libs.append(feature.xcb)
|
|
|
|
|
defs.append(("HAVE_XCB", None))
|
|
|
|
@ -37,7 +37,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
libs.extend(["kernel32", "user32", "gdi32"])
|
|
|
|
|
if struct.unpack("h", b"\0\1")[0] == 1:
|
|
|
|
|
defs.append(("WORDS_BIGENDIAN", None))
|
|
|
|
|
@@ -861,6 +861,8 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -862,6 +862,8 @@ class pil_build_ext(build_ext):
|
|
|
|
|
if feature.freetype:
|
|
|
|
|
srcs = []
|
|
|
|
|
libs = ["freetype"]
|
|
|
|
@ -46,7 +46,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
defs = []
|
|
|
|
|
if feature.raqm:
|
|
|
|
|
if not feature.want_vendor("raqm"): # using system Raqm
|
|
|
|
|
@@ -883,7 +885,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -884,7 +886,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
|
|
|
|
|
if feature.lcms:
|
|
|
|
|
extra = []
|
|
|
|
@ -55,7 +55,7 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
extra.extend(["user32", "gdi32"])
|
|
|
|
|
self._update_extension("PIL._imagingcms", [feature.lcms] + extra)
|
|
|
|
|
else:
|
|
|
|
|
@@ -902,7 +904,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
@@ -903,7 +905,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
else:
|
|
|
|
|
self._remove_extension("PIL._webp")
|
|
|
|
|
|
|
|
|
@ -64,9 +64,9 @@ diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
|
|
|
|
self._update_extension("PIL._imagingtk", tk_libs)
|
|
|
|
|
|
|
|
|
|
build_ext.build_extensions(self)
|
|
|
|
|
diff -rupN --no-dereference Pillow-9.4.0/src/libImaging/ImPlatform.h Pillow-9.4.0-new/src/libImaging/ImPlatform.h
|
|
|
|
|
--- Pillow-9.4.0/src/libImaging/ImPlatform.h 2023-01-02 00:29:07.000000000 +0100
|
|
|
|
|
+++ Pillow-9.4.0-new/src/libImaging/ImPlatform.h 2023-01-02 10:44:32.109518818 +0100
|
|
|
|
|
diff -rupN --no-dereference Pillow-9.5.0/src/libImaging/ImPlatform.h Pillow-9.5.0-new/src/libImaging/ImPlatform.h
|
|
|
|
|
--- Pillow-9.5.0/src/libImaging/ImPlatform.h 2023-04-01 09:49:41.000000000 +0200
|
|
|
|
|
+++ Pillow-9.5.0-new/src/libImaging/ImPlatform.h 2023-04-03 09:25:21.949393602 +0200
|
|
|
|
|
@@ -28,7 +28,7 @@
|
|
|
|
|
#if defined(_WIN32) || defined(__CYGWIN__)
|
|
|
|
|
|
|
|
|
|