|
|
@ -1,6 +1,6 @@
|
|
|
|
diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
diff -rupN --no-dereference Pillow-9.2.0/setup.py Pillow-9.2.0-new/setup.py
|
|
|
|
--- Pillow-9.1.1/setup.py 2022-05-17 12:33:52.000000000 +0200
|
|
|
|
--- Pillow-9.2.0/setup.py 2022-07-01 15:19:51.000000000 +0200
|
|
|
|
+++ Pillow-9.1.1-new/setup.py 2022-05-20 23:52:00.467965674 +0200
|
|
|
|
+++ Pillow-9.2.0-new/setup.py 2022-07-20 16:40:23.805366371 +0200
|
|
|
|
@@ -135,7 +135,7 @@ class RequiredDependencyException(Except
|
|
|
|
@@ -135,7 +135,7 @@ class RequiredDependencyException(Except
|
|
|
|
pass
|
|
|
|
pass
|
|
|
|
|
|
|
|
|
|
|
@ -10,7 +10,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
PLATFORM_PYPY = hasattr(sys, "pypy_version_info")
|
|
|
|
PLATFORM_PYPY = hasattr(sys, "pypy_version_info")
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
@@ -497,7 +497,7 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -503,7 +503,7 @@ class pil_build_ext(build_ext):
|
|
|
|
#
|
|
|
|
#
|
|
|
|
# add platform directories
|
|
|
|
# add platform directories
|
|
|
|
|
|
|
|
|
|
|
@ -19,7 +19,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
pass
|
|
|
|
pass
|
|
|
|
|
|
|
|
|
|
|
|
elif sys.platform == "cygwin":
|
|
|
|
elif sys.platform == "cygwin":
|
|
|
|
@@ -589,7 +589,7 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -595,7 +595,7 @@ class pil_build_ext(build_ext):
|
|
|
|
# FIXME: check /opt/stuff directories here?
|
|
|
|
# FIXME: check /opt/stuff directories here?
|
|
|
|
|
|
|
|
|
|
|
|
# standard locations
|
|
|
|
# standard locations
|
|
|
@ -28,7 +28,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
_add_directory(library_dirs, "/usr/local/lib")
|
|
|
|
_add_directory(library_dirs, "/usr/local/lib")
|
|
|
|
_add_directory(include_dirs, "/usr/local/include")
|
|
|
|
_add_directory(include_dirs, "/usr/local/include")
|
|
|
|
|
|
|
|
|
|
|
|
@@ -835,7 +835,7 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -841,7 +841,7 @@ class pil_build_ext(build_ext):
|
|
|
|
if feature.xcb:
|
|
|
|
if feature.xcb:
|
|
|
|
libs.append(feature.xcb)
|
|
|
|
libs.append(feature.xcb)
|
|
|
|
defs.append(("HAVE_XCB", None))
|
|
|
|
defs.append(("HAVE_XCB", None))
|
|
|
@ -37,7 +37,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
libs.extend(["kernel32", "user32", "gdi32"])
|
|
|
|
libs.extend(["kernel32", "user32", "gdi32"])
|
|
|
|
if struct.unpack("h", b"\0\1")[0] == 1:
|
|
|
|
if struct.unpack("h", b"\0\1")[0] == 1:
|
|
|
|
defs.append(("WORDS_BIGENDIAN", None))
|
|
|
|
defs.append(("WORDS_BIGENDIAN", None))
|
|
|
|
@@ -857,6 +857,8 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -863,6 +863,8 @@ class pil_build_ext(build_ext):
|
|
|
|
if feature.freetype:
|
|
|
|
if feature.freetype:
|
|
|
|
srcs = []
|
|
|
|
srcs = []
|
|
|
|
libs = ["freetype"]
|
|
|
|
libs = ["freetype"]
|
|
|
@ -46,7 +46,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
defs = []
|
|
|
|
defs = []
|
|
|
|
if feature.raqm:
|
|
|
|
if feature.raqm:
|
|
|
|
if not feature.want_vendor("raqm"): # using system Raqm
|
|
|
|
if not feature.want_vendor("raqm"): # using system Raqm
|
|
|
|
@@ -879,7 +881,7 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -885,7 +887,7 @@ class pil_build_ext(build_ext):
|
|
|
|
|
|
|
|
|
|
|
|
if feature.lcms:
|
|
|
|
if feature.lcms:
|
|
|
|
extra = []
|
|
|
|
extra = []
|
|
|
@ -55,7 +55,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
extra.extend(["user32", "gdi32"])
|
|
|
|
extra.extend(["user32", "gdi32"])
|
|
|
|
self._update_extension("PIL._imagingcms", [feature.lcms] + extra)
|
|
|
|
self._update_extension("PIL._imagingcms", [feature.lcms] + extra)
|
|
|
|
else:
|
|
|
|
else:
|
|
|
|
@@ -898,7 +900,7 @@ class pil_build_ext(build_ext):
|
|
|
|
@@ -904,7 +906,7 @@ class pil_build_ext(build_ext):
|
|
|
|
else:
|
|
|
|
else:
|
|
|
|
self._remove_extension("PIL._webp")
|
|
|
|
self._remove_extension("PIL._webp")
|
|
|
|
|
|
|
|
|
|
|
@ -64,9 +64,9 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
|
|
|
self._update_extension("PIL._imagingtk", tk_libs)
|
|
|
|
self._update_extension("PIL._imagingtk", tk_libs)
|
|
|
|
|
|
|
|
|
|
|
|
build_ext.build_extensions(self)
|
|
|
|
build_ext.build_extensions(self)
|
|
|
|
diff -rupN --no-dereference Pillow-9.1.1/src/libImaging/ImPlatform.h Pillow-9.1.1-new/src/libImaging/ImPlatform.h
|
|
|
|
diff -rupN --no-dereference Pillow-9.2.0/src/libImaging/ImPlatform.h Pillow-9.2.0-new/src/libImaging/ImPlatform.h
|
|
|
|
--- Pillow-9.1.1/src/libImaging/ImPlatform.h 2022-05-17 12:33:52.000000000 +0200
|
|
|
|
--- Pillow-9.2.0/src/libImaging/ImPlatform.h 2022-07-01 15:19:51.000000000 +0200
|
|
|
|
+++ Pillow-9.1.1-new/src/libImaging/ImPlatform.h 2022-05-20 23:52:00.468965741 +0200
|
|
|
|
+++ Pillow-9.2.0-new/src/libImaging/ImPlatform.h 2022-07-20 16:40:23.806366371 +0200
|
|
|
|
@@ -28,7 +28,7 @@
|
|
|
|
@@ -28,7 +28,7 @@
|
|
|
|
#if defined(_WIN32) || defined(__CYGWIN__)
|
|
|
|
#if defined(_WIN32) || defined(__CYGWIN__)
|
|
|
|
|
|
|
|
|
|
|
|