Update for EPEL9

epel9
Adrien Vergé 3 years ago
commit 4f0a3c5d8e

2
.gitignore vendored

@ -1 +1 @@
/pathspec-0.6.0.tar.gz /pathspec-0.9.0.tar.gz

@ -0,0 +1,27 @@
From 46bad125f2d599a409704b6c1dcda47b709b4aec Mon Sep 17 00:00:00 2001
From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
Date: Sun, 10 Oct 2021 08:19:25 +0000
Subject: [PATCH] Refactor deprecated unittest aliases for Python 3.11
compatibility.
---
pathspec/tests/test_gitwildmatch.py | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/pathspec/tests/test_gitwildmatch.py b/pathspec/tests/test_gitwildmatch.py
index 9868381..f9b4b66 100644
--- a/pathspec/tests/test_gitwildmatch.py
+++ b/pathspec/tests/test_gitwildmatch.py
@@ -543,6 +543,11 @@ def test_09_single_exclamation_mark_fail(self):
def _check_invalid_pattern(self, git_ignore_pattern):
expected_message_pattern = re.escape(repr(git_ignore_pattern))
- with self.assertRaisesRegexp(GitWildMatchPatternError, expected_message_pattern):
+ # assertRaisesRegexp was a deprecated alias removed in Python 3.11
+ if hasattr(self, 'assertRaisesRegex'):
+ assertRaisesRegex = self.assertRaisesRegex
+ else:
+ assertRaisesRegex = self.assertRaisesRegexp
+ with assertRaisesRegex(GitWildMatchPatternError, expected_message_pattern):
GitWildMatchPattern(git_ignore_pattern)

@ -1,7 +1,8 @@
Name: python-pathspec Name: python%{python3_pkgversion}-pathspec
Version: 0.6.0 Version: 0.9.0
Release: 1%{?dist} Release: 1%{?dist}
Summary: Utility library for gitignore style pattern matching of file paths Summary: Utility library for gitignore style pattern matching of file paths
License: MPL 2.0 License: MPL 2.0
URL: https://github.com/cpburnz/python-path-specification URL: https://github.com/cpburnz/python-path-specification
Source0: https://files.pythonhosted.org/packages/source/p/pathspec/pathspec-%{version}.tar.gz Source0: https://files.pythonhosted.org/packages/source/p/pathspec/pathspec-%{version}.tar.gz
@ -12,66 +13,71 @@ Path Specification (pathspec) is a utility library for pattern matching of file
paths. So far this only includes Git's wildmatch pattern matching which itself paths. So far this only includes Git's wildmatch pattern matching which itself
is derived from Rsync's wildmatch. Git uses wildmatch for its gitignore files. is derived from Rsync's wildmatch. Git uses wildmatch for its gitignore files.
%package -n python2-pathspec
Summary: %{summary}
BuildRequires: python2-devel
BuildRequires: python2-setuptools
%{?python_provide:%python_provide python2-pathspec}
%description -n python2-pathspec
Path Specification (pathspec) is a utility library for pattern matching of file
paths. So far this only includes Git's wildmatch pattern matching which itself
is derived from Rsync's wildmatch. Git uses wildmatch for its gitignore files.
%package -n python%{python3_pkgversion}-pathspec
Summary: %{summary}
BuildRequires: python%{python3_pkgversion}-devel BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools BuildRequires: python%{python3_pkgversion}-setuptools
%{?python_provide:%python_provide python%{python3_pkgversion}-pathspec} %{?python_provide:%python_provide python%{python3_pkgversion}-pathspec}
%description -n python%{python3_pkgversion}-pathspec
Path Specification (pathspec) is a utility library for pattern matching of file
paths. So far this only includes Git's wildmatch pattern matching which itself
is derived from Rsync's wildmatch. Git uses wildmatch for its gitignore files.
%prep %prep
%autosetup -n pathspec-%{version} %autosetup -n pathspec-%{version}
# Remove bundled egg-info # Remove bundled egg-info
rm -rf pathspec.egg-info rm -rf pathspec.egg-info
%build %build
%py2_build
%py3_build %py3_build
%install %install
%py2_install
%py3_install %py3_install
%check %check
%{__python2} setup.py test
%{__python3} setup.py test %{__python3} setup.py test
%files -n python2-pathspec
%doc README.rst
%license LICENSE
%{python2_sitelib}/pathspec
%{python2_sitelib}/pathspec-%{version}-py?.?.egg-info
%files -n python%{python3_pkgversion}-pathspec %files
%doc README.rst %doc README.rst
%license LICENSE %license LICENSE
%{python3_sitelib}/pathspec %{python3_sitelib}/pathspec
%{python3_sitelib}/pathspec-%{version}-py?.?.egg-info %{python3_sitelib}/pathspec-%{version}-py%{python3_version}.egg-info
%changelog %changelog
* Fri Dec 17 2021 Adrien Vergé <adrienverge@gmail.com> - 0.9.0-1
- Update to version 0.9.0
- Prepare for EPEL9
* Tue Oct 15 2019 Adrien Vergé <adrienverge@gmail.com> - 0.6.0-1 * Tue Oct 15 2019 Adrien Vergé <adrienverge@gmail.com> - 0.6.0-1
- Update to latest upstream version - Update to latest upstream version
- Adapt for EPEL 8 and Python 2/3 support
* Fri Mar 08 2019 Troy Dawson <tdawson@redhat.com> - 0.5.3-2 * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.5.3-11
- Rebuilt to change main python from 3.4 to 3.6 - Rebuilt for Python 3.8.0rc1 (#1748018)
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.5.3-10
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Oct 11 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.5.3-7
- Python2 binary package has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.5.3-5
- Rebuilt for Python 3.7
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.5.3-3
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Jul 7 2017 Adrien Vergé <adrienverge@gmail.com> - 0.5.3-1 * Fri Jul 7 2017 Adrien Vergé <adrienverge@gmail.com> - 0.5.3-1
- Update to latest upstream version - Update to latest upstream version

@ -1 +1 @@
SHA512 (pathspec-0.6.0.tar.gz) = e08baa05a3fe58ec6ecd651577834115cdeef26b75eef274d843c3c6444cf771e86f99a2a2b2980a6d1ece946997f1ebe714f79ddd5c296071c2e18b73955a84 SHA512 (pathspec-0.9.0.tar.gz) = 660f13525325c27b598048a3576fd704c3843e0b07770187d005f0e93996a90cee44e9a0725b6bf775982f586ed3b4ba7cccee966d7149e71e2b95d48030b2f2

Loading…
Cancel
Save