import python-mock-4.0.3-17.el10

i10ce changed/i10ce/python-mock-4.0.3-17.el10
Arkady L. Shane 1 week ago
parent 38ed6e4c59
commit fe9b8434dd
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/mock-2.0.0.tar.gz SOURCES/mock-4.0.3.tar.gz

@ -1 +1 @@
397ed52eb2d8d4b326bc3fa6b38adda5f0b090d3 SOURCES/mock-2.0.0.tar.gz 177c1059c58d80ad33ef0b7f480ef72d287acfb2 SOURCES/mock-4.0.3.tar.gz

@ -1,72 +0,0 @@
From 894204aba025609a91ad219767b88caa65d81259 Mon Sep 17 00:00:00 2001
From: Lumir Balhar <lbalhar@redhat.com>
Date: Wed, 20 Jun 2018 12:47:42 +0200
Subject: [PATCH] Remove pbr dependency
---
mock/mock.py | 6 ++----
requirements.txt | 4 ----
setup.cfg | 3 +++
setup.py | 3 +--
4 files changed, 6 insertions(+), 10 deletions(-)
diff --git a/mock/mock.py b/mock/mock.py
index c674a85..afa1105 100644
--- a/mock/mock.py
+++ b/mock/mock.py
@@ -66,11 +66,9 @@ from types import ModuleType
import six
from six import wraps
-from pbr.version import VersionInfo
-_v = VersionInfo('mock').semantic_version()
-__version__ = _v.release_string()
-version_info = _v.version_tuple()
+__version__ = 'VERSIONPLACEHOLDER'
+version_info = tuple(map(int, __version__.split('.'))) + ('final', 0)
import mock
diff --git a/requirements.txt b/requirements.txt
index 31bbe5d..bca9f9b 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,6 +1,2 @@
funcsigs>=1;python_version<"3.3"
-# For runtime needs this is correct. For setup_requires needs, 1.2.0 is needed
-# but setuptools can't cope with conflicts in setup_requires, so thats
-# unversioned.
-pbr>=0.11
six>=1.9
diff --git a/setup.cfg b/setup.cfg
index f5e0a02..3f7f263 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,6 @@
[metadata]
name = mock
+version = VERSIONPLACEHOLDER
summary = Rolling backport of unittest.mock for all Pythons
home-page = https://github.com/testing-cabal/mock
description-file = README.rst
@@ -49,3 +50,5 @@ tag_build =
tag_date = 0
tag_svn_revision = 0
+[options]
+packages = mock
diff --git a/setup.py b/setup.py
index 5f727ae..b80f541 100755
--- a/setup.py
+++ b/setup.py
@@ -2,5 +2,4 @@
import setuptools
setuptools.setup(
- setup_requires=['pbr>=1.3', 'setuptools>=17.1'],
- pbr=True)
+ setup_requires=['setuptools>=17.1'])
--
2.17.1

@ -0,0 +1,73 @@
From f3e3d82aab0ede7e25273806dc0505574d85eae2 Mon Sep 17 00:00:00 2001
From: Chris Withers <chris@simplistix.co.uk>
Date: Thu, 15 Apr 2021 08:27:25 +0100
Subject: [PATCH] fix tests that should test mock but were testing
unittest.mock
---
mock/tests/testmock.py | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/mock/tests/testmock.py b/mock/tests/testmock.py
index 5702b6d..1a70909 100644
--- a/mock/tests/testmock.py
+++ b/mock/tests/testmock.py
@@ -13,6 +13,7 @@
create_autospec, mock
)
from mock.mock import _Call, _CallList
+import mock.mock as mock_module
class Iter(object):
@@ -47,7 +48,7 @@ def test_all(self):
# if __all__ is badly defined then import * will raise an error
# We have to exec it because you can't import * inside a method
# in Python 3
- exec("from unittest.mock import *")
+ exec("from mock.mock import *")
def test_constructor(self):
@@ -2137,16 +2138,16 @@ def test_isinstance_under_settrace(self):
# test_patch_dict_test_prefix and test_patch_test_prefix not restoring
# causes the objects patched to go out of sync
- old_patch = unittest.mock.patch
+ old_patch = mock_module.patch
# Directly using __setattr__ on unittest.mock causes current imported
# reference to be updated. Use a lambda so that during cleanup the
# re-imported new reference is updated.
- self.addCleanup(lambda patch: setattr(unittest.mock, 'patch', patch),
+ self.addCleanup(lambda patch: setattr(mock_module, 'patch', patch),
old_patch)
with patch.dict('sys.modules'):
- del sys.modules['unittest.mock']
+ del sys.modules['mock']
# This trace will stop coverage being measured ;-)
def trace(frame, event, arg): # pragma: no cover
@@ -2155,7 +2156,7 @@ def trace(frame, event, arg): # pragma: no cover
self.addCleanup(sys.settrace, sys.gettrace())
sys.settrace(trace)
- from unittest.mock import (
+ from mock.mock import (
Mock, MagicMock, NonCallableMock, NonCallableMagicMock
)
@@ -2170,10 +2171,10 @@ def trace(frame, event, arg): # pragma: no cover
def test_bool_not_called_when_passing_spec_arg(self):
class Something:
def __init__(self):
- self.obj_with_bool_func = unittest.mock.MagicMock()
+ self.obj_with_bool_func = mock_module.MagicMock()
obj = Something()
- with unittest.mock.patch.object(obj, 'obj_with_bool_func', autospec=True): pass
+ with mock_module.patch.object(obj, 'obj_with_bool_func', autospec=True): pass
self.assertEqual(obj.obj_with_bool_func.__bool__.call_count, 0)

@ -1,97 +1,210 @@
%if 0%{?fedora} || 0%{?rhel} > 6 ## START: Set by rpmautospec
# keeping python3 subpackage as stdlib mock lives in a different namespace ## (rpmautospec version 0.6.5)
# Some people may have not fixed their imports ## RPMAUTOSPEC: autorelease, autochangelog
%global with_python3 1 %define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
%endif release_number = 17;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
# Not yet in Fedora buildroot print(release_number + base_release_number - 1);
%{!?python3_pkgversion:%global python3_pkgversion 3} }%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
%global mod_name mock
%bcond_without tests
Name: python-mock Name: python-mock
Version: 2.0.0 Version: 4.0.3
Release: 11%{?dist} Release: %autorelease
Summary: A Python Mocking and Patching Library for Testing Summary: Deprecated, use unittest.mock from the standard library instead
License: BSD-2-Clause
URL: https://github.com/testing-cabal/mock
Source0: %{url}/archive/%{version}/mock-%{version}.tar.gz
License: BSD # Fix tests that should test mock but were testing unittest.mock
URL: http://www.voidspace.org.uk/python/%{mod_name}/ # Merged upstream
Source0: http://pypi.python.org/packages/source/m/%{mod_name}/%{mod_name}-%{version}.tar.gz Patch1: %{url}/commit/f3e3d82aab.patch
Patch0: 0001-Remove-pbr-dependency.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: python%{python3_pkgversion}-devel BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools BuildRequires: python%{python3_pkgversion}-setuptools
# For tests %if %{with tests}
BuildRequires: python%{python3_pkgversion}-unittest2 BuildRequires: python%{python3_pkgversion}-pytest
BuildRequires: python%{python3_pkgversion}-six BuildRequires: python%{python3_pkgversion}-six
%endif
%description %description
Mock is a Python module that provides a core mock class. It removes the need This is a deprecated package.
to create a host of stubs throughout your test suite. After performing an
action, you can make assertions about which methods / attributes were used and The mock module is now part of the Python standard library,
arguments they were called with. You can also specify return values and set available as unittest.mock in Python 3.3 onwards.
needed attributes in the normal way.
https://fedoraproject.org/wiki/Changes/DeprecatePythonMock
%package -n python%{python3_pkgversion}-mock %package -n python%{python3_pkgversion}-mock
Summary: A Python Mocking and Patching Library for Testing Summary: %{summary}
%{?python_provide:%python_provide python%{python3_pkgversion}-%{mod_name}}
Requires: python3-six >= 1.9.0 # This package is deprecated, no new packages in Fedora can depend on it
# https://fedoraproject.org/wiki/Changes/DeprecatePythonMock
Provides: deprecated()
%description -n python%{python3_pkgversion}-mock %description -n python%{python3_pkgversion}-mock
Mock is a Python module that provides a core mock class. It removes the need This is a deprecated package.
to create a host of stubs throughout your test suite. After performing an
action, you can make assertions about which methods / attributes were used and The mock module is now part of the Python standard library,
arguments they were called with. You can also specify return values and set available as unittest.mock in Python 3.3 onwards.
needed attributes in the normal way.
https://fedoraproject.org/wiki/Changes/DeprecatePythonMock
%prep %prep
%setup -q -n %{mod_name}-%{version} %autosetup -p1 -n mock-%{version}
%patch0 -p1
sed -i "s|VERSIONPLACEHOLDER|%{version}|" setup.cfg mock/mock.py
%build %build
%{py3_build} %py3_build
%if %{with tests}
%check %check
%{__python3} -m unittest %pytest
%endif
%install %install
%{py3_install} %py3_install
%if 0%{?with_python3}
%files -n python%{python3_pkgversion}-mock %files -n python%{python3_pkgversion}-mock
%license LICENSE.txt %license LICENSE.txt
%doc docs/* %doc README.rst
%{python3_sitelib}/*.egg-info %{python3_sitelib}/*.egg-info/
%{python3_sitelib}/%{mod_name} %{python3_sitelib}/mock/
%endif
%changelog %changelog
* Wed Jul 11 2018 Petr Viktorin <pviktori@redhat.com> - 2.0.0-11 * Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 4.0.3-17
- Remove the Python 2 subpackage - Rebuilt for MSVSphere 10
https://bugzilla.redhat.com/show_bug.cgi?id=1590793
- Re-enable tests ## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 4.0.3-16
- Rebuilt for Python 3.13
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 4.0.3-15
- Bootstrap for Python 3.13
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Jun 16 2023 Python Maint <python-maint@redhat.com> - 4.0.3-9
- Rebuilt for Python 3.12
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 4.0.3-8
- Bootstrap for Python 3.12
* Sun Mar 12 2023 Tim Orling <ticotimo@gmail.com> - 4.0.3-7
- migrated to SPDX license
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jul 09 2018 Petr Viktorin <pviktori@redhat.com> - 2.0.0-10 * Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 4.0.3-4
- Drop dependency on python3-funcsigs - Rebuilt for Python 3.11
(funcsigs functionality is in the Python 3 standard library -- inspect)
- Drop dependency on python2-unittest2
(Not available in the distro)
- Fix python2 requires names * Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 4.0.3-3
- Bootstrap for Python 3.11
* Mon Jun 25 2018 Lumír Balhar <lbalhar@redhat.com> - 2.0.0-9 * Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-2
- Allow build with Python 2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 2.0.0-8 * Thu Jan 06 2022 Miro Hrončok <mhroncok@redhat.com> - 4.0.3-1
- Add patch to remove dependency on pbr - Update to 4.0.3 for Python 3.11 support
- Fixes: rhbz#2019006
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jun 02 2021 Python Maint <python-maint@redhat.com> - 3.0.5-16
- Rebuilt for Python 3.10
* Wed Jun 02 2021 Python Maint <python-maint@redhat.com> - 3.0.5-15
- Bootstrap for Python 3.10
* Tue Feb 02 2021 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-14
- Deprecate python3-mock
- https://fedoraproject.org/wiki/Changes/DeprecatePythonMock
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Dec 07 2020 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-12
- BuildRequire six to fix a build failure
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-10
- Rebuilt for Python 3.9
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-9
- Bootstrap for Python 3.9
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Nov 28 2019 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-7
- Subpackage python2-mock has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Fri Nov 01 2019 Petr Viktorin <pviktori@redhat.com> - 3.0.5-6
- Remove unused dependencies on pbr
The current version of Mock does not use pbr.
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-5
- Rebuilt for Python 3.8.0rc1 (#1748018)
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-4
- Rebuilt for Python 3.8
* Wed Aug 14 2019 Miro Hrončok <mhroncok@redhat.com> - 3.0.5-3
- Bootstrap for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Mon Jul 08 2019 Yatin Karel <ykarel@redhat.com> - 3.0.5-1
- Update to 3.0.5 (RHBZ#1721075)
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Fri Oct 26 2018 Petr Viktorin <pviktori@redhat.com> - 2.0.0-12
- Run tests for Python 3
* Fri Aug 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-11
- Don't require funcsigs on python3, it's part of the standard library
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Jun 13 2018 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-9
- Rebuilt for Python 3.7
* Fri Mar 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.0.0-8
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7 * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
@ -169,3 +282,5 @@ sed -i "s|VERSIONPLACEHOLDER|%{version}|" setup.cfg mock/mock.py
* Fri Jul 22 2011 Praveen Kumar <kumarpraveen.nitdgp@gmail.com> - 0.7.2-1 * Fri Jul 22 2011 Praveen Kumar <kumarpraveen.nitdgp@gmail.com> - 0.7.2-1
- Initial RPM release - Initial RPM release
## END: Generated by rpmautospec

Loading…
Cancel
Save