Update to 3.12.0

Reenable docs in EPEL7
epel9
Michel Alexandre Salim 8 years ago
parent 88aa9d84f4
commit 2f31c2579e

2
.gitignore vendored

@ -1 +1 @@
/hypothesis-3.4.0.tar.gz /hypothesis-3.12.0.tar.gz

@ -1,10 +0,0 @@
--- hypothesis-2.0.0/docs/conf.py.offline 2016-01-11 00:47:23.000000000 +0700
+++ hypothesis-2.0.0/docs/conf.py 2016-02-14 10:50:58.790136352 +0700
@@ -33,7 +33,6 @@
extensions = [
'sphinx.ext.autodoc',
'sphinx.ext.viewcode',
- 'sphinx.ext.intersphinx',
]
templates_path = ['_templates']

@ -1,26 +1,24 @@
%{!?__python2: %global __python2 /usr/bin/python2}
%global srcname hypothesis %global srcname hypothesis
%global sum A library for property based testing
Name: python-%{srcname} Name: python-%{srcname}
Version: 3.4.0 Version: 3.12.0
Release: 4%{?dist} Release: 1%{?dist}
Summary: A library for property based testing Summary: %{sum}
License: MPLv2.0 License: MPLv2.0
URL: https://github.com/DRMacIver/hypothesis URL: https://github.com/HypothesisWorks/hypothesis-python
Source0: https://github.com/DRMacIver/hypothesis/archive/%{version}.tar.gz#/hypothesis-%{version}.tar.gz Source0: %{url}/archive/%{version}.tar.gz#/hypothesis-%{version}.tar.gz
# disable Sphinx extensions that require Internet access # disable Sphinx extensions that require Internet access
Patch0: %{srcname}-2.0.0-offline.patch Patch0: %{srcname}-3.12.0-offline.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: python2-devel BuildRequires: python2-devel
BuildRequires: python-sphinx BuildRequires: python-sphinx
BuildRequires: python-enum34 BuildRequires: python-enum34
BuildRequires: python%{python3_pkgversion}-devel
%if 0%{?fedora} BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: python3-devel
%endif
%description %description
Hypothesis is a library for testing your Python code against a much Hypothesis is a library for testing your Python code against a much
@ -35,12 +33,10 @@ Summary: A library for property based testing
Obsoletes: python-%{srcname} < 1.11.1-1 Obsoletes: python-%{srcname} < 1.11.1-1
Requires: python-enum34 Requires: python-enum34
%if 0%{?fedora}
%{?python_provide:%python_provide python2-%{srcname}} %{?python_provide:%python_provide python2-%{srcname}}
%if 0%{?fedora}
Suggests: numpy Suggests: numpy
Suggests: pytz Suggests: pytz
%else
Provides: python-hypothesis = %{version}-%{release}
%endif %endif
%description -n python2-%{srcname} %description -n python2-%{srcname}
@ -51,21 +47,20 @@ to integrate seamlessly into your existing Python unit testing work
flow. flow.
%if 0%{?fedora} %package -n python%{python3_pkgversion}-%{srcname}
%package -n python3-%{srcname}
Summary: A library for property based testing Summary: A library for property based testing
%{?python_provide:%python_provide python3-%{srcname}} %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
%if 0%{?fedora}
Suggests: python3-numpy Suggests: python%{python3_pkgversion}-numpy
Suggests: python3-pytz Suggests: python%{python3_pkgversion}-pytz
%endif
%description -n python3-%{srcname} %description -n python%{python3_pkgversion}-%{srcname}
Hypothesis is a library for testing your Python code against a much Hypothesis is a library for testing your Python code against a much
larger range of examples than you would ever want to write by larger range of examples than you would ever want to write by
hand. Its based on the Haskell library, Quickcheck, and is designed hand. Its based on the Haskell library, Quickcheck, and is designed
to integrate seamlessly into your existing Python unit testing work to integrate seamlessly into your existing Python unit testing work
flow. flow.
%endif
%prep %prep
@ -76,43 +71,36 @@ flow.
%build %build
%if 0%{?fedora}
%py2_build %py2_build
%py3_build %py3_build
READTHEDOCS=True sphinx-build -b man docs docs/_build/man PYTHONPATH=src READTHEDOCS=True sphinx-build -b man docs docs/_build/man
%else
%{__python2} setup.py build
%endif
%install %install
%if 0%{?fedora}
%py2_install %py2_install
%py3_install %py3_install
%{__install} -Dp -m 644 docs/_build/man/hypothesis.1 \ %{__install} -Dp -m 644 docs/_build/man/hypothesis.1 \
$RPM_BUILD_ROOT%{_mandir}/man1/hypothesis.1 $RPM_BUILD_ROOT%{_mandir}/man1/hypothesis.1
%else
%{__python2} setup.py install --skip-build --prefix=%{_prefix} --root %{buildroot}
%endif
%files -n python2-%{srcname} %files -n python2-%{srcname}
%license LICENSE.txt %license LICENSE.txt
%doc README.rst %doc README.rst
%{python2_sitelib}/* %{python2_sitelib}/*
%if 0%{?fedora}
%{_mandir}/man1/hypothesis.1* %{_mandir}/man1/hypothesis.1*
%endif
%if 0%{?fedora} %files -n python%{python3_pkgversion}-%{srcname}
%files -n python3-%{srcname}
%license LICENSE.txt %license LICENSE.txt
%doc README.rst %doc README.rst
%{python3_sitelib}/* %{python3_sitelib}/*
%{_mandir}/man1/hypothesis.1* %{_mandir}/man1/hypothesis.1*
%endif
%changelog %changelog
* Mon Jul 10 2017 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.12.0-1
- Update to 3.12.0
- Reenable docs in EPEL7
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.0-4 * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

@ -1 +1 @@
c123bc1c62545d18cd243e3964000357 hypothesis-3.4.0.tar.gz SHA512 (hypothesis-3.12.0.tar.gz) = 7f82d2c8f2e2c875dd050b6403dff6aa6fee20f176920e74d155de1fbc311369d608f3d637b497480d27bca3cc3caee9d0c683c0b7e44daad62317ddbe893f8a

Loading…
Cancel
Save