Update to 1.4.1.

- Apipkg has been debundled.
- Follow updated Python packaging guidelines.
- Spec file cleanups.
epel9
Thomas Moschny 9 years ago
parent 0178361cc9
commit f17796b646

11
.gitignore vendored

@ -1,9 +1,2 @@
/execnet-1.0.4.tar.gz /execnet-*.tar.gz
/execnet-1.0.5.tar.gz /execnet-*.zip
/execnet-1.0.6.tar.gz
/execnet-1.0.7.tar.gz
/execnet-1.0.8.tar.gz
/execnet-1.0.9.zip
/execnet-1.1.zip
/execnet-1.2.0.tar.gz
/execnet-1.3.0.tar.gz

@ -1,29 +0,0 @@
diff -up execnet-1.2.0/testing/test_rsync.py.needssymlink execnet-1.2.0/testing/test_rsync.py
--- execnet-1.2.0/testing/test_rsync.py.needssymlink 2014-06-16 09:26:02.320929971 -0600
+++ execnet-1.2.0/testing/test_rsync.py 2014-06-18 11:42:01.024851339 -0600
@@ -12,9 +12,6 @@ def pytest_funcarg__gw1(request):
)
pytest_funcarg__gw2 = pytest_funcarg__gw1
-needssymlink = pytest.mark.skipif(not hasattr(py.path.local, "mksymlinkto"),
- reason="py.path.local has no mksymlinkto() on this platform")
-
def pytest_funcarg__dirs(request):
t = request.getfuncargvalue('tmpdir')
class dirs:
@@ -133,7 +130,6 @@ class TestRSync:
mode = destdir.stat().mode
assert mode & 511 == 504
- @needssymlink
def test_symlink_rsync(self, dirs, gw1):
source = dirs.source
dest = dirs.dest1
@@ -149,7 +145,6 @@ class TestRSync:
assert dest.join('rellink').readlink() == "subdir/existant"
assert dest.join('abslink').readlink() == expected
- @needssymlink
def test_symlink2_rsync(self, dirs, gw1):
source = dirs.source
dest = dirs.dest1

@ -1,51 +1,33 @@
%if 0%{?rhel} && 0%{?rhel} <= 6
%{!?__python2: %global __python2 /usr/bin/python2}
%{!?python2_sitelib: %global python2_sitelib %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
%endif
%if 0%{?fedora}
%global with_python3 1
%endif
%global srcname execnet %global srcname execnet
Name: python-%{srcname} Name: python-%{srcname}
Version: 1.3.0 Version: 1.4.1
Release: 4%{?dist} Release: 1%{?dist}
Summary: Elastic Python Deployment Summary: Elastic Python Deployment
Group: Development/Languages
# package is now under the MIT license, (although the docs still say # package is now under the MIT license, (although the docs still say
# otherwise, see https://bitbucket.org/hpk42/execnet/issue/33), and # otherwise, see https://bitbucket.org/hpk42/execnet/issue/33), and
# one example file (doc/example/sysinfo.py) is GPLv2+ # one example file (doc/example/sysinfo.py) is GPLv2+
License: MIT and GPLv2+ License: MIT and GPLv2+
URL: http://codespeak.net/execnet URL: http://codespeak.net/execnet
Source0: http://pypi.python.org/packages/source/e/%{srcname}/%{srcname}-%{version}.tar.gz Source0: http://pypi.python.org/packages/source/e/%{srcname}/%{srcname}-%{version}.tar.gz
# pytest is too old in EL7 - this patch removes the failing @needssymlink decorator
Patch2: python-execnet-needssymlink.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: python-devel BuildRequires: python2-devel
BuildRequires: python-setuptools BuildRequires: python2-setuptools
Requires: python-setuptools BuildRequires: python-apipkg
BuildRequires: pytest BuildRequires: pytest
BuildRequires: python-sphinx
BuildRequires: /bin/ps
BuildRequires: python-eventlet
BuildRequires: python-hgdistver BuildRequires: python-hgdistver
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 7 BuildRequires: python-eventlet
BuildRequires: python-gevent >= 1.0 BuildRequires: python-gevent >= 1.0
%endif
%if 0%{?with_python3}
BuildRequires: python3-devel BuildRequires: python3-devel
BuildRequires: python3-setuptools BuildRequires: python3-setuptools
BuildRequires: python3-apipkg
BuildRequires: python3-pytest BuildRequires: python3-pytest
BuildRequires: python3-hgdistver BuildRequires: python3-hgdistver
# these do not exist # these do not exist
#BuildRequires: python3-eventlet #BuildRequires: python3-eventlet
#BuildRequires: python3-gevent #BuildRequires: python3-gevent
%endif # with_python3 BuildRequires: python-sphinx
# execnet was separated from pylib at that point BuildRequires: /bin/ps
Conflicts: python-py < 1.1.0
%description %description
execnet provides a share-nothing model with channel-send/receive execnet provides a share-nothing model with channel-send/receive
@ -58,14 +40,30 @@ minimal and fast API targetting the following uses:
* write scripts to administer multiple environments * write scripts to administer multiple environments
%if 0%{?with_python3} %package -n python2-%{srcname}
%package -n python3-execnet
Summary: Elastic Python Deployment Summary: Elastic Python Deployment
Group: Development/Languages %{?python_provide:%python_provide python2-%{srcname}}
Requires: python3-setuptools Requires: python2-setuptools
Requires: python-apipkg
%description -n python2-%{srcname}
execnet provides a share-nothing model with channel-send/receive
communication for distributing execution across many Python
interpreters across version, platform and network barriers. It has a
minimal and fast API targetting the following uses:
* distribute tasks to (many) local or remote CPUs
* write and deploy hybrid multi-process applications
* write scripts to administer multiple environments
%description -n python3-execnet %package -n python3-%{srcname}
Summary: Elastic Python Deployment
%{?python_provide:%python_provide python3-%{srcname}}
Requires: python3-setuptools
Requires: python3-apipkg
%description -n python3-%{srcname}
execnet provides a share-nothing model with channel-send/receive execnet provides a share-nothing model with channel-send/receive
communication for distributing execution across many Python communication for distributing execution across many Python
interpreters across version, platform and network barriers. It has a interpreters across version, platform and network barriers. It has a
@ -74,14 +72,12 @@ minimal and fast API targetting the following uses:
* distribute tasks to (many) local or remote CPUs * distribute tasks to (many) local or remote CPUs
* write and deploy hybrid multi-process applications * write and deploy hybrid multi-process applications
* write scripts to administer multiple environments * write scripts to administer multiple environments
%endif # with_python3
%prep %prep
%setup -qc -n %{srcname}-%{version} %setup -qc -n %{srcname}-%{version}
mv %{srcname}-%{version} python2 mv %{srcname}-%{version} python2
pushd python2 pushd python2
%patch2 -p1
# remove shebangs and fix permissions # remove shebangs and fix permissions
find . -type f -a \( -name '*.py' -o -name 'py.*' \) \ find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
@ -89,40 +85,33 @@ find . -type f -a \( -name '*.py' -o -name 'py.*' \) \
-exec chmod u=rw,go=r {} \; -exec chmod u=rw,go=r {} \;
popd popd
%if 0%{?with_python3}
cp -a python2 python3 cp -a python2 python3
%endif # with_python3
%build %build
pushd python2 pushd python2
%{__python2} setup.py build %py2_build
make -C doc html make -C doc html
popd popd
%if 0%{?with_python3}
pushd python3 pushd python3
%{__python3} setup.py build %py3_build
make -C doc html make -C doc html
popd popd
%endif # with_python3
%install %install
pushd python2 pushd python2
%{__python2} setup.py install -O1 --skip-build --root %{buildroot} %py2_install
# remove hidden file # remove hidden file
rm doc/_build/html/.buildinfo rm doc/_build/html/.buildinfo
popd popd
%if 0%{?with_python3}
pushd python3 pushd python3
%{__python3} setup.py install -O1 --skip-build --root %{buildroot} %py3_install
# remove hidden file # remove hidden file
rm doc/_build/html/.buildinfo rm doc/_build/html/.buildinfo
popd popd
%endif # with_python3
%check %check
@ -130,41 +119,37 @@ pushd python2
PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \ PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \
py.test-%{python2_version} -r s -k'-test_stdouterrin_setnull' testing py.test-%{python2_version} -r s -k'-test_stdouterrin_setnull' testing
popd popd
%if 0%{?with_python3}
pushd python3 pushd python3
PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \ PYTHONPATH=$(pwd) LC_ALL="en_US.UTF-8" \
py.test-%{python3_version} -r s -k'-test_stdouterrin_setnull' testing py.test-%{python3_version} -r s -k'-test_stdouterrin_setnull' testing
popd popd
%endif # with_python3
%files %files -n python2-%{srcname}
%{python2_sitelib}/%{srcname}* %{python2_sitelib}/%{srcname}*
%doc python2/README.txt %doc python2/README.txt
%doc python2/CHANGELOG %doc python2/CHANGELOG
%doc python2/doc/_build/html %doc python2/doc/_build/html
%if 0%{?_licensedir:1}
%license python2/LICENSE %license python2/LICENSE
%else
%doc python2/LICENSE
%endif # licensedir
%if 0%{?with_python3} %files -n python3-%{srcname}
%files -n python3-execnet
%{python3_sitelib}/%{srcname}* %{python3_sitelib}/%{srcname}*
%doc python3/README.txt %doc python3/README.txt
%doc python3/CHANGELOG %doc python3/CHANGELOG
%doc python3/doc/_build/html %doc python3/doc/_build/html
%if 0%{?_licensedir:1}
%license python3/LICENSE %license python3/LICENSE
%else
%doc python3/LICENSE %doc python3/LICENSE
%endif # licemsedir
%endif # with_python3
%changelog %changelog
* Sat Jan 23 2016 Thomas Moschny <thomas.moschny@gmx.de> - 1.4.1-1
- Update to 1.4.1.
- Apipkg has been debundled.
- Follow updated Python packaging guidelines.
- Spec file cleanups.
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-4 * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-4
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5 - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5

@ -1 +1 @@
426c1a963cee5f671a3e8187b983c915 execnet-1.3.0.tar.gz 0ff84b6c79d0dafb7e2971629c4d127a execnet-1.4.1.tar.gz

Loading…
Cancel
Save