parent
fb16c7f8eb
commit
336e7cc0e7
@ -1,71 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Ronny Pfannschmidt <Ronny.Pfannschmidt@gmx.de>
|
||||
# Date 1346694793 -7200
|
||||
# Node ID 49c5934137e5f8ac9d16ea96ac2a5c01149ad190
|
||||
# Parent ec10c11ac8eb248a995c70ad2fee426315249f33
|
||||
fix issue #9 - terminate the worker threadpools in safe_terminate
|
||||
|
||||
diff -r ec10c11ac8eb248a995c70ad2fee426315249f33 -r 49c5934137e5f8ac9d16ea96ac2a5c01149ad190 CHANGELOG
|
||||
--- a/CHANGELOG Wed Jun 20 18:16:40 2012 +0200
|
||||
+++ b/CHANGELOG Mon Sep 03 19:53:13 2012 +0200
|
||||
@@ -23,6 +23,8 @@
|
||||
- fix issue #2 - properly reconfigure the channels string coercion for rsync,
|
||||
so it can send from python2 to python3
|
||||
|
||||
+- fix issue #9 - propperly terminate the worker threadpools in safe_terminate
|
||||
+
|
||||
- refactor socketserver, so it can be directly remote_exec'd for starting a socket gateway on a remote
|
||||
|
||||
|
||||
diff -r ec10c11ac8eb248a995c70ad2fee426315249f33 -r 49c5934137e5f8ac9d16ea96ac2a5c01149ad190 execnet/multi.py
|
||||
--- a/execnet/multi.py Wed Jun 20 18:16:40 2012 +0200
|
||||
+++ b/execnet/multi.py Mon Sep 03 19:53:13 2012 +0200
|
||||
@@ -252,6 +252,8 @@
|
||||
replylist.append(reply)
|
||||
for reply in replylist:
|
||||
reply.get()
|
||||
+ workerpool.shutdown()
|
||||
+ workerpool.join()
|
||||
|
||||
|
||||
default_group = Group()
|
||||
diff -r ec10c11ac8eb248a995c70ad2fee426315249f33 -r 49c5934137e5f8ac9d16ea96ac2a5c01149ad190 testing/test_multi.py
|
||||
--- a/testing/test_multi.py Wed Jun 20 18:16:40 2012 +0200
|
||||
+++ b/testing/test_multi.py Mon Sep 03 19:53:13 2012 +0200
|
||||
@@ -2,6 +2,8 @@
|
||||
tests for multi channels and gateway Groups
|
||||
"""
|
||||
|
||||
+import threading
|
||||
+from time import sleep
|
||||
import execnet
|
||||
import py
|
||||
from execnet.gateway_base import Channel
|
||||
@@ -193,6 +195,7 @@
|
||||
|
||||
|
||||
def test_safe_terminate():
|
||||
+ active = threading.active_count()
|
||||
l = []
|
||||
def term():
|
||||
py.std.time.sleep(3)
|
||||
@@ -200,8 +203,12 @@
|
||||
l.append(1)
|
||||
safe_terminate(1, [(term, kill)] * 10)
|
||||
assert len(l) == 10
|
||||
+ sleep(0.1)
|
||||
+ py.std.gc.collect()
|
||||
+ assert threading.active_count() == active
|
||||
|
||||
def test_safe_terminate2():
|
||||
+ active = threading.active_count()
|
||||
l = []
|
||||
def term():
|
||||
return
|
||||
@@ -209,3 +216,6 @@
|
||||
l.append(1)
|
||||
safe_terminate(3, [(term, kill)] * 10)
|
||||
assert len(l) == 0
|
||||
+ sleep(0.1)
|
||||
+ py.std.gc.collect()
|
||||
+ assert threading.active_count() == active
|
@ -1,23 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Robert Kuska <rkuska@redhat.com>
|
||||
# Date 1400488914 -7200
|
||||
# Node ID 8b3f3a14d53c561f0bae1990dc251d5fde09432e
|
||||
# Parent 6f3729e2c7eb97616a71b8f917b4f4986dfdd8b7
|
||||
Fixes test in test_channel according the new exec traceback in py3.4
|
||||
|
||||
diff --git a/testing/test_channel.py b/testing/test_channel.py
|
||||
--- a/testing/test_channel.py
|
||||
+++ b/testing/test_channel.py
|
||||
@@ -72,9 +72,10 @@
|
||||
channel.receive()
|
||||
except channel.RemoteError:
|
||||
e = sys.exc_info()[1]
|
||||
+ print(e)
|
||||
assert str(e).startswith('Traceback (most recent call last):')
|
||||
- assert str(e).find('NameError: global name \'foobar\' '
|
||||
- 'is not defined') > -1
|
||||
+ assert str(e).find('NameError') > -1
|
||||
+ assert str(e).find('foobar') > -1
|
||||
else:
|
||||
pytest.fail('No exception raised')
|
||||
|
@ -0,0 +1,12 @@
|
||||
diff -up execnet-1.3.0/setup.py.orig execnet-1.3.0/setup.py
|
||||
--- execnet-1.3.0/setup.py.orig 2015-03-08 12:38:03.021618008 +0100
|
||||
+++ execnet-1.3.0/setup.py 2015-03-08 12:45:21.326035058 +0100
|
||||
@@ -63,7 +63,7 @@ def main():
|
||||
setup_requires=[
|
||||
# this is a setup/release time dependency
|
||||
# we are supposed to use wheels
|
||||
- 'hgdistver',
|
||||
+ #'hgdistver',
|
||||
]
|
||||
)
|
||||
|
@ -1,18 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Robert Kuska <rkuska@redhat.com>
|
||||
# Date 1400489832 -7200
|
||||
# Node ID 47ff3652b0aed191f7bafc741c211d1415f65224
|
||||
# Parent 8b3f3a14d53c561f0bae1990dc251d5fde09432e
|
||||
Remove redudant print statement
|
||||
|
||||
diff --git a/testing/test_channel.py b/testing/test_channel.py
|
||||
--- a/testing/test_channel.py
|
||||
+++ b/testing/test_channel.py
|
||||
@@ -72,7 +72,6 @@
|
||||
channel.receive()
|
||||
except channel.RemoteError:
|
||||
e = sys.exc_info()[1]
|
||||
- print(e)
|
||||
assert str(e).startswith('Traceback (most recent call last):')
|
||||
assert str(e).find('NameError') > -1
|
||||
assert str(e).find('foobar') > -1
|
Loading…
Reference in new issue