- New upstream release pycrypto 2.3: - Fix NameError when attempting to use deprecated getRandomNumber() function - _slowmath: Compute RSA u parameter when it's not given to RSA.construct; this makes _slowmath behave the same as _fastmath in this regard - Make RSA.generate raise a more user-friendly exception message when the user tries to generate a bogus-length key - Add -c option to %setup because upstream tarball has dropped the top-level directory - Run benchmark as part of %check if we have python 2.4 or later - BR: python2-devel rather than just python-devel - Add patch to make sure we can find libgmp in 64-bit multilib environmentsf38
parent
6e1e1b3e92
commit
b05e574ecf
@ -1 +1 @@
|
|||||||
pycrypto-2.2.tar.gz
|
/pycrypto-2.3.tar.gz
|
||||||
|
@ -0,0 +1,11 @@
|
|||||||
|
--- pycrypto-2.3/setup.py 2010-08-27 09:25:59.462963720 +0100
|
||||||
|
+++ pycrypto-2.3/setup.py 2010-08-27 10:12:04.590901603 +0100
|
||||||
|
@@ -136,7 +136,7 @@
|
||||||
|
self.compiler.include_dirs.insert(0, "src/inc-msvc/")
|
||||||
|
|
||||||
|
# Detect libgmp and don't build _fastmath if it is missing.
|
||||||
|
- lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib']
|
||||||
|
+ lib_dirs = self.compiler.library_dirs + ['/lib64', '/usr/lib64']
|
||||||
|
if not (self.compiler.find_library_file(lib_dirs, 'gmp')):
|
||||||
|
print >>sys.stderr, "warning: GMP library not found; Not building Crypto.PublicKey._fastmath."
|
||||||
|
self.__remove_extensions(["Crypto.PublicKey._fastmath"])
|
Loading…
Reference in new issue