Update to 2.2

- New upstream release pycrypto 2.2:
  - Deprecated Crypto.Util.number.getRandomNumber()
  - It's been replaced by getRandomNBitInteger and getRandomInteger
  - Better isPrime() and getPrime() implementations
  - getStrongPrime() implementation for generating RSA primes
  - Support for importing and exporting RSA keys in DER and PEM format
  - Fix PyCrypto when floor division (python -Qnew) is enabled
  - When building using gcc, use -std=c99 for compilation
- Update optflags patch
f38
Paul Howarth 15 years ago
parent a0deb11495
commit 6e1e1b3e92

2
.gitignore vendored

@ -1 +1 @@
pycrypto-2.1.0.tar.gz pycrypto-2.2.tar.gz

@ -1,6 +1,6 @@
--- pycrypto-2.1.0/setup.py.orig 2009-12-13 20:39:29.000000000 +0000 --- pycrypto-2.2/setup.py.orig 2010-08-02 22:15:23.000000000 +0100
+++ pycrypto-2.1.0/setup.py 2010-02-16 13:18:15.910546268 +0000 +++ pycrypto-2.2/setup.py 2010-08-03 09:23:48.012339680 +0100
@@ -124,25 +124,6 @@ @@ -127,27 +127,6 @@
# Make assert() statements always work # Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG") self.__remove_compiler_option("-DNDEBUG")
@ -18,6 +18,8 @@
- self.__add_compiler_option("-fomit-frame-pointer") - self.__add_compiler_option("-fomit-frame-pointer")
- # Don't include debug symbols unless debugging - # Don't include debug symbols unless debugging
- self.__remove_compiler_option("-g") - self.__remove_compiler_option("-g")
- # Don't include profiling information (incompatible with -fomit-frame-pointer)
- self.__remove_compiler_option("-pg")
- if USE_GCOV: - if USE_GCOV:
- self.__add_compiler_option("-fprofile-arcs") - self.__add_compiler_option("-fprofile-arcs")
- self.__add_compiler_option("-ftest-coverage") - self.__add_compiler_option("-ftest-coverage")

@ -1,16 +1,16 @@
%global pythonver %(%{__python} -c "import sys; print sys.version[:3]" || echo 0.0) %global pythonver %(%{__python} -c "import sys; print sys.version[:3]" 2>/dev/null || echo 0.0)
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" 2>/dev/null)}
Summary: Cryptography library for Python Summary: Cryptography library for Python
Name: python-crypto Name: python-crypto
Version: 2.1.0 Version: 2.2
Release: 2%{?dist} Release: 1%{?dist}
# Mostly Public Domain apart from parts of HMAC.py and setup.py, which are Python # Mostly Public Domain apart from parts of HMAC.py and setup.py, which are Python
License: Public Domain and Python License: Public Domain and Python
Group: Development/Libraries Group: Development/Libraries
URL: http://www.pycrypto.org/ URL: http://www.pycrypto.org/
Source0: http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz Source0: http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
Patch0: python-crypto-2.1.0-optflags.patch Patch0: python-crypto-2.2-optflags.patch
Provides: pycrypto = %{version}-%{release} Provides: pycrypto = %{version}-%{release}
BuildRequires: python-devel >= 2.2, gmp-devel >= 4.1 BuildRequires: python-devel >= 2.2, gmp-devel >= 4.1
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot-%(%{__id_u} -n)
@ -33,7 +33,7 @@ SHA), and various encryption algorithms (AES, DES, RSA, ElGamal etc.).
%{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py %{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
# Fix permissions for debuginfo # Fix permissions for debuginfo
%{__chmod} -x src/*.c %{__chmod} -x src/_fastmath.c
%build %build
CFLAGS="%{optflags}" %{__python} setup.py build CFLAGS="%{optflags}" %{__python} setup.py build
@ -63,6 +63,17 @@ fi > egg-info
%{python_sitearch}/Crypto/ %{python_sitearch}/Crypto/
%changelog %changelog
* Tue Aug 3 2010 Paul Howarth <paul@city-fan.org> - 2.2-1
- Update to 2.2
- Deprecated Crypto.Util.number.getRandomNumber()
- It's been replaced by getRandomNBitInteger and getRandomInteger
- Better isPrime() and getPrime() implementations
- getStrongPrime() implementation for generating RSA primes
- Support for importing and exporting RSA keys in DER and PEM format
- Fix PyCrypto when floor division (python -Qnew) is enabled
- When building using gcc, use -std=c99 for compilation
- Update optflags patch
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-2 * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild

@ -1 +1 @@
1d3eb04f06e6f09a080bc37fb019f9bf pycrypto-2.1.0.tar.gz 4f0ed728b14b98f09120cb2ec461ec98 pycrypto-2.2.tar.gz

Loading…
Cancel
Save