Add patch to add support for sphinx 3.2

epel9
Dan Čermák 4 years ago
parent 367e5bc1c6
commit ae563f1f5f
No known key found for this signature in database
GPG Key ID: 8F8C178E966641D3

@ -0,0 +1,34 @@
From 8d07f406105c8196ac01519c770dd87c09d54465 Mon Sep 17 00:00:00 2001
From: Jakob Lykke Andersen <Jakob@caput.dk>
Date: Sun, 2 Aug 2020 15:36:28 +0200
Subject: [PATCH] Allow Sphinx 3.2
---
requirements/production.txt | 2 +-
setup.py | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/requirements/production.txt b/requirements/production.txt
index cdfe658e..c6f74e00 100644
--- a/requirements/production.txt
+++ b/requirements/production.txt
@@ -2,5 +2,5 @@ docutils>=0.12
Jinja2>=2.7.3
MarkupSafe>=0.23
Pygments>=1.6
-Sphinx>=3.0,<3.2
+Sphinx>=3.0,<3.3
six>=1.9.0
diff --git a/setup.py b/setup.py
index a8f2a71b..4dc7fd20 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@
render `Doxygen <http://www.doxygen.org>`__ xml output.
'''
-requires = ['Sphinx>=3.0,<3.2', 'docutils>=0.12', 'six>=1.9']
+requires = ['Sphinx>=3.0,<3.3', 'docutils>=0.12', 'six>=1.9']
if sys.version_info < (3, 5):
print('ERROR: Sphinx requires at least Python 3.5 to run.')

@ -6,12 +6,14 @@ render the Doxygen xml output.
Name: python-%{srcname} Name: python-%{srcname}
Version: 4.19.2 Version: 4.19.2
Release: 2%{?dist} Release: 3%{?dist}
Summary: Adds support for Doxygen xml output to reStructuredText and Sphinx Summary: Adds support for Doxygen xml output to reStructuredText and Sphinx
License: BSD License: BSD
URL: https://github.com/%{owner}/%{srcname} URL: https://github.com/%{owner}/%{srcname}
Source0: %{URL}/archive/v%{version}.tar.gz Source0: %{URL}/archive/v%{version}.tar.gz
# allows sphinx 3.2
Patch0: https://github.com/michaeljones/breathe/commit/8d07f406105c8196ac01519c770dd87c09d54465.patch
BuildArch: noarch BuildArch: noarch
@ -19,7 +21,7 @@ BuildRequires: doxygen >= 1.8.4
BuildRequires: python%{python3_pkgversion}-devel BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: %{py3_dist six} >= 1.9 BuildRequires: %{py3_dist six} >= 1.9
BuildRequires: (%{py3_dist Sphinx} >= 3.0 and %{py3_dist Sphinx} < 3.2) BuildRequires: (%{py3_dist Sphinx} >= 3.0 and %{py3_dist Sphinx} < 3.3)
BuildRequires: %{py3_dist docutils} >= 0.12 BuildRequires: %{py3_dist docutils} >= 0.12
BuildRequires: %{py3_dist pytest} BuildRequires: %{py3_dist pytest}
# NOTE: git is only needed because part of the build process checks if it's in # NOTE: git is only needed because part of the build process checks if it's in
@ -48,7 +50,7 @@ License: BSD and zlib
This package contains documentation for developer documentation for %{srcname}. This package contains documentation for developer documentation for %{srcname}.
%prep %prep
%autosetup -n %{srcname}-%{version} %autosetup -n %{srcname}-%{version} -p1
%build %build
%py3_build %py3_build
@ -74,6 +76,9 @@ make dev-test
%license LICENSE %license LICENSE
%changelog %changelog
* Thu Aug 20 2020 Dan Čermák <dan.cermak@cgc-instruments.com> - 4.19.2-3
- Add patch to add support for sphinx 3.2
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.19.2-2 * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.19.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

Loading…
Cancel
Save