Patch for bucket test threshold.

epel9
Gwyn Ciesla 4 years ago
parent 85a91c4f62
commit dba5641c2e

@ -0,0 +1,8 @@
--- tests/functional/retries/test_bucket.py~ 2021-01-12 13:04:04.000000000 -0600
+++ tests/functional/retries/test_bucket.py 2021-01-13 13:41:25.177245044 -0600
@@ -106,4 +106,4 @@
# can sanity check that our implementation isn't drastically
# starving a thread. So we'll arbitrarily say that a thread
# can't have less than 20% of the mean allocations per thread.
- self.assertTrue(not any(x < (0.2 * mean) for x in distribution))
+ self.assertTrue(not any(x < (0.3 * mean) for x in distribution))

@ -3,7 +3,7 @@
Name: python-%{pypi_name} Name: python-%{pypi_name}
# NOTICE - Updating this package requires updating python-boto3 # NOTICE - Updating this package requires updating python-boto3
Version: 1.19.53 Version: 1.19.53
Release: 1%{?dist} Release: 2%{?dist}
Summary: Low-level, data-driven core of boto 3 Summary: Low-level, data-driven core of boto 3
License: ASL 2.0 License: ASL 2.0
@ -11,6 +11,8 @@ URL: https://github.com/boto/botocore
Source0: %{pypi_source} Source0: %{pypi_source}
BuildArch: noarch BuildArch: noarch
Patch0: botocore-1.19.53-bucket-threshhold.patch
BuildRequires: pyproject-rpm-macros BuildRequires: pyproject-rpm-macros
BuildRequires: python3-devel BuildRequires: python3-devel
BuildRequires: python3-jsonschema BuildRequires: python3-jsonschema
@ -33,7 +35,7 @@ A low-level interface to a growing number of Amazon Web Services. The
botocore package is the foundation for the AWS CLI as well as boto3. botocore package is the foundation for the AWS CLI as well as boto3.
%prep %prep
%autosetup -n %{pypi_name}-%{version} %autosetup -n %{pypi_name}-%{version} -p0
rm -vr %{pypi_name}.egg-info rm -vr %{pypi_name}.egg-info
# Remove online tests # Remove online tests
rm -vr tests/integration rm -vr tests/integration
@ -46,7 +48,6 @@ rm -vr tests/functional/leak
# -r use final runtime dependencies as BuildRequires # -r use final runtime dependencies as BuildRequires
%pyproject_buildrequires -r %pyproject_buildrequires -r
%build %build
%pyproject_wheel %pyproject_wheel
@ -65,6 +66,9 @@ nosetests-%{python3_version} unit functional
%{python3_sitelib}/%{pypi_name}-*.dist-info/ %{python3_sitelib}/%{pypi_name}-*.dist-info/
%changelog %changelog
* Wed Jan 13 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.19.53-2
- Patch to increase bucket test threshold.
* Wed Jan 13 08:29:49 CST 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.19.53-1 * Wed Jan 13 08:29:49 CST 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.19.53-1
- 1.19.53 - 1.19.53

Loading…
Cancel
Save