parent
61cdf6e8c5
commit
4a20480db3
@ -1,97 +0,0 @@
|
|||||||
From 0d6a559495203194128911071f7c2d0a21bd1500 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
|
||||||
Date: Fri, 25 Jul 2014 15:21:22 +0200
|
|
||||||
Subject: [PATCH] Do not use bundled requests
|
|
||||||
|
|
||||||
---
|
|
||||||
botocore/awsrequest.py | 12 ++++++------
|
|
||||||
botocore/compat.py | 2 +-
|
|
||||||
botocore/endpoint.py | 4 ++--
|
|
||||||
botocore/retryhandler.py | 4 ++--
|
|
||||||
botocore/utils.py | 2 +-
|
|
||||||
5 files changed, 12 insertions(+), 12 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/botocore/awsrequest.py b/botocore/awsrequest.py
|
|
||||||
index bf4a4da..ccc01a6 100644
|
|
||||||
--- a/botocore/awsrequest.py
|
|
||||||
+++ b/botocore/awsrequest.py
|
|
||||||
@@ -19,14 +19,14 @@ import socket
|
|
||||||
import inspect
|
|
||||||
|
|
||||||
from botocore.compat import six
|
|
||||||
-from botocore.vendored.requests import models
|
|
||||||
-from botocore.vendored.requests.sessions import REDIRECT_STATI
|
|
||||||
+from requests import models
|
|
||||||
+from requests.sessions import REDIRECT_STATI
|
|
||||||
from botocore.compat import HTTPHeaders, HTTPResponse
|
|
||||||
from botocore.exceptions import UnseekableStreamError
|
|
||||||
-from botocore.vendored.requests.packages.urllib3.connection import VerifiedHTTPSConnection
|
|
||||||
-from botocore.vendored.requests.packages.urllib3.connection import HTTPConnection
|
|
||||||
-from botocore.vendored.requests.packages.urllib3.connectionpool import HTTPConnectionPool
|
|
||||||
-from botocore.vendored.requests.packages.urllib3.connectionpool import HTTPSConnectionPool
|
|
||||||
+from urllib3.connection import VerifiedHTTPSConnection
|
|
||||||
+from urllib3.connection import HTTPConnection
|
|
||||||
+from urllib3.connectionpool import HTTPConnectionPool
|
|
||||||
+from urllib3.connectionpool import HTTPSConnectionPool
|
|
||||||
|
|
||||||
|
|
||||||
logger = logging.getLogger(__name__)
|
|
||||||
diff --git a/botocore/compat.py b/botocore/compat.py
|
|
||||||
index f759ccb..97adeb4 100644
|
|
||||||
--- a/botocore/compat.py
|
|
||||||
+++ b/botocore/compat.py
|
|
||||||
@@ -16,7 +16,7 @@ import datetime
|
|
||||||
import sys
|
|
||||||
import inspect
|
|
||||||
|
|
||||||
-from botocore.vendored import six
|
|
||||||
+import six
|
|
||||||
|
|
||||||
|
|
||||||
if six.PY3:
|
|
||||||
diff --git a/botocore/endpoint.py b/botocore/endpoint.py
|
|
||||||
index 963068d..9409499 100644
|
|
||||||
--- a/botocore/endpoint.py
|
|
||||||
+++ b/botocore/endpoint.py
|
|
||||||
@@ -17,8 +17,8 @@ import logging
|
|
||||||
import time
|
|
||||||
import threading
|
|
||||||
|
|
||||||
-from botocore.vendored.requests.sessions import Session
|
|
||||||
-from botocore.vendored.requests.utils import get_environ_proxies
|
|
||||||
+from requests.sessions import Session
|
|
||||||
+from requests.utils import get_environ_proxies
|
|
||||||
|
|
||||||
import botocore.response
|
|
||||||
import botocore.exceptions
|
|
||||||
diff --git a/botocore/retryhandler.py b/botocore/retryhandler.py
|
|
||||||
index 2505db2..c12d2e0 100644
|
|
||||||
--- a/botocore/retryhandler.py
|
|
||||||
+++ b/botocore/retryhandler.py
|
|
||||||
@@ -17,8 +17,8 @@ import functools
|
|
||||||
import logging
|
|
||||||
from binascii import crc32
|
|
||||||
|
|
||||||
-from botocore.vendored.requests import ConnectionError, Timeout
|
|
||||||
-from botocore.vendored.requests.packages.urllib3.exceptions import ClosedPoolError
|
|
||||||
+from requests import ConnectionError, Timeout
|
|
||||||
+from urllib3.exceptions import ClosedPoolError
|
|
||||||
|
|
||||||
from botocore.exceptions import ChecksumError
|
|
||||||
|
|
||||||
diff --git a/botocore/utils.py b/botocore/utils.py
|
|
||||||
index 91d5fd0..4c0db61 100644
|
|
||||||
--- a/botocore/utils.py
|
|
||||||
+++ b/botocore/utils.py
|
|
||||||
@@ -20,7 +20,7 @@ from dateutil.tz import tzlocal, tzutc
|
|
||||||
|
|
||||||
from botocore.exceptions import InvalidExpressionError, ConfigNotFound
|
|
||||||
from botocore.compat import json, quote
|
|
||||||
-from botocore.vendored import requests
|
|
||||||
+import requests
|
|
||||||
from botocore.compat import OrderedDict
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From 61098ed6590a80ef27ea95def98e7691cea811e8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
|
||||||
Date: Fri, 25 Jul 2014 15:11:57 +0200
|
|
||||||
Subject: [PATCH] botocore: Add some version requirements
|
|
||||||
|
|
||||||
---
|
|
||||||
setup.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
|
||||||
index b7a220f..d3758f1 100644
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -11,7 +11,7 @@ from setuptools import setup, find_packages
|
|
||||||
|
|
||||||
|
|
||||||
requires = ['jmespath==0.5.0',
|
|
||||||
- 'python-dateutil>=2.1,<3.0.0']
|
|
||||||
+ 'python-dateutil>=1.5,<3.0.0']
|
|
||||||
|
|
||||||
|
|
||||||
if sys.version_info[:2] == (2, 6):
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
Loading…
Reference in new issue