Added patch to fix parameter of build_list_params() (#647005)

f38
Robert Scheck 14 years ago
parent 0b559a9d07
commit da1ca05216

@ -0,0 +1,15 @@
The build_list_parameters function only contains half of the fix applied by upstream
commit 79f6a6cc7b2420440091. Specifically, line 78 refers to a function parameter that
was renamed. More details at: https://bugzilla.redhat.com/show_bug.cgi?id=647005
--- boto-1.9b/boto/ec2/blockdevicemapping.py 2009-12-16 17:21:40.000000000 +0100
+++ boto-1.9b/boto/ec2/blockdevicemapping.py.prefix 2010-11-18 21:59:07.000000000 +0100
@@ -75,7 +75,7 @@
def build_list_params(self, params, prefix=''):
i = 1
for dev_name in self:
- pre = '%sBlockDeviceMapping.%d' % (pre, i)
+ pre = '%sBlockDeviceMapping.%d' % (prefix, i)
params['%s.DeviceName' % pre] = dev_name
ebs = self[dev_name]
if ebs.snapshot_id:

@ -4,12 +4,13 @@
Summary: A simple lightweight interface to Amazon Web Services Summary: A simple lightweight interface to Amazon Web Services
Name: python-boto Name: python-boto
Version: 1.9b Version: 1.9b
Release: 3%{?dist} Release: 4%{?dist}
License: MIT License: MIT
Group: Development/Languages Group: Development/Languages
URL: http://code.google.com/p/%{pkgname}/ URL: http://code.google.com/p/%{pkgname}/
Source: http://boto.googlecode.com/files/%{pkgname}-%{version}.tar.gz Source: http://boto.googlecode.com/files/%{pkgname}-%{version}.tar.gz
Patch0: python-boto-1.9b-image.patch Patch0: python-boto-1.9b-image.patch
Patch1: python-boto-1.9b-prefix.patch
BuildRequires: python-devel, python-setuptools-devel BuildRequires: python-devel, python-setuptools-devel
BuildArch: noarch BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -24,6 +25,7 @@ use, lightweight wrapper around the Amazon services.
%prep %prep
%setup -q -n %{pkgname}-%{version} %setup -q -n %{pkgname}-%{version}
%patch0 -p1 -b .image %patch0 -p1 -b .image
%patch1 -p1 -b .prefix
%build %build
%{__python} setup.py build %{__python} setup.py build
@ -48,6 +50,9 @@ rm -rf $RPM_BUILD_ROOT
%{python_sitelib}/* %{python_sitelib}/*
%changelog %changelog
* Thu Nov 18 2010 Robert Scheck <robert@fedoraproject.org> 1.9b-4
- Added patch to fix parameter of build_list_params() (#647005)
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.9b-3 * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.9b-3
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild

Loading…
Cancel
Save