Initial import

f38
Robert Scheck 18 years ago
parent c59de582ad
commit 57b6ba2209

@ -0,0 +1 @@
boto-0.9b.tar.gz

@ -0,0 +1,29 @@
Patch by Robert Scheck <robert@fedoraproject.org> which makes boto >= 0.9b working
by using the older Python 2.3, that doesn't support the non-decorator syntax, which
is used at @staticmethod.
--- boto-0.9b/boto/mturk/connection.py 2007-06-04 23:19:27.000000000 +0200
+++ boto-0.9b/boto/mturk/connection.py.python23 2007-08-30 12:53:24.000000000 +0200
@@ -171,7 +171,6 @@
else:
raise EC2ResponseError(response.status, response.reason, body)
- @staticmethod
def get_keywords_as_string(keywords):
"""
Returns a comma+space-separated string of keywords from either a list or a string
@@ -185,8 +184,8 @@
else:
raise TypeError("keywords argument must be a string or a list of strings; got a %s" % type(keywords))
return final_keywords
+ get_keywords_as_string = staticmethod(get_keywords_as_string)
- @staticmethod
def get_price_as_price(reward):
"""
Returns a Price data structure from either a float or a Price
@@ -196,3 +195,4 @@
else:
final_price = Price(reward)
return final_price
+ get_price_as_price = staticmethod(get_price_as_price)

@ -0,0 +1,49 @@
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%define pkgname boto
Summary: A simple lightweight interface to Amazon Web Services
Name: python-boto
Version: 0.9b
Release: 1%{?dist}
License: MIT
Group: Development/Languages
URL: http://code.google.com/p/%{pkgname}/
Source: http://boto.googlecode.com/files/%{pkgname}-%{version}.tar.gz
Patch: python-boto-0.9b-python23.patch
BuildRequires: python-devel >= 2.3
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
Boto is a Python package that provides interfaces to Amazon Web Services.
It supports S3 (Simple Storage Service), SQS (Simple Queue Service) via
the REST API's provided by those services and EC2 (Elastic Compute Cloud)
via the Query API. The goal of boto is to provide a very simple, easy to
use, lightweight wrapper around the Amazon services.
%prep
%setup -q -n %{pkgname}-%{version}
%patch -p1 -b .python23
%build
%{__python} setup.py build
%install
rm -rf $RPM_BUILD_ROOT
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
# Remove all test scripts
rm -rf $RPM_BUILD_ROOT{%{_bindir},%{python_sitelib}/tests}
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc README
%{python_sitelib}/%{pkgname}/
%changelog
* Thu Aug 30 2007 Robert Scheck <robert@fedoraproject.org> 0.9b-1
- Upgrade to 0.9b
- Initial spec file for Fedora and Red Hat Enterprise Linux

@ -0,0 +1 @@
b7591fd2515dcd75fd01095473381c87 boto-0.9b.tar.gz
Loading…
Cancel
Save