Update F18 Puppet to 3.1.0

This is the update to 3.1.0 which is a working Puppet on Ruby 1.9.3.
This update differs from rawhide slightly in that we are keeping systemV
init scripts rather than using Systemd since this is an update within
F18.

Note that 2.7.x on F18 with F18's ruby did not work and was an
unsupported combination from upstream. This resolves that issue and
rebases Puppet. This is not backward compatible, but since 2.7.x of
Puppet didn't work, I thought it was probably ok.

Merge branch 'master' into f18

Conflicts:
	puppet.spec
	puppetmaster-old-client-compat.patch

Signed-off-by: Michael Stahnke <stahnma@puppetlabs.com>
epel9
Michael Stahnke 12 years ago
commit d40fa44259

3
.gitignore vendored

@ -1,5 +1,6 @@
*~ *~
*.rpm *.rpm
*.tar.gz *.tar.gz
*.tar.gz.ac *.tar.gz.asc
/puppet-*/
/.build*.log /.build*.log

@ -1,18 +0,0 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
Comment: GPGTools - http://gpgtools.org
iQIcBAABAgAGBQJQ24gaAAoJEBBUt6JL1uwwFBQP/Rnl+wuQW9cq7MC3JCGpNwNn
8RkUvEnFCCzvomfRd7LXhzJ4b/X0EPQNr5Kr3VNEDpHJgekLdddb+NJRec22FXnV
TV11sf6meeDBYMyYm0tz1+OXjW+eBLklRVtM9eHzP6B8OTcfmreGBGtMMexQkgch
QYVZYL8g4v9464K5KJ8kU+5Wa9vXfulfMNz0sPAcjCWaqu6whE+LoCd29pWkBhGf
q14fqmKJK2A8V8FyGrcUn/v6Pg2vLizS5gmna+1w7tHGfyDViKA9U4lj0nA/Y7/n
NISQk0l0VXlsrFoUtk3+TaOvAzvO0fQ3opwELvLsyBf+76JUZZqgbfUaNtk1l7sY
PR4plQRJ2hDIzKOvEkonnqHe8OnSTw0S3mdCxq8oVF5VUvgynpw3YNIfLrWVArNW
Zzskz/nfyD/oaJDimwi+JdgLcEInUJWws98ElgaLOBb43reirNXAgYCXl53jwf/e
dzOIyspL9OmrISoff0hvH2lP6RmJ5mX30KaIkNN0St9fhg/9dmI1NGB3vwiEJwyq
GdHd+j3ViZsgMW2nC2Wi258Wk6zMvNWKn+7rYWmaeZwwTLSYECI7oRtshuFKYirz
TpcIRBFuBbgoSX1rrt0DFhB6sQRzbDPaLl4DMeUdRw5OK+EkKVurfbenhkLqMO//
IQJbtEkNKqARBCpvuyKY
=ljH5
-----END PGP SIGNATURE-----

@ -2,6 +2,9 @@
# --without augeas and/or --without selinux to rpmbuild or mock # --without augeas and/or --without selinux to rpmbuild or mock
# F-17 and above have ruby-1.9.x, and place libs in a different location # F-17 and above have ruby-1.9.x, and place libs in a different location
# Specifically not using systemd on F18 as it's technically a break between
# using SystemV on 2.7.x and Systemd on 3.1.0.
%if 0%{?fedora} >= 17 %if 0%{?fedora} >= 17
%global puppet_libdir %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]') %global puppet_libdir %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
%else %else
@ -9,7 +12,7 @@
%endif %endif
# F-17 also ships with systemd; package/use systemd files in this case # F-17 also ships with systemd; package/use systemd files in this case
%if 0%{?fedora} >= 17 %if 0%{?fedora} > 18
%global _with_systemd 1 %global _with_systemd 1
%else %else
%global _with_systemd 0 %global _with_systemd 0
@ -19,8 +22,8 @@
%global ruby_version %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["ruby_version"]') %global ruby_version %(ruby -rrbconfig -e 'puts RbConfig::CONFIG["ruby_version"]')
Name: puppet Name: puppet
Version: 3.0.2 Version: 3.1.0
Release: 2%{?dist} Release: 3%{?dist}
Summary: A network tool for managing many disparate systems Summary: A network tool for managing many disparate systems
License: ASL 2.0 License: ASL 2.0
URL: http://puppetlabs.com URL: http://puppetlabs.com
@ -109,8 +112,9 @@ The server can also function as a certificate authority and file server.
patch -s -p1 < %{confdir}/rundir-perms.patch patch -s -p1 < %{confdir}/rundir-perms.patch
# Fix some rpmlint complaints # Fix some rpmlint complaints
for f in mac_dscl.pp mac_dscl_revert.pp \ for f in mac_automount.pp mcx_dock_absent.pp mcx_dock_default.pp \
mac_pkgdmg.pp ; do mcx_dock_full.pp mcx_dock_invalid.pp mcx_nogroup.pp \
mcx_notexists_absent.pp; do
sed -i -e'1d' examples/$f sed -i -e'1d' examples/$f
chmod a-x examples/$f chmod a-x examples/$f
done done
@ -119,12 +123,6 @@ for f in external/nagios.rb relationship.rb; do
done done
chmod +x ext/puppet-load.rb ext/regexp_nodes/regexp_nodes.rb chmod +x ext/puppet-load.rb ext/regexp_nodes/regexp_nodes.rb
find examples/ -type f -empty | xargs rm
find examples/ -type f | xargs chmod a-x
# puppet-queue.conf is more of an example, used for stompserver
mv conf/puppet-queue.conf examples/etc/puppet/
%build %build
# Nothing to build # Nothing to build
@ -255,6 +253,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/%{name}/modules
%{_mandir}/man8/puppet-resource_type.8.gz %{_mandir}/man8/puppet-resource_type.8.gz
%{_mandir}/man8/puppet-secret_agent.8.gz %{_mandir}/man8/puppet-secret_agent.8.gz
%{_mandir}/man8/puppet-status.8.gz %{_mandir}/man8/puppet-status.8.gz
%{_mandir}/man8/extlookup2hiera.8.gz
%files server %files server
%defattr(-, root, root, 0755) %defattr(-, root, root, 0755)
@ -352,9 +351,15 @@ fi
rm -rf %{buildroot} rm -rf %{buildroot}
%changelog %changelog
* Thu Mar 7 2013 Daniel Drake <dsd@laptop.org> - 3.0.2-2 * Thu Mar 07 2013 Michael Stahnke <stahnma@puppetlabs.com> - 3.1.0-3
- Disable systemd in F18 as per bz#873853
* Thu Mar 7 2013 Daniel Drake <dsd@laptop.org> - 3.1.0-2
- Improve server compatibility with old puppet clients (#831303) - Improve server compatibility with old puppet clients (#831303)
* Mon Feb 11 2013 Sam Kottler <shk@redhat.com> - 3.1.0-1
- Update to 3.1.0
* Tue Oct 30 2012 Moses Mendoza <moses@puppetlabs.com> - 3.0.2-1 * Tue Oct 30 2012 Moses Mendoza <moses@puppetlabs.com> - 3.0.2-1
- Update to 3.0.2 - Update to 3.0.2
- Update new dependencies (ruby >= 1.8.7, facter >= 1.6.6, hiera >= 1.0.0) - Update new dependencies (ruby >= 1.8.7, facter >= 1.6.6, hiera >= 1.0.0)

@ -19,12 +19,21 @@ setups.
lib/puppet/util/monkey_patches.rb | 9 +++++++++ lib/puppet/util/monkey_patches.rb | 9 +++++++++
1 file changed, 9 insertions(+) 1 file changed, 9 insertions(+)
<<<<<<< HEAD
Index: puppet-3.0.2/lib/puppet/util/monkey_patches.rb Index: puppet-3.0.2/lib/puppet/util/monkey_patches.rb
=================================================================== ===================================================================
--- puppet-3.0.2.orig/lib/puppet/util/monkey_patches.rb --- puppet-3.0.2.orig/lib/puppet/util/monkey_patches.rb
+++ puppet-3.0.2/lib/puppet/util/monkey_patches.rb +++ puppet-3.0.2/lib/puppet/util/monkey_patches.rb
@@ -310,3 +310,13 @@ if RUBY_VERSION == '1.8.5' @@ -310,3 +310,13 @@ if RUBY_VERSION == '1.8.5'
module_function :move module_function :move
=======
Index: puppet-3.1.0/lib/puppet/util/monkey_patches.rb
===================================================================
--- puppet-3.1.0.orig/lib/puppet/util/monkey_patches.rb
+++ puppet-3.1.0/lib/puppet/util/monkey_patches.rb
@@ -356,3 +356,13 @@ unless Dir.respond_to?(:mktmpdir)
end
>>>>>>> master
end end
end end
+ +

@ -1,2 +1,2 @@
c4507a83679df9f6c8409d97cc6ef757 puppet-3.0.2.tar.gz 4cbdcc9dfcda677c820175375a500651 puppet-3.1.0.tar.gz
ca2521e8af245f25cb54f5a167b0a183 puppet-3.0.2.tar.gz.asc d2e905ef5ae97b8b196f508082fb4680 puppet-3.1.0.tar.gz.asc

Loading…
Cancel
Save