i9c-beta-stream-16
changed/i9c-beta-stream-16/postgresql-16.1-1.module+el9.4.0+21089+0ca8f31a
commit
8fee3680df
@ -0,0 +1,3 @@
|
|||||||
|
SOURCES/postgresql-15.5.tar.bz2
|
||||||
|
SOURCES/postgresql-16.1.tar.bz2
|
||||||
|
SOURCES/postgresql-setup-8.9.tar.gz
|
@ -0,0 +1,3 @@
|
|||||||
|
1688b684c181a3173a3f2b76a12e83c8371facc8 SOURCES/postgresql-15.5.tar.bz2
|
||||||
|
7b335f3dbb9f566fa021f255650178b7c9642df2 SOURCES/postgresql-16.1.tar.bz2
|
||||||
|
ba5d21f1d9c02e2c21976e76bd3ded0f64988e01 SOURCES/postgresql-setup-8.9.tar.gz
|
@ -0,0 +1,69 @@
|
|||||||
|
#
|
||||||
|
# Simplified makefile for running the PostgreSQL regression tests
|
||||||
|
# in an RPM installation
|
||||||
|
#
|
||||||
|
|
||||||
|
# maximum simultaneous connections for parallel tests
|
||||||
|
MAXCONNOPT =
|
||||||
|
ifdef MAX_CONNECTIONS
|
||||||
|
MAXCONNOPT += --max-connections=$(MAX_CONNECTIONS)
|
||||||
|
endif
|
||||||
|
|
||||||
|
# locale
|
||||||
|
NOLOCALE =
|
||||||
|
ifdef NO_LOCALE
|
||||||
|
NOLOCALE += --no-locale
|
||||||
|
endif
|
||||||
|
|
||||||
|
srcdir := .
|
||||||
|
|
||||||
|
REGRESS_OPTS += --dlpath=.
|
||||||
|
|
||||||
|
pg_regress_locale_flags = $(if $(ENCODING),--encoding=$(ENCODING)) $(NOLOCALE)
|
||||||
|
|
||||||
|
pg_regress_installcheck = ./pg_regress --inputdir=$(srcdir) --bindir=@bindir@ $(pg_regress_locale_flags)
|
||||||
|
|
||||||
|
# Test input and expected files. These are created by pg_regress itself, so we
|
||||||
|
# don't have a rule to create them. We do need rules to clean them however.
|
||||||
|
ifile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/input/*.source)))
|
||||||
|
input_files := $(foreach file, $(ifile_list), sql/$(file).sql)
|
||||||
|
ofile_list := $(subst .source,, $(notdir $(wildcard $(srcdir)/output/*.source)))
|
||||||
|
output_files := $(foreach file, $(ofile_list), expected/$(file).out)
|
||||||
|
|
||||||
|
abs_srcdir := $(shell pwd)
|
||||||
|
abs_builddir := $(shell pwd)
|
||||||
|
|
||||||
|
check: installcheck-parallel
|
||||||
|
|
||||||
|
installcheck: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/serial_schedule $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
installcheck-parallel: cleandirs
|
||||||
|
$(pg_regress_installcheck) $(REGRESS_OPTS) --schedule=$(srcdir)/parallel_schedule $(MAXCONNOPT) $(EXTRA_TESTS)
|
||||||
|
|
||||||
|
# The tests command the server to write into testtablespace and results.
|
||||||
|
# On a SELinux-enabled system this will fail unless we mark those directories
|
||||||
|
# as writable by the server.
|
||||||
|
cleandirs:
|
||||||
|
-rm -rf testtablespace results
|
||||||
|
mkdir testtablespace results
|
||||||
|
if test -x /usr/bin/chcon && ! test -f /.dockerenv; then \
|
||||||
|
/usr/bin/chcon -u system_u -r object_r -t postgresql_db_t testtablespace results ; \
|
||||||
|
fi
|
||||||
|
|
||||||
|
# old interfaces follow...
|
||||||
|
|
||||||
|
runcheck: check
|
||||||
|
runtest: installcheck
|
||||||
|
runtest-parallel: installcheck-parallel
|
||||||
|
|
||||||
|
|
||||||
|
##
|
||||||
|
## Clean up
|
||||||
|
##
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
rm -f $(output_files) $(input_files)
|
||||||
|
rm -rf testtablespace
|
||||||
|
rm -rf results tmp_check log
|
||||||
|
rm -f regression.diffs regression.out regress.out run_check.out
|
@ -0,0 +1 @@
|
|||||||
|
8f53aa95d78eb8e82536ea46b68187793b42bba3b4f65aa342f540b23c9b10a6 postgresql-15.5.tar.bz2
|
@ -0,0 +1 @@
|
|||||||
|
ce3c4d85d19b0121fe0d3f8ef1fa601f71989e86f8a66f7dc3ad546dd5564fec postgresql-16.1.tar.bz2
|
@ -0,0 +1,4 @@
|
|||||||
|
[ -f /etc/profile ] && source /etc/profile
|
||||||
|
|
||||||
|
PGDATA=/var/lib/pgsql/data
|
||||||
|
export PGDATA
|
@ -0,0 +1,43 @@
|
|||||||
|
We don't build/install interfaces by upstream's implicit rules.
|
||||||
|
|
||||||
|
This patch is used on two places; postgresql.spec and libecpg.spec -- keep those
|
||||||
|
in sync!
|
||||||
|
|
||||||
|
Related: rhbz#1618698
|
||||||
|
|
||||||
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
|
index bcdbd95..4bea236 100644
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||||
|
backend/utils/mb/conversion_procs \
|
||||||
|
backend/snowball \
|
||||||
|
include \
|
||||||
|
- interfaces \
|
||||||
|
backend/replication/libpqwalreceiver \
|
||||||
|
backend/replication/pgoutput \
|
||||||
|
fe_utils \
|
||||||
|
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||||
|
index b9d86ac..29df69f 100644
|
||||||
|
--- a/src/Makefile.global.in
|
||||||
|
+++ b/src/Makefile.global.in
|
||||||
|
@@ -549,7 +549,7 @@ endif
|
||||||
|
# How to link to libpq. (This macro may be used as-is by backend extensions.
|
||||||
|
# Client-side code should go through libpq_pgport or libpq_pgport_shlib,
|
||||||
|
# instead.)
|
||||||
|
-libpq = -L$(libpq_builddir) -lpq
|
||||||
|
+libpq = -lpq
|
||||||
|
|
||||||
|
# libpq_pgport is for use by client executables (not libraries) that use libpq.
|
||||||
|
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||||
|
@@ -579,7 +579,6 @@ endif
|
||||||
|
# Commonly used submake targets
|
||||||
|
|
||||||
|
submake-libpq: | submake-generated-headers
|
||||||
|
- $(MAKE) -C $(libpq_builddir) all
|
||||||
|
|
||||||
|
submake-libpgport: | submake-generated-headers
|
||||||
|
$(MAKE) -C $(top_builddir)/src/port all
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
@ -0,0 +1,33 @@
|
|||||||
|
diff -ur postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample patched/src/backend/utils/misc/postgresql.conf.sample
|
||||||
|
--- postgresql-15.0/src/backend/utils/misc/postgresql.conf.sample 2022-10-10 22:57:37.000000000 +0200
|
||||||
|
+++ patched/src/backend/utils/misc/postgresql.conf.sample 2022-10-13 10:51:57.000000000 +0200
|
||||||
|
@@ -448,7 +448,7 @@
|
||||||
|
# logging_collector to be on.
|
||||||
|
|
||||||
|
# This is used when logging to stderr:
|
||||||
|
-#logging_collector = off # Enable capturing of stderr, jsonlog,
|
||||||
|
+logging_collector = on # Enable capturing of stderr, jsonlog,
|
||||||
|
# and csvlog into log files. Required
|
||||||
|
# to be on for csvlogs and jsonlogs.
|
||||||
|
# (change requires restart)
|
||||||
|
@@ -456,16 +456,16 @@
|
||||||
|
# These are only used if logging_collector is on:
|
||||||
|
#log_directory = 'log' # directory where log files are written,
|
||||||
|
# can be absolute or relative to PGDATA
|
||||||
|
-#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log' # log file name pattern,
|
||||||
|
+log_filename = 'postgresql-%a.log' # log file name pattern,
|
||||||
|
# can include strftime() escapes
|
||||||
|
#log_file_mode = 0600 # creation mode for log files,
|
||||||
|
# begin with 0 to use octal notation
|
||||||
|
-#log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_age = 1d # Automatic rotation of logfiles will
|
||||||
|
# happen after that time. 0 disables.
|
||||||
|
-#log_rotation_size = 10MB # Automatic rotation of logfiles will
|
||||||
|
+log_rotation_size = 0 # Automatic rotation of logfiles will
|
||||||
|
# happen after that much log output.
|
||||||
|
# 0 disables.
|
||||||
|
-#log_truncate_on_rotation = off # If on, an existing log file with the
|
||||||
|
+log_truncate_on_rotation = on # If on, an existing log file with the
|
||||||
|
# same name as the new log file will be
|
||||||
|
# truncated rather than appended to.
|
||||||
|
# But such truncation only occurs on
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -up postgresql-13.1/src/interfaces/Makefile.patch10 postgresql-13.1/src/interfaces/Makefile
|
||||||
|
--- postgresql-13.1/src/interfaces/Makefile.patch10 2021-02-02 21:33:23.235292305 +0100
|
||||||
|
+++ postgresql-13.1/src/interfaces/Makefile 2021-02-02 21:33:30.281365440 +0100
|
||||||
|
@@ -12,7 +12,7 @@ subdir = src/interfaces
|
||||||
|
top_builddir = ../..
|
||||||
|
include $(top_builddir)/src/Makefile.global
|
||||||
|
|
||||||
|
-SUBDIRS = libpq ecpg
|
||||||
|
+SUBDIRS = libpq
|
||||||
|
|
||||||
|
$(recurse)
|
||||||
|
|
@ -0,0 +1,57 @@
|
|||||||
|
We should ideally provide '/bin/pg_config' in postgresql-server-devel, and
|
||||||
|
provide no pg_config binary in libpq package. But most of the Fedora packages
|
||||||
|
that use pg_config actually only build against PG libraries (and
|
||||||
|
postgresql-server-devel isn't needed). So.., to avoid the initial rush around
|
||||||
|
rhbz#1618698 change, rather provide pg_server_config binary, which int urn means
|
||||||
|
that we'll have to fix only a minimal set of packages which really build
|
||||||
|
PostgreSQL server modules.
|
||||||
|
|
||||||
|
diff -ur postgresql-16beta1/src/bin/pg_config/Makefile postgresql16_pg_config_patch/src/bin/pg_config/Makefile
|
||||||
|
--- postgresql-16beta1/src/bin/pg_config/Makefile 2023-05-22 23:08:08.000000000 +0200
|
||||||
|
+++ postgresql16_pg_config_patch/src/bin/pg_config/Makefile 2023-06-05 13:51:30.000000000 +0200
|
||||||
|
@@ -11,6 +11,8 @@
|
||||||
|
PGFILEDESC = "pg_config - report configuration information"
|
||||||
|
PGAPPICON=win32
|
||||||
|
|
||||||
|
+PG_CONFIG = pg_server_config$(X)
|
||||||
|
+
|
||||||
|
subdir = src/bin/pg_config
|
||||||
|
top_builddir = ../../..
|
||||||
|
include $(top_builddir)/src/Makefile.global
|
||||||
|
@@ -19,22 +21,22 @@
|
||||||
|
$(WIN32RES) \
|
||||||
|
pg_config.o
|
||||||
|
|
||||||
|
-all: pg_config
|
||||||
|
+all: $(PG_CONFIG)
|
||||||
|
|
||||||
|
-pg_config: $(OBJS) | submake-libpgport
|
||||||
|
- $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
|
||||||
|
+$(PG_CONFIG): $(OBJS) | submake-libpgport
|
||||||
|
+ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@
|
||||||
|
|
||||||
|
install: all installdirs
|
||||||
|
- $(INSTALL_SCRIPT) pg_config$(X) '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ $(INSTALL_SCRIPT) $(PG_CONFIG) '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
installdirs:
|
||||||
|
$(MKDIR_P) '$(DESTDIR)$(bindir)'
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
- rm -f '$(DESTDIR)$(bindir)/pg_config$(X)'
|
||||||
|
+ rm -f '$(DESTDIR)$(bindir)/$(PG_CONFIG)'
|
||||||
|
|
||||||
|
clean distclean maintainer-clean:
|
||||||
|
- rm -f pg_config$(X) $(OBJS)
|
||||||
|
+ rm -f $(PG_CONFIG) $(OBJS)
|
||||||
|
rm -rf tmp_check
|
||||||
|
|
||||||
|
check:
|
||||||
|
diff -ur postgresql-16beta1/src/bin/pg_config/nls.mk postgresql16_pg_config_patch/src/bin/pg_config/nls.mk
|
||||||
|
--- postgresql-16beta1/src/bin/pg_config/nls.mk 2023-05-22 23:08:08.000000000 +0200
|
||||||
|
+++ postgresql16_pg_config_patch/src/bin/pg_config/nls.mk 2023-06-05 13:49:37.000000000 +0200
|
||||||
|
@@ -1,3 +1,3 @@
|
||||||
|
# src/bin/pg_config/nls.mk
|
||||||
|
-CATALOG_NAME = pg_config
|
||||||
|
+CATALOG_NAME = pg_server_config
|
||||||
|
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
@ -0,0 +1,50 @@
|
|||||||
|
Change the built-in default socket directory to be /var/run/postgresql.
|
||||||
|
For backwards compatibility with (probably non-libpq-based) clients that
|
||||||
|
might still expect to find the socket in /tmp, also create a socket in
|
||||||
|
/tmp. This is to resolve communication problems with clients operating
|
||||||
|
under systemd's PrivateTmp environment, which won't be using the same
|
||||||
|
global /tmp directory as the server; see bug #825448.
|
||||||
|
|
||||||
|
Note that we apply the socket directory change at the level of the
|
||||||
|
hard-wired defaults in the C code, not by just twiddling the setting in
|
||||||
|
postgresql.conf.sample; this is so that the change will take effect on
|
||||||
|
server package update, without requiring any existing postgresql.conf
|
||||||
|
to be updated. (Of course, a user who dislikes this behavior can still
|
||||||
|
override it via postgresql.conf.)
|
||||||
|
|
||||||
|
diff -ur -x 'cscope*' postgresql-16beta1/src/backend/utils/misc/guc_tables.c postgresql16_socket_patch/src/backend/utils/misc/guc_tables.c
|
||||||
|
--- postgresql-16beta1/src/backend/utils/misc/guc_tables.c 2023-05-22 23:08:08.000000000 +0200
|
||||||
|
+++ postgresql16_socket_patch/src/backend/utils/misc/guc_tables.c 2023-06-01 09:39:24.000000000 +0200
|
||||||
|
@@ -4300,7 +4300,7 @@
|
||||||
|
GUC_LIST_INPUT | GUC_LIST_QUOTE | GUC_SUPERUSER_ONLY
|
||||||
|
},
|
||||||
|
&Unix_socket_directories,
|
||||||
|
- DEFAULT_PGSOCKET_DIR,
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||||
|
NULL, NULL, NULL
|
||||||
|
},
|
||||||
|
|
||||||
|
diff -ur -x 'cscope*' postgresql-16beta1/src/bin/initdb/initdb.c postgresql16_socket_patch/src/bin/initdb/initdb.c
|
||||||
|
--- postgresql-16beta1/src/bin/initdb/initdb.c 2023-05-22 23:08:08.000000000 +0200
|
||||||
|
+++ postgresql16_socket_patch/src/bin/initdb/initdb.c 2023-06-01 09:42:16.000000000 +0200
|
||||||
|
@@ -1291,7 +1291,7 @@
|
||||||
|
* these are indeed defaults, keep the postgresql.conf lines commented.
|
||||||
|
*/
|
||||||
|
conflines = replace_guc_value(conflines, "unix_socket_directories",
|
||||||
|
- DEFAULT_PGSOCKET_DIR, true);
|
||||||
|
+ DEFAULT_PGSOCKET_DIR ", /tmp", true);
|
||||||
|
|
||||||
|
conflines = replace_guc_value(conflines, "port",
|
||||||
|
DEF_PGPORT_STR, true);
|
||||||
|
diff -ur -x 'cscope*' postgresql-16beta1/src/include/pg_config_manual.h postgresql16_socket_patch/src/include/pg_config_manual.h
|
||||||
|
--- postgresql-16beta1/src/include/pg_config_manual.h 2023-05-22 23:08:08.000000000 +0200
|
||||||
|
+++ postgresql16_socket_patch/src/include/pg_config_manual.h 2023-06-01 09:43:19.000000000 +0200
|
||||||
|
@@ -206,7 +206,7 @@
|
||||||
|
* support them yet.
|
||||||
|
*/
|
||||||
|
#ifndef WIN32
|
||||||
|
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||||
|
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||||
|
#else
|
||||||
|
#define DEFAULT_PGSOCKET_DIR ""
|
||||||
|
#endif
|
@ -0,0 +1,3 @@
|
|||||||
|
#%PAM-1.0
|
||||||
|
auth include password-auth
|
||||||
|
account include password-auth
|
@ -0,0 +1 @@
|
|||||||
|
d /run/postgresql 0755 postgres postgres -
|
@ -0,0 +1,72 @@
|
|||||||
|
For the RPMs, we want the custom installation directories to end in
|
||||||
|
/pgsql not /postgresql. This is historical but not worth changing.
|
||||||
|
|
||||||
|
Notice that this patch also makes the appending of /pgsql unconditional.
|
||||||
|
This is to avoid unexpected behavior if the RPM is built in a working
|
||||||
|
directory whose path happens to include "postgres" or "pgsql" already.
|
||||||
|
However, datadir and sysconfdir are already set up in the specfile's
|
||||||
|
configure call, so we do not have to append anything to them.
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in
|
||||||
|
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400
|
||||||
|
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400
|
||||||
|
@@ -55,8 +55,7 @@
|
||||||
|
# Installation directories
|
||||||
|
#
|
||||||
|
# These are set by the equivalent --xxxdir configure options. We
|
||||||
|
-# append "postgresql" to some of them, if the string does not already
|
||||||
|
-# contain "pgsql" or "postgres", in order to avoid directory clutter.
|
||||||
|
+# append "pgsql" to some of them, in order to avoid directory clutter.
|
||||||
|
#
|
||||||
|
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
||||||
|
# by configure, since the installation tree may have been relocated.
|
||||||
|
@@ -74,45 +73,23 @@
|
||||||
|
bindir := @bindir@
|
||||||
|
|
||||||
|
datadir := @datadir@
|
||||||
|
-ifeq "$(findstring pgsql, $(datadir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(datadir))" ""
|
||||||
|
-override datadir := $(datadir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
sysconfdir := @sysconfdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(sysconfdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(sysconfdir))" ""
|
||||||
|
-override sysconfdir := $(sysconfdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
|
||||||
|
libdir := @libdir@
|
||||||
|
|
||||||
|
pkglibdir = $(libdir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkglibdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkglibdir))" ""
|
||||||
|
-override pkglibdir := $(pkglibdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkglibdir := $(pkglibdir)/pgsql
|
||||||
|
|
||||||
|
includedir := @includedir@
|
||||||
|
|
||||||
|
pkgincludedir = $(includedir)
|
||||||
|
-ifeq "$(findstring pgsql, $(pkgincludedir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(pkgincludedir))" ""
|
||||||
|
-override pkgincludedir := $(pkgincludedir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override pkgincludedir := $(pkgincludedir)/pgsql
|
||||||
|
|
||||||
|
mandir := @mandir@
|
||||||
|
|
||||||
|
docdir := @docdir@
|
||||||
|
-ifeq "$(findstring pgsql, $(docdir))" ""
|
||||||
|
-ifeq "$(findstring postgres, $(docdir))" ""
|
||||||
|
-override docdir := $(docdir)/postgresql
|
||||||
|
-endif
|
||||||
|
-endif
|
||||||
|
+override docdir := $(docdir)/pgsql
|
||||||
|
|
||||||
|
htmldir := @htmldir@
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue