commit
23d076b19a
@ -0,0 +1 @@
|
|||||||
|
SOURCES/pa_stable_v19_20140130.tgz
|
@ -0,0 +1 @@
|
|||||||
|
526a7955de59016a06680ac24209ecb6ce05527d SOURCES/pa_stable_v19_20140130.tgz
|
@ -0,0 +1,21 @@
|
|||||||
|
# Makefile for source rpm: portaudio
|
||||||
|
# $Id$
|
||||||
|
NAME := portaudio
|
||||||
|
SPECFILE = $(firstword $(wildcard *.spec))
|
||||||
|
|
||||||
|
define find-makefile-common
|
||||||
|
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
|
||||||
|
endef
|
||||||
|
|
||||||
|
MAKEFILE_COMMON := $(shell $(find-makefile-common))
|
||||||
|
|
||||||
|
ifeq ($(MAKEFILE_COMMON),)
|
||||||
|
# attept a checkout
|
||||||
|
define checkout-makefile-common
|
||||||
|
test -f CVS/Rootx && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
|
||||||
|
endef
|
||||||
|
|
||||||
|
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
|
||||||
|
endif
|
||||||
|
|
||||||
|
include $(MAKEFILE_COMMON)
|
@ -0,0 +1,188 @@
|
|||||||
|
diff -wruN portaudio/include/pa_unix_oss.h portaudio-v19/include/pa_unix_oss.h
|
||||||
|
--- portaudio/include/pa_unix_oss.h 1969-12-31 18:00:00.000000000 -0600
|
||||||
|
+++ portaudio-v19/include/pa_unix_oss.h 2012-12-14 22:34:14.290247100 -0600
|
||||||
|
@@ -0,0 +1,52 @@
|
||||||
|
+#ifndef PA_UNIX_OSS_H
|
||||||
|
+#define PA_UNIX_OSS_H
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * $Id: portaudio.patch,v 1.10 2009-06-30 04:52:59 llucius Exp $
|
||||||
|
+ * PortAudio Portable Real-Time Audio Library
|
||||||
|
+ * OSS-specific extensions
|
||||||
|
+ *
|
||||||
|
+ * Copyright (c) 1999-2000 Ross Bencina and Phil Burk
|
||||||
|
+ *
|
||||||
|
+ * Permission is hereby granted, free of charge, to any person obtaining
|
||||||
|
+ * a copy of this software and associated documentation files
|
||||||
|
+ * (the "Software"), to deal in the Software without restriction,
|
||||||
|
+ * including without limitation the rights to use, copy, modify, merge,
|
||||||
|
+ * publish, distribute, sublicense, and/or sell copies of the Software,
|
||||||
|
+ * and to permit persons to whom the Software is furnished to do so,
|
||||||
|
+ * subject to the following conditions:
|
||||||
|
+ *
|
||||||
|
+ * The above copyright notice and this permission notice shall be
|
||||||
|
+ * included in all copies or substantial portions of the Software.
|
||||||
|
+ *
|
||||||
|
+ * Any person wishing to distribute modifications to the Software is
|
||||||
|
+ * requested to send the modifications to the original developer so that
|
||||||
|
+ * they can be incorporated into the canonical version.
|
||||||
|
+ *
|
||||||
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
||||||
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
||||||
|
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
|
||||||
|
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
|
||||||
|
+ * ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
|
||||||
|
+ * CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
|
||||||
|
+ * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
||||||
|
+ *
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/** @file
|
||||||
|
+ * OSS-specific PortAudio API extension header file.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#ifdef __cplusplus
|
||||||
|
+extern "C" {
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+const char *PaOSS_GetStreamInputDevice( PaStream *s );
|
||||||
|
+
|
||||||
|
+const char *PaOSS_GetStreamOutputDevice( PaStream *s );
|
||||||
|
+
|
||||||
|
+#ifdef __cplusplus
|
||||||
|
+}
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#endif
|
||||||
|
diff -wruN portaudio/include/portaudio.h portaudio-v19/include/portaudio.h
|
||||||
|
--- portaudio/include/portaudio.h 2012-08-31 19:10:13.000000000 -0500
|
||||||
|
+++ portaudio-v19/include/portaudio.h 2012-12-14 22:34:14.368247200 -0600
|
||||||
|
@@ -1146,6 +1146,15 @@
|
||||||
|
signed long Pa_GetStreamWriteAvailable( PaStream* stream );
|
||||||
|
|
||||||
|
|
||||||
|
+/** Retrieve the host type handling an open stream.
|
||||||
|
+
|
||||||
|
+ @return Returns a non-negative value representing the host API type
|
||||||
|
+ handling an open stream or, a PaErrorCode (which are always negative)
|
||||||
|
+ if PortAudio is not initialized or an error is encountered.
|
||||||
|
+*/
|
||||||
|
+PaHostApiTypeId Pa_GetStreamHostApiType( PaStream* stream );
|
||||||
|
+
|
||||||
|
+
|
||||||
|
/* Miscellaneous utilities */
|
||||||
|
|
||||||
|
|
||||||
|
diff -wruN portaudio/src/common/pa_front.c portaudio-v19/src/common/pa_front.c
|
||||||
|
--- portaudio/src/common/pa_front.c 2012-12-04 12:39:48.000000000 -0600
|
||||||
|
+++ portaudio-v19/src/common/pa_front.c 2012-12-14 09:44:34.604344800 -0600
|
||||||
|
@@ -1216,8 +1216,10 @@
|
||||||
|
hostApiInputParametersPtr, hostApiOutputParametersPtr,
|
||||||
|
sampleRate, framesPerBuffer, streamFlags, streamCallback, userData );
|
||||||
|
|
||||||
|
- if( result == paNoError )
|
||||||
|
+ if( result == paNoError ) {
|
||||||
|
AddOpenStream( *stream );
|
||||||
|
+ PA_STREAM_REP(*stream)->hostApiType = hostApi->info.type;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
|
||||||
|
PA_LOGAPI(("Pa_OpenStream returned:\n" ));
|
||||||
|
@@ -1729,6 +1731,32 @@
|
||||||
|
return result;
|
||||||
|
}
|
||||||
|
|
||||||
|
+PaHostApiTypeId Pa_GetStreamHostApiType( PaStream* stream )
|
||||||
|
+{
|
||||||
|
+ PaError error = PaUtil_ValidateStreamPointer( stream );
|
||||||
|
+ PaHostApiTypeId result;
|
||||||
|
+
|
||||||
|
+#ifdef PA_LOG_API_CALLS
|
||||||
|
+ PaUtil_DebugPrint("Pa_GetStreamHostApiType called:\n" );
|
||||||
|
+ PaUtil_DebugPrint("\tPaStream* stream: 0x%p\n", stream );
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+ if( error == paNoError )
|
||||||
|
+ {
|
||||||
|
+ result = PA_STREAM_REP(stream)->hostApiType;
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ {
|
||||||
|
+ result = (PaHostApiTypeId) error;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+#ifdef PA_LOG_API_CALLS
|
||||||
|
+ PaUtil_DebugPrint("Pa_GetStreamHostApiType returned:\n" );
|
||||||
|
+ PaUtil_DebugPrint("\tPaError: %d ( %s )\n\n", result, Pa_GetErrorText( result ) );
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+ return result;
|
||||||
|
+}
|
||||||
|
|
||||||
|
PaError Pa_GetSampleSize( PaSampleFormat format )
|
||||||
|
{
|
||||||
|
diff -wruN portaudio/src/common/pa_stream.c portaudio-v19/src/common/pa_stream.c
|
||||||
|
--- portaudio/src/common/pa_stream.c 2008-02-15 01:50:33.000000000 -0600
|
||||||
|
+++ portaudio-v19/src/common/pa_stream.c 2012-12-14 09:44:34.607345000 -0600
|
||||||
|
@@ -93,6 +93,8 @@
|
||||||
|
streamRepresentation->streamInfo.inputLatency = 0.;
|
||||||
|
streamRepresentation->streamInfo.outputLatency = 0.;
|
||||||
|
streamRepresentation->streamInfo.sampleRate = 0.;
|
||||||
|
+
|
||||||
|
+ streamRepresentation->hostApiType = 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
diff -wruN portaudio/src/common/pa_stream.h portaudio-v19/src/common/pa_stream.h
|
||||||
|
--- portaudio/src/common/pa_stream.h 2008-02-15 01:50:33.000000000 -0600
|
||||||
|
+++ portaudio-v19/src/common/pa_stream.h 2012-12-14 09:44:34.610345200 -0600
|
||||||
|
@@ -152,6 +152,7 @@
|
||||||
|
PaStreamFinishedCallback *streamFinishedCallback;
|
||||||
|
void *userData;
|
||||||
|
PaStreamInfo streamInfo;
|
||||||
|
+ PaHostApiTypeId hostApiType;
|
||||||
|
} PaUtilStreamRepresentation;
|
||||||
|
|
||||||
|
|
||||||
|
diff -wruN portaudio/src/hostapi/oss/pa_unix_oss.c portaudio-v19/src/hostapi/oss/pa_unix_oss.c
|
||||||
|
--- portaudio/src/hostapi/oss/pa_unix_oss.c 2011-05-02 12:07:11.000000000 -0500
|
||||||
|
+++ portaudio-v19/src/hostapi/oss/pa_unix_oss.c 2012-12-14 09:44:34.625346000 -0600
|
||||||
|
@@ -2028,3 +2028,26 @@
|
||||||
|
#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
+const char *PaOSS_GetStreamInputDevice( PaStream* s )
|
||||||
|
+{
|
||||||
|
+ PaOssStream *stream = (PaOssStream*)s;
|
||||||
|
+
|
||||||
|
+ if( stream->capture )
|
||||||
|
+ {
|
||||||
|
+ return stream->capture->devName;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return NULL;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+const char *PaOSS_GetStreamOutputDevice( PaStream* s )
|
||||||
|
+{
|
||||||
|
+ PaOssStream *stream = (PaOssStream*)s;
|
||||||
|
+
|
||||||
|
+ if( stream->playback )
|
||||||
|
+ {
|
||||||
|
+ return stream->playback->devName;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return NULL;
|
||||||
|
+}
|
||||||
|
diff -up portaudio/configure.in~ portaudio/configure.in
|
||||||
|
--- portaudio/configure.in~ 2013-04-07 12:20:18.000000000 +0200
|
||||||
|
+++ portaudio/configure.in 2013-05-04 15:14:14.356191153 +0200
|
||||||
|
@@ -387,7 +387,7 @@ case "${host_os}" in
|
||||||
|
DLL_LIBS="$DLL_LIBS -lasound"
|
||||||
|
LIBS="$LIBS -lasound"
|
||||||
|
OTHER_OBJS="$OTHER_OBJS src/hostapi/alsa/pa_linux_alsa.o"
|
||||||
|
- INCLUDES="$INCLUDES pa_linux_alsa.h"
|
||||||
|
+ INCLUDES="$INCLUDES pa_linux_alsa.h pa_unix_oss.h"
|
||||||
|
AC_DEFINE(PA_USE_ALSA,1)
|
||||||
|
fi
|
||||||
|
|
@ -0,0 +1,21 @@
|
|||||||
|
diff -Naupr portaudio.orig/Doxyfile portaudio/Doxyfile
|
||||||
|
--- portaudio.orig/Doxyfile 2006-08-23 10:15:11.000000000 +0200
|
||||||
|
+++ portaudio/Doxyfile 2008-12-22 14:11:16.558309299 +0100
|
||||||
|
@@ -124,7 +124,7 @@ GENERATE_HTML = YES
|
||||||
|
HTML_OUTPUT = html
|
||||||
|
HTML_FILE_EXTENSION = .html
|
||||||
|
HTML_HEADER =
|
||||||
|
-HTML_FOOTER =
|
||||||
|
+HTML_FOOTER = no_date_footer.html
|
||||||
|
HTML_STYLESHEET =
|
||||||
|
HTML_ALIGN_MEMBERS = YES
|
||||||
|
GENERATE_HTMLHELP = NO
|
||||||
|
diff -Naupr portaudio.orig/no_date_footer.html portaudio/no_date_footer.html
|
||||||
|
--- portaudio.orig/no_date_footer.html 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ portaudio/no_date_footer.html 2008-12-22 14:11:01.144246196 +0100
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+<hr size="1"><address style="text-align: right;"><small>Generated for $projectname by
|
||||||
|
+<a href="http://www.doxygen.org/index.html">
|
||||||
|
+<img src="doxygen.png" alt="doxygen" align="middle" border="0"></a>$doxygenversion</small></address>
|
||||||
|
+</body>
|
||||||
|
+</html>
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -up portaudio/portaudio-2.0.pc.in.alsa portaudio/portaudio-2.0.pc.in
|
||||||
|
--- portaudio/portaudio-2.0.pc.in.alsa 2011-05-05 11:55:28.000000000 +0200
|
||||||
|
+++ portaudio/portaudio-2.0.pc.in 2011-05-05 11:55:33.000000000 +0200
|
||||||
|
@@ -5,7 +5,7 @@ includedir=@includedir@
|
||||||
|
|
||||||
|
Name: PortAudio
|
||||||
|
Description: Portable audio I/O
|
||||||
|
-Requires:
|
||||||
|
+Requires: alsa
|
||||||
|
Version: 19
|
||||||
|
|
||||||
|
Libs: -L${libdir} -lportaudio @LIBS@
|
@ -0,0 +1,217 @@
|
|||||||
|
Name: portaudio
|
||||||
|
Version: 19
|
||||||
|
Release: 30%{?dist}
|
||||||
|
Summary: Free, cross platform, open-source, audio I/O library
|
||||||
|
License: MIT
|
||||||
|
URL: http://www.portaudio.com/
|
||||||
|
|
||||||
|
Source0: http://www.portaudio.com/archives/pa_stable_v19_20140130.tgz
|
||||||
|
Patch1: portaudio-doxynodate.patch
|
||||||
|
Patch2: portaudio-pkgconfig-alsa.patch
|
||||||
|
# Add some extra API needed by audacity
|
||||||
|
# http://audacity.googlecode.com/svn/audacity-src/trunk/lib-src/portmixer/portaudio.patch
|
||||||
|
Patch3: portaudio-audacity.patch
|
||||||
|
|
||||||
|
BuildRequires: doxygen
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: alsa-lib-devel
|
||||||
|
%if ! 0%{?rhel} > 7
|
||||||
|
BuildRequires: jack-audio-connection-kit-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
|
||||||
|
%description
|
||||||
|
PortAudio is a portable audio I/O library designed for cross-platform
|
||||||
|
support of audio. It uses a callback mechanism to request audio processing.
|
||||||
|
Audio can be generated in various formats, including 32 bit floating point,
|
||||||
|
and will be converted to the native format internally.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for the portaudio audio I/O library
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
PortAudio is a portable audio I/O library designed for cross-platform
|
||||||
|
support of audio. It uses a callback mechanism to request audio processing.
|
||||||
|
Audio can be generated in various formats, including 32 bit floating point,
|
||||||
|
and will be converted to the native format internally.
|
||||||
|
|
||||||
|
This package contains files required to build applications that will use the
|
||||||
|
portaudio library.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
# Needed for patch3
|
||||||
|
autoreconf -i -f
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static --enable-cxx
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' bindings/cpp/libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' bindings/cpp/libtool
|
||||||
|
# no -j# because building with -j# is broken
|
||||||
|
make
|
||||||
|
# Build html devel documentation
|
||||||
|
doxygen
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE.txt
|
||||||
|
%doc README.txt
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc doc/html/*
|
||||||
|
%{_includedir}/portaudiocpp/
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%exclude %{_libdir}/*.la
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Feb 27 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 19-30
|
||||||
|
- Rebuilt for MSVSphere 8.9
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 19-30
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 19-29
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 19-28
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 19-27
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 19-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 19-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 19-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 19-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 19-21
|
||||||
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 22 2014 Hans de Goede <hdegoede@redhat.com> - 19-19
|
||||||
|
- Upgrade to the "stable" v19_20140130 snapshot (rhbz#1111780)
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 4 2013 Hans de Goede <hdegoede@redhat.com> - 19-16
|
||||||
|
- Add a patch from audacity adding some extra API calls audacity needs
|
||||||
|
- Cleanup spec-file
|
||||||
|
- Update svn snapshot to bring in some alsa samplerate handling fixes
|
||||||
|
- Run autoreconf for aarch64 support (rhbz#926363)
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 05 2011 Dan Horák <dan[at]danny.cz> - 19-12
|
||||||
|
- fix dependency on alsa-lib-devel
|
||||||
|
|
||||||
|
* Sun Mar 27 2011 Hans de Goede <hdegoede@redhat.com> - 19-11
|
||||||
|
- Upgrade to a more recent snapshot to bring in various bugfixes (rhbz#691148)
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 19-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 22 2008 Matthias Saou <http://freshrpms.net/> 19-7
|
||||||
|
- Add Doxyfile patch to remove date in footer and fix multilib (#342931).
|
||||||
|
|
||||||
|
* Sun Dec 7 2008 Hans de Goede <hdegoede@redhat.com> 19-6
|
||||||
|
- Add a patch by Kevin Kofler to make non mmap alsa (and thus pulseaudio) work
|
||||||
|
(bz 445644)
|
||||||
|
|
||||||
|
* Sun Feb 3 2008 Matthias Saou <http://freshrpms.net/> 19-5
|
||||||
|
- Update to "stable" v19_20071207.
|
||||||
|
- Rebuild against latest jack in rawhide (#430672).
|
||||||
|
- Backport update to F8 too (#431266).
|
||||||
|
|
||||||
|
* Mon Dec 10 2007 Matthias Saou <http://freshrpms.net/> 19-4
|
||||||
|
- Include portaudiocpp library and headers (#413681).
|
||||||
|
|
||||||
|
* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 19-3
|
||||||
|
- Rebuild for new BuildID feature.
|
||||||
|
|
||||||
|
* Sun Aug 5 2007 Matthias Saou <http://freshrpms.net/> 19-2
|
||||||
|
- Update License field.
|
||||||
|
|
||||||
|
* Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 19-1
|
||||||
|
- Update to "stable" v19_061121.
|
||||||
|
- Switch virtual devel provide to a real sub-package.
|
||||||
|
- Update spec to match build changes from custom Makefile to autotools.
|
||||||
|
- Include new pkgconfig file and require pkgconfig from the devel package.
|
||||||
|
- Add ldconfig calls now that we have a versionned shared library.
|
||||||
|
- Rebuild against alsa-lib and jack-audio-connection-kit.
|
||||||
|
- Build doxygen documentation and include it in the devel package.
|
||||||
|
|
||||||
|
* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 18.1-8
|
||||||
|
- FC6 rebuild.
|
||||||
|
|
||||||
|
* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 18.1-7
|
||||||
|
- FC5 rebuild.
|
||||||
|
|
||||||
|
* Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 18.1-6
|
||||||
|
- Rebuild for new gcc/glibc.
|
||||||
|
|
||||||
|
* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 18.1-5
|
||||||
|
- rebuild on all arches
|
||||||
|
|
||||||
|
* Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 18.1-4
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Tue Nov 16 2004 Matthias Saou <http://freshrpms.net/> 18.1-3
|
||||||
|
- Bump release to provide Extras upgrade path.
|
||||||
|
|
||||||
|
* Fri Nov 5 2004 Matthias Saou <http://freshrpms.net/> 18.1-2
|
||||||
|
- Add -devel provides.
|
||||||
|
- Fix .so 644 mode (overidden in defattr).
|
||||||
|
|
||||||
|
* Thu Jun 10 2004 Dag Wieers <dag@wieers.com> - 18.1-1
|
||||||
|
- Added -fPIC for x86_64.
|
||||||
|
|
||||||
|
* Sat Sep 13 2003 Dag Wieers <dag@wieers.com> - 18.1-0
|
||||||
|
- Initial package. (using DAR)
|
||||||
|
|
Loading…
Reference in new issue