commit
b80eec626f
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/poppler-24.02.0.tar.xz
|
||||||
|
SOURCES/poppler-test-2021-01-11-03a4b9eb854a06a83c465e82de601796c458bbe9.tar.xz
|
@ -0,0 +1,2 @@
|
|||||||
|
c1d39286dc67245274c9ab698cb910ed2aff18d8 SOURCES/poppler-24.02.0.tar.xz
|
||||||
|
4f8e2304626c0229e2f5f02a39d6e6b93620326b SOURCES/poppler-test-2021-01-11-03a4b9eb854a06a83c465e82de601796c458bbe9.tar.xz
|
@ -0,0 +1,12 @@
|
|||||||
|
--- poppler-0.90.0/CMakeLists.txt
|
||||||
|
+++ poppler-0.90.0/CMakeLists.txt
|
||||||
|
@@ -17,6 +17,9 @@ else()
|
||||||
|
|
||||||
|
include(MacroOptionalFindPackage)
|
||||||
|
find_package(PkgConfig)
|
||||||
|
+
|
||||||
|
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
||||||
|
+
|
||||||
|
include(TestBigEndian)
|
||||||
|
test_big_endian(WORDS_BIGENDIAN)
|
||||||
|
include(CheckFileOffsetBits)
|
@ -0,0 +1,11 @@
|
|||||||
|
--- poppler-21.01.0/glib/CMakeLists.txt
|
||||||
|
+++ poppler-21.01.0/glib/CMakeLists.txt
|
||||||
|
@@ -121,7 +121,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_
|
||||||
|
|
||||||
|
# General gir: Reset object-list for introspection & load tool args
|
||||||
|
set(INTROSPECTION_GIRS)
|
||||||
|
- set(INTROSPECTION_SCANNER_ARGS "--add-include-path=${CMAKE_CURRENT_SOURCE_DIR}" "--warn-all")
|
||||||
|
+ set(INTROSPECTION_SCANNER_ARGS "--add-include-path=${CMAKE_CURRENT_SOURCE_DIR}" "--warn-all" "--sources-top-dirs=${CMAKE_SOURCE_DIR}" "--sources-top-dirs=${CMAKE_BINARY_DIR}")
|
||||||
|
set(INTROSPECTION_COMPILER_ARGS ${INTROSPECTION_COMPILER_ARGS} "--includedir=${CMAKE_CURRENT_SOURCE_DIR}")
|
||||||
|
|
||||||
|
# Poppler: Assign package to gir & export keys
|
@ -0,0 +1,102 @@
|
|||||||
|
From 0554731052d1a97745cb179ab0d45620589dd9c4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Albert Astals Cid <aacid@kde.org>
|
||||||
|
Date: Fri, 7 Jun 2024 00:54:55 +0200
|
||||||
|
Subject: pdfinfo: Fix crash in broken documents when using -dests
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/utils/pdfinfo.cc b/utils/pdfinfo.cc
|
||||||
|
index 5d37ef64..7d569749 100644
|
||||||
|
--- a/utils/pdfinfo.cc
|
||||||
|
+++ b/utils/pdfinfo.cc
|
||||||
|
@@ -15,7 +15,7 @@
|
||||||
|
// under GPL version 2 or later
|
||||||
|
//
|
||||||
|
// Copyright (C) 2006 Dom Lachowicz <cinamod@hotmail.com>
|
||||||
|
-// Copyright (C) 2007-2010, 2012, 2016-2022 Albert Astals Cid <aacid@kde.org>
|
||||||
|
+// Copyright (C) 2007-2010, 2012, 2016-2022, 2024 Albert Astals Cid <aacid@kde.org>
|
||||||
|
// Copyright (C) 2010 Hib Eris <hib@hiberis.nl>
|
||||||
|
// Copyright (C) 2011 Vittal Aithal <vittal.aithal@cognidox.com>
|
||||||
|
// Copyright (C) 2012, 2013, 2016-2018, 2021 Adrian Johnson <ajohnson@redneon.com>
|
||||||
|
@@ -113,16 +113,21 @@ static const ArgDesc argDesc[] = { { "-f", argInt, &firstPage, 0, "first page to
|
||||||
|
{ "-?", argFlag, &printHelp, 0, "print usage information" },
|
||||||
|
{} };
|
||||||
|
|
||||||
|
-static void printTextString(const GooString *s, const UnicodeMap *uMap)
|
||||||
|
+static void printStdTextString(const std::string &s, const UnicodeMap *uMap)
|
||||||
|
{
|
||||||
|
char buf[8];
|
||||||
|
- std::vector<Unicode> u = TextStringToUCS4(s->toStr());
|
||||||
|
+ const std::vector<Unicode> u = TextStringToUCS4(s);
|
||||||
|
for (const auto &c : u) {
|
||||||
|
int n = uMap->mapUnicode(c, buf, sizeof(buf));
|
||||||
|
fwrite(buf, 1, n, stdout);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+static void printTextString(const GooString *s, const UnicodeMap *uMap)
|
||||||
|
+{
|
||||||
|
+ printStdTextString(s->toStr(), uMap);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static void printUCS4String(const Unicode *u, int len, const UnicodeMap *uMap)
|
||||||
|
{
|
||||||
|
char buf[8];
|
||||||
|
@@ -294,11 +299,6 @@ static void printStruct(const StructElement *element, unsigned indent)
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
-struct GooStringCompare
|
||||||
|
-{
|
||||||
|
- bool operator()(GooString *lhs, GooString *rhs) const { return lhs->cmp(const_cast<GooString *>(rhs)) < 0; }
|
||||||
|
-};
|
||||||
|
-
|
||||||
|
static void printLinkDest(const std::unique_ptr<LinkDest> &dest)
|
||||||
|
{
|
||||||
|
GooString s;
|
||||||
|
@@ -369,29 +369,25 @@ static void printLinkDest(const std::unique_ptr<LinkDest> &dest)
|
||||||
|
|
||||||
|
static void printDestinations(PDFDoc *doc, const UnicodeMap *uMap)
|
||||||
|
{
|
||||||
|
- std::map<Ref, std::map<GooString *, std::unique_ptr<LinkDest>, GooStringCompare>> map;
|
||||||
|
+ std::map<Ref, std::map<std::string, std::unique_ptr<LinkDest>>> map;
|
||||||
|
|
||||||
|
int numDests = doc->getCatalog()->numDestNameTree();
|
||||||
|
for (int i = 0; i < numDests; i++) {
|
||||||
|
- GooString *name = new GooString(doc->getCatalog()->getDestNameTreeName(i));
|
||||||
|
+ const GooString *name = doc->getCatalog()->getDestNameTreeName(i);
|
||||||
|
std::unique_ptr<LinkDest> dest = doc->getCatalog()->getDestNameTreeDest(i);
|
||||||
|
- if (dest && dest->isPageRef()) {
|
||||||
|
+ if (name && dest && dest->isPageRef()) {
|
||||||
|
Ref pageRef = dest->getPageRef();
|
||||||
|
- map[pageRef].insert(std::make_pair(name, std::move(dest)));
|
||||||
|
- } else {
|
||||||
|
- delete name;
|
||||||
|
+ map[pageRef].insert(std::make_pair(name->toStr(), std::move(dest)));
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
numDests = doc->getCatalog()->numDests();
|
||||||
|
for (int i = 0; i < numDests; i++) {
|
||||||
|
- GooString *name = new GooString(doc->getCatalog()->getDestsName(i));
|
||||||
|
+ const char *name = doc->getCatalog()->getDestsName(i);
|
||||||
|
std::unique_ptr<LinkDest> dest = doc->getCatalog()->getDestsDest(i);
|
||||||
|
- if (dest && dest->isPageRef()) {
|
||||||
|
+ if (name && dest && dest->isPageRef()) {
|
||||||
|
Ref pageRef = dest->getPageRef();
|
||||||
|
map[pageRef].insert(std::make_pair(name, std::move(dest)));
|
||||||
|
- } else {
|
||||||
|
- delete name;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -405,9 +401,8 @@ static void printDestinations(PDFDoc *doc, const UnicodeMap *uMap)
|
||||||
|
printf("%4d ", i);
|
||||||
|
printLinkDest(it.second);
|
||||||
|
printf(" \"");
|
||||||
|
- printTextString(it.first, uMap);
|
||||||
|
+ printStdTextString(it.first, uMap);
|
||||||
|
printf("\"\n");
|
||||||
|
- delete it.first;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue