Add patch to fix pkg-config file

epel9
Sandro Mani 6 years ago
parent 4fc43e752b
commit fe69905b7e

@ -1,6 +1,6 @@
Name: podofo
Version: 0.9.6
Release: 6%{?dist}
Release: 7%{?dist}
Summary: Tools and libraries to work with the PDF file format
# The library is licensed under the LGPL.
@ -13,6 +13,8 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.
Patch0: podofo-0.9.4-freetype.patch
# Don't attempt to copy non-existing testdata dir
Patch1: podofo_tests.patch
# Fix pkg-config file
Patch2: podofo_pkgconfig.patch
# Backport patch for CVE-2018-5783
# https://sourceforge.net/p/podofo/code/1949
@ -151,10 +153,13 @@ find doc/html -exec touch -r %{SOURCE0} {} \;
%doc doc/html examples
%{_includedir}/%{name}
%{_libdir}/*.so
%{_libdir}/pkgconfig/lib%{name}-0.pc
%{_libdir}/pkgconfig/lib%{name}.pc
%changelog
* Mon May 27 2019 Sandro Mani <manisandro@gmail.com> - 0.9.6-7
- Fix pkg-config file
* Wed Mar 13 2019 Sandro Mani <manisandro@gmail.com> - 0.9.6-6
- Backport security fixes: CVE-2019-9199, CVE-2019-9687

@ -0,0 +1,31 @@
Description: Fix pkg-config to actually work with the way podofo is installed
Author: Mattia Rizzolo <mattia@debian.org>
Bug: https://sourceforge.net/p/podofo/tickets/30
Bug-Debian: https://bugs.debian.org/908134
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libpodofo/+bug/1792407
Last-Update: 2018-09-18
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -314,10 +314,10 @@
MESSAGE("Pkg-config found, creating a pkg-config file for linking against shared library.")
CONFIGURE_FILE(
"libpodofo.pc.in"
- "${PoDoFo_BINARY_DIR}/libpodofo-${PODOFO_VERSION_MAJOR}.pc"
+ "${PoDoFo_BINARY_DIR}/libpodofo.pc"
@ONLY)
INSTALL(
- FILES "${PoDoFo_BINARY_DIR}/libpodofo-${PODOFO_VERSION_MAJOR}.pc"
+ FILES "${PoDoFo_BINARY_DIR}/libpodofo.pc"
DESTINATION "${LIBDIRNAME}/pkgconfig")
ELSE(PKG_CONFIG_FOUND)
MESSAGE("Pkg-config not found. No pkg-config file will be created.")
--- a/src/libpodofo.pc.in
+++ b/src/libpodofo.pc.in
@@ -6,5 +6,5 @@
Name: @CMAKE_PROJECT_NAME@
Description: A C++ library to work with the PDF file format
Version: @PODOFO_VERSION@
-Libs: -L${libdir} -lpodofo-@PODOFO_VERSION_MAJOR@
+Libs: -L${libdir} -lpodofo
Cflags: -I${includedir}
Loading…
Cancel
Save