- spec cleanup
epel9
Dan Horák 11 years ago
parent 7df6ff0224
commit e0a13c8baa

@ -0,0 +1,23 @@
diff -up podofo-0.9.1/CMakeLists.txt.freetype podofo-0.9.1/CMakeLists.txt
--- podofo-0.9.1/CMakeLists.txt.freetype 2011-04-26 20:02:47.000000000 +0200
+++ podofo-0.9.1/CMakeLists.txt 2014-06-10 13:53:44.563899433 +0200
@@ -351,8 +351,8 @@ ENDIF(CppUnit_FOUND)
FIND_PACKAGE(OpenSSL)
-FIND_PACKAGE(FREETYPE REQUIRED)
-MESSAGE("Found freetype library at ${FREETYPE_LIBRARIES}, headers ${FREETYPE_INCLUDE_DIR}")
+FIND_PACKAGE(Freetype REQUIRED)
+MESSAGE("Found freetype library at ${FREETYPE_LIBRARIES}, headers ${FREETYPE_INCLUDE_DIRS}")
FIND_PACKAGE(LIBSTLPORT)
SET(stlport_libraries_if_use_stlport)
@@ -448,7 +448,7 @@ INCLUDE_DIRECTORIES(
${PoDoFo_BINARY_DIR}
${PoDoFo_SOURCE_DIR}
${PoDoFo_SOURCE_DIR}/src
- ${FREETYPE_INCLUDE_DIR}
+ ${FREETYPE_INCLUDE_DIRS}
${ZLIB_INCLUDE_DIR}
${EXTRA_INCLUDES}
)

@ -1,6 +1,6 @@
Name: podofo Name: podofo
Version: 0.9.1 Version: 0.9.1
Release: 13%{?dist} Release: 14%{?dist}
Summary: Tools and libraries to work with the PDF file format Summary: Tools and libraries to work with the PDF file format
Group: Applications/Publishing Group: Applications/Publishing
@ -9,7 +9,7 @@ URL: http://podofo.sourceforge.net
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Patch0: %{name}-0.9.1-unistd.patch Patch0: %{name}-0.9.1-unistd.patch
Patch1: %{name}-0.9.1-lua52.patch Patch1: %{name}-0.9.1-lua52.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Patch2: %{name}-0.9.1-freetype.patch
BuildRequires: cmake BuildRequires: cmake
BuildRequires: zlib-devel BuildRequires: zlib-devel
@ -60,10 +60,15 @@ Development files and documentation for the %{name} library.
%setup -q %setup -q
%patch0 -p1 -b .unistd %patch0 -p1 -b .unistd
%patch1 -p1 -b .lua52 %patch1 -p1 -b .lua52
%patch2 -p1 -b .freetype
# disable timestamps in docs # disable timestamps in docs
echo "HTML_TIMESTAMP = NO" >> Doxyfile echo "HTML_TIMESTAMP = NO" >> Doxyfile
# switch to system provided files
rm cmake/modules/FindFREETYPE.cmake
rm cmake/modules/FindZLIB.cmake
%build %build
%cmake -DPODOFO_BUILD_SHARED=1 \ %cmake -DPODOFO_BUILD_SHARED=1 \
@ -81,37 +86,34 @@ find doc/html -exec touch -r %{SOURCE0} {} \;
%install %install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT make install DESTDIR=$RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
%post libs -p /sbin/ldconfig %post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig %postun libs -p /sbin/ldconfig
%files %files
%defattr(-,root,root,-)
%doc COPYING %doc COPYING
%{_bindir}/%{name}* %{_bindir}/%{name}*
%{_mandir}/man1/%{name}*.1* %{_mandir}/man1/%{name}*.1*
%files libs %files libs
%defattr(-,root,root,-)
%doc AUTHORS COPYING.LIB ChangeLog FAQ.html README.html TODO %doc AUTHORS COPYING.LIB ChangeLog FAQ.html README.html TODO
%{_libdir}/*.so.* %{_libdir}/*.so.*
%files devel %files devel
%defattr(-,root,root,-)
%doc doc/html %doc doc/html
%{_includedir}/%{name} %{_includedir}/%{name}
%{_libdir}/*.so %{_libdir}/*.so
%changelog %changelog
* Tue Jun 10 2014 Dan Horák <dan[at]danny.cz> - 0.9.1-14
- fix FTBFS (#1106651)
- spec cleanup
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-13 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Loading…
Cancel
Save