New bug fix release.

epel9
Sérgio Basto 10 years ago
parent 1e7f90c65b
commit 1525f2fc12

@ -44,17 +44,8 @@
# DEBUG
if [ -z "$DEBUG" ]; then
--- ./Makefile.orig 2014-10-14 02:15:03.000000000 +0100
+++ ./Makefile 2014-10-17 21:50:58.450930108 +0100
@@ -1,7 +1,7 @@
-include config.mk
BIN ?= pngquant
-BINPREFIX = $(PREFIX)/bin
+BINPREFIX = $(DESTDIR)/$(PREFIX)/bin
OBJS = pngquant.o rwpng.o
COCOA_OBJS = rwpng_cocoa.o
--- ./Makefile.orig 2015-01-06 16:13:51.000000000 +0000
+++ ./Makefile 2015-01-06 23:10:30.660389846 +0000
@@ -11,6 +11,8 @@ OBJS += $(COCOA_OBJS)
endif
@ -74,7 +65,7 @@
$(OBJS): $(wildcard *.h) config.mk
rwpng_cocoa.o: rwpng_cocoa.m
$(CC) -Wno-enum-conversion -c $(CFLAGS) -o $@ $< || clang -Wno-enum-conversion -c -O3 -o $@ $<
$(CC) -Wno-enum-conversion -c $(CFLAGS) -o $@ $< || clang -Wno-enum-conversion -c -O3 $(CFLAGS) -o $@ $<
-$(BIN): $(STATICLIB) $(OBJS)
- $(CC) $(OBJS) $(LDFLAGS) -o $@

@ -1,7 +1,7 @@
%global libname libimagequant
Name: pngquant
Version: 2.3.1
Version: 2.3.2
Release: 1%{?dist}
Summary: PNG quantization tool for reducing image file size
%{?el5:Group: Applications/Multimedia}
@ -9,9 +9,9 @@ Summary: PNG quantization tool for reducing image file size
License: BSD with advertising
URL: http://%{name}.org
Source0: http://github.srcurl.net/pornel/%{name}/%{version}/%{name}-%{version}.tar.gz
Source0: https://github.com/pornel/pngquant/archive/%{name}-%{version}.tar.gz
Patch0: %{name}-2.3.0_fix-Makefile.patch
Patch0: %{name}-2.3.2_fix-Makefile.patch
%{?el5:BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)}
@ -62,11 +62,12 @@ rm lib/configure
%build
# this configure export compiler-flags properly
%configure || :
# export compiler-flags properly
./configure --prefix=/usr \
./configure --prefix=%{_prefix} --enable-debug \
%ifarch %{ix86}
--disable-sse \
--disable-sse
%endif
make %{?_smp_mflags} PREFIX=%{_prefix}
@ -94,6 +95,10 @@ install -pm 0644 lib/*.h \
install -pm 0644 %{name}.1 \
%{buildroot}/%{_mandir}/man1/%{name}.1
mkdir -p %{buildroot}/%{_bindir}
make install PREFIX=%{_prefix} DESTDIR=%{buildroot}
install -Dpm0755 pngquant %{buildroot}/%{_bindir}/pngquant
install -Dpm0644 pngquant.1 %{buildroot}/%{_mandir}/man1/pngquant.1
%clean
%{?el5:rm -rf %{buildroot}}
@ -120,6 +125,9 @@ install -pm 0644 %{name}.1 \
%changelog
* Wed Jan 07 2015 Sérgio Basto <sergio@serjux.com> - 2.3.2-1
- New bug fix release.
* Fri Oct 17 2014 Sérgio Basto <sergio@serjux.com> - 2.3.1-1
- New bug fixing release

@ -1 +1 @@
f2c2fb8a304006ab3d2abbc36cec8fc0 pngquant-2.3.1.tar.gz
89d45e7a736320e54dca4cc7b2b093e8 pngquant-2.3.2.tar.gz

Loading…
Cancel
Save