commit
b680fc7461
@ -0,0 +1 @@
|
|||||||
|
SOURCES/plotutils-2.6.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
7921301d9dfe8991e3df2829bd733df6b2a70838 SOURCES/plotutils-2.6.tar.gz
|
@ -0,0 +1,39 @@
|
|||||||
|
diff -up plotutils-2.6/libplot/z_write.c.png15 plotutils-2.6/libplot/z_write.c
|
||||||
|
--- plotutils-2.6/libplot/z_write.c.png15 2008-07-15 20:54:10.000000000 -0400
|
||||||
|
+++ plotutils-2.6/libplot/z_write.c 2012-03-22 13:26:48.251676137 -0400
|
||||||
|
@@ -164,7 +164,11 @@ _pl_z_maybe_output_image (S___(Plotter *
|
||||||
|
}
|
||||||
|
|
||||||
|
/* cleanup after libpng errors (error handler does a longjmp) */
|
||||||
|
+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
|
||||||
|
+ if (setjmp (png_jmpbuf(png_ptr)))
|
||||||
|
+#else
|
||||||
|
if (setjmp (png_ptr->jmpbuf))
|
||||||
|
+#endif
|
||||||
|
{
|
||||||
|
png_destroy_write_struct (&png_ptr, (png_info **)NULL);
|
||||||
|
return -1;
|
||||||
|
@@ -444,7 +448,11 @@ _our_error_fn_stdio (png_struct *png_ptr
|
||||||
|
#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
|
||||||
|
+ longjmp (png_jmpbuf(png_ptr), 1);
|
||||||
|
+#else
|
||||||
|
longjmp (png_ptr->jmpbuf, 1);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
@@ -515,7 +523,11 @@ _our_error_fn_stream (png_struct *png_pt
|
||||||
|
#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
|
||||||
|
+ longjmp (png_jmpbuf(png_ptr), 1);
|
||||||
|
+#else
|
||||||
|
longjmp (png_ptr->jmpbuf, 1);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,54 @@
|
|||||||
|
Do not call the undeclared exit function. This avoids build problems
|
||||||
|
with future compilers which do not support implicit function
|
||||||
|
declarations.
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 229ccd453ae4487f..fdf3785ad4c5175f 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -19537,9 +19537,9 @@ int main()
|
||||||
|
|| fflush ((FILE *)0) < 0
|
||||||
|
|| (fpr = fopen ("conftest0", "r")) == (FILE *)0
|
||||||
|
|| fread (test_array, 1, 7, fpr) != 7)
|
||||||
|
- exit (1);
|
||||||
|
+ return 1;
|
||||||
|
else
|
||||||
|
- exit(0); }
|
||||||
|
+ return 0; }
|
||||||
|
_ACEOF
|
||||||
|
rm -f conftest$ac_exeext
|
||||||
|
if { (ac_try="$ac_link"
|
||||||
|
@@ -24022,7 +24022,7 @@ int main()
|
||||||
|
int i;
|
||||||
|
for (i=0; i < B; i++)
|
||||||
|
Array[i] = i - 3;
|
||||||
|
- exit (Array[1] != -2);
|
||||||
|
+ return Array[1] != -2;
|
||||||
|
}
|
||||||
|
_ACEOF
|
||||||
|
rm -f conftest$ac_exeext
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 8fb7b640864eb4a8..d1f6d7e08c6946d4 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -88,9 +88,9 @@ int main()
|
||||||
|
|| fflush ((FILE *)0) < 0
|
||||||
|
|| (fpr = fopen ("conftest0", "r")) == (FILE *)0
|
||||||
|
|| fread (test_array, 1, 7, fpr) != 7)
|
||||||
|
- exit (1);
|
||||||
|
+ return 1;
|
||||||
|
else
|
||||||
|
- exit(0); }]])],[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_NULL_FLUSH)],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(no)])
|
||||||
|
+ return 0; }]])],[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_NULL_FLUSH)],[AC_MSG_RESULT(no)],[AC_MSG_RESULT(no)])
|
||||||
|
|
||||||
|
# Checks for header files: ANSI C, POSIX, and nonstandard Unix headers.
|
||||||
|
AC_HEADER_STDC
|
||||||
|
@@ -383,7 +383,7 @@ int main()
|
||||||
|
int i;
|
||||||
|
for (i=0; i < B; i++)
|
||||||
|
Array[[i]] = i - 3;
|
||||||
|
- exit (Array[[1]] != -2);
|
||||||
|
+ return Array[[1]] != -2;
|
||||||
|
}]])],
|
||||||
|
[ac_cv_c_gcc_strength_bug="no"],[ac_cv_c_gcc_strength_bug="yes"],[ac_cv_c_gcc_strength_bug="yes"]) )
|
||||||
|
if test "$ac_cv_c_gcc_strength_bug" = "yes"
|
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/pic2plot/gram.yy b/pic2plot/gram.yy
|
||||||
|
index d11320b..1bcce46 100644
|
||||||
|
--- a/pic2plot/gram.yy
|
||||||
|
+++ b/pic2plot/gram.yy
|
||||||
|
@@ -1833,7 +1833,7 @@ do_sprintf(const char *form, const double *v, int nv)
|
||||||
|
{
|
||||||
|
one_format += *form++;
|
||||||
|
one_format += '\0';
|
||||||
|
- sprintf(sprintf_buf, one_format.contents());
|
||||||
|
+ sprintf(sprintf_buf, "%s", one_format.contents());
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
@ -0,0 +1,231 @@
|
|||||||
|
Name: plotutils
|
||||||
|
Version: 2.6
|
||||||
|
Release: 36%{?dist}
|
||||||
|
Summary: GNU vector and raster graphics utilities and libraries
|
||||||
|
|
||||||
|
# libxmi is GPLv2+
|
||||||
|
# rest is GPLv3+
|
||||||
|
License: GPL-2.0-or-later AND GPL-3.0-or-later
|
||||||
|
URL: http://www.gnu.org/software/plotutils/
|
||||||
|
Source0: ftp://ftp.gnu.org/gnu/plotutils/plotutils-%{version}.tar.gz
|
||||||
|
Patch0: plotutils-2.6-png15.patch
|
||||||
|
Patch1: plotutils-aarch64.patch
|
||||||
|
Patch2: plotutils-werror-format-security.patch
|
||||||
|
Patch3: plotutils-configure-c99.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: flex
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: xorg-x11-proto-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXaw-devel
|
||||||
|
BuildRequires: libXt-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: byacc
|
||||||
|
|
||||||
|
%description
|
||||||
|
The GNU plotutils package contains software for both programmers and
|
||||||
|
technical users. Its centerpiece is libplot, a powerful C/C++ function
|
||||||
|
library for exporting 2-D vector graphics in many file formats, both
|
||||||
|
vector and raster. It can also do vector graphics animations. Besides
|
||||||
|
libplot, the package contains command-line programs for plotting
|
||||||
|
scientific data. Many of them use libplot to export graphics
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Headers for developing programs that will use %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains the header files needed for developing %{name}
|
||||||
|
applications
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .png15
|
||||||
|
%patch1 -p1 -b .aarch64
|
||||||
|
%patch2 -p1 -b .format-security
|
||||||
|
%patch3 -p1
|
||||||
|
# Avoid attempting autotools rebuild.
|
||||||
|
touch -r aclocal.m4 configure*
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static --enable-libplotter --enable-libxmi --enable-ps-fonts-in-pcl
|
||||||
|
|
||||||
|
# fix rpath handling
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
|
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf docs-to-include
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
mkdir docs-to-include
|
||||||
|
mv ${RPM_BUILD_ROOT}%{_datadir}/ode docs-to-include
|
||||||
|
mv ${RPM_BUILD_ROOT}%{_datadir}/pic2plot docs-to-include
|
||||||
|
mv ${RPM_BUILD_ROOT}%{_datadir}/libplot docs-to-include
|
||||||
|
mv ${RPM_BUILD_ROOT}%{_datadir}/tek2plot docs-to-include
|
||||||
|
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS COMPAT COPYING NEWS THANKS README PROBLEMS KNOWN_BUGS
|
||||||
|
%doc docs-to-include/*
|
||||||
|
%{_bindir}/graph
|
||||||
|
%{_bindir}/ode
|
||||||
|
%{_bindir}/double
|
||||||
|
%{_bindir}/plot
|
||||||
|
%{_bindir}/pic2plot
|
||||||
|
%{_bindir}/plotfont
|
||||||
|
%{_bindir}/spline
|
||||||
|
%{_bindir}/tek2plot
|
||||||
|
%{_bindir}/hersheydemo
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_infodir}/*.info*
|
||||||
|
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc TODO
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%{_libdir}/*.so
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.6-36
|
||||||
|
- Bump release for June 2024 mass rebuild
|
||||||
|
|
||||||
|
* Thu May 23 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.6-35
|
||||||
|
- Convert to SPDX license tag
|
||||||
|
|
||||||
|
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-34
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-33
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-32
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-31
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 18 2023 Florian Weimer <fweimer@redhat.com> - 2.6-30
|
||||||
|
- Port configure script to C99 (#2161952)
|
||||||
|
|
||||||
|
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-29
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-28
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-27
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 19 2018 Michael Simacek <msimacek@redhat.com> - 2.6-20
|
||||||
|
- Add BR on gcc-c++ and make
|
||||||
|
- Remove deprecated Group tag
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.6-13
|
||||||
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Dec 04 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-10
|
||||||
|
- Fix FTBFS when "-Werror=format-security" is used
|
||||||
|
|
||||||
|
* Tue Nov 26 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-9
|
||||||
|
- Apply aarch64 support patch (#926356)
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 19 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-6
|
||||||
|
- Fix license tag (upstream relicensed in version 2.5.1)
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 22 2012 Tom Callaway <spot@fedoraproject.org> - 2.6-4
|
||||||
|
- fix build against libpng15
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 2.6-2
|
||||||
|
- Rebuild for new libpng
|
||||||
|
|
||||||
|
* Wed Mar 2 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 2.6-1
|
||||||
|
- Update to 2.6
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5-5
|
||||||
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
* Mon Aug 20 2007 Denis Leroy <denis@poolshark.org> - 2.5-4
|
||||||
|
- License tag update
|
||||||
|
|
||||||
|
* Mon Aug 28 2006 Denis Leroy <denis@poolshark.org> - 2.5-3
|
||||||
|
- FE6 Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 10 2006 Denis Leroy <denis@poolshark.org> - 2.5-2
|
||||||
|
- Some reformatting, added ldconfig Req
|
||||||
|
|
||||||
|
* Wed Aug 9 2006 Denis Leroy <denis@poolshark.org> - 2.5-1
|
||||||
|
- Initial version
|
Loading…
Reference in new issue