refresh startkde.patch

.spec cleanup
epel9
Rex Dieter 7 years ago
parent 0668727b2d
commit dae05ff73d

@ -1,13 +1,13 @@
# Define (as 1) to enable bootstrap when building plasma-workspace on a new # Set (as 1) to enable bootstrap when building plasma-workspace on a new
# repo or arch where there's no package that would provide plasmashell # repo or arch where there's no package that would provide plasmashell
# define bootstrap 1 #global bootstrap 1
%global kf5_version_min 5.34.0 %global kf5_version_min 5.42.0
Name: plasma-workspace Name: plasma-workspace
Summary: Plasma workspace, applications and applets Summary: Plasma workspace, applications and applets
Version: 5.12.5 Version: 5.12.5
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv2+ License: GPLv2+
URL: https://cgit.kde.org/%{name}.git URL: https://cgit.kde.org/%{name}.git
@ -417,7 +417,7 @@ install -m644 -p breeze-fedora/* \
# Make kcheckpass work # Make kcheckpass work
install -m644 -p -D %{SOURCE10} %{buildroot}%{_sysconfdir}/pam.d/kde install -m644 -p -D %{SOURCE10} %{buildroot}%{_sysconfdir}/pam.d/kde
%find_lang all --with-html --with-qt --all-name %find_lang all --with-html --all-name
grep "%{_kf5_docdir}" all.lang > %{name}-doc.lang grep "%{_kf5_docdir}" all.lang > %{name}-doc.lang
grep libkworkspace.mo all.lang > libkworkspace5.lang grep libkworkspace.mo all.lang > libkworkspace5.lang
@ -574,6 +574,10 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/{plasma-windowed,org.
%changelog %changelog
* Sun May 06 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.12.5-2
- refresh startkde.patch
- .spec cleanup
* Tue May 01 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.12.5-1 * Tue May 01 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.12.5-1
- 5.12.5 - 5.12.5

@ -1,8 +1,7 @@
diff --git a/startkde/startkde.cmake b/startkde/startkde.cmake diff -up plasma-workspace-5.12.5/startkde/startkde.cmake.startkde plasma-workspace-5.12.5/startkde/startkde.cmake
index 54e2850..2c050b8 100644 --- plasma-workspace-5.12.5/startkde/startkde.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
--- a/startkde/startkde.cmake +++ plasma-workspace-5.12.5/startkde/startkde.cmake 2018-05-06 21:12:49.592504191 -0500
+++ b/startkde/startkde.cmake @@ -161,48 +161,6 @@ for prefix in `echo $scriptpath`; do
@@ -164,48 +164,6 @@ for prefix in `echo $scriptpath`; do
done done
done done
@ -51,12 +50,12 @@ index 54e2850..2c050b8 100644
# Set a left cursor instead of the standard X11 "X" cursor, since I've heard # Set a left cursor instead of the standard X11 "X" cursor, since I've heard
# from some users that they're confused and don't know what to do. This is # from some users that they're confused and don't know what to do. This is
# especially necessary on slow machines, where starting KDE takes one or two # especially necessary on slow machines, where starting KDE takes one or two
@@ -282,22 +240,21 @@ if test $? -ne 0; then @@ -279,22 +237,21 @@ if test $? -ne 0; then
# Startup error # Startup error
echo 'startkde: Could not sync environment to dbus.' 1>&2 echo 'startkde: Could not sync environment to dbus.' 1>&2
test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
- xmessage -geometry 500x100 "Could not sync environment to dbus." - xmessage -geometry 500x100 "Could not sync environment to dbus."
+ message "Could not sync environment to dbus." + xmessage "Could not sync environment to dbus."
exit 1 exit 1
fi fi
@ -69,7 +68,7 @@ index 54e2850..2c050b8 100644
echo 'startkde: Could not start kdeinit5. Check your installation.' 1>&2 echo 'startkde: Could not start kdeinit5. Check your installation.' 1>&2
test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
- xmessage -geometry 500x100 "Could not start kdeinit5. Check your installation." - xmessage -geometry 500x100 "Could not start kdeinit5. Check your installation."
+ message "Could not start kdeinit5. Check your installation." + xmessage "Could not start kdeinit5. Check your installation."
exit 1 exit 1
fi fi
@ -79,7 +78,7 @@ index 54e2850..2c050b8 100644
# finally, give the session control to the session manager # finally, give the session control to the session manager
# see kdebase/ksmserver for the description of the rest of the startup sequence # see kdebase/ksmserver for the description of the rest of the startup sequence
@@ -330,13 +287,13 @@ if test x"$wait_drkonqi"x = x"true"x ; then @@ -327,13 +284,13 @@ if test x"$wait_drkonqi"x = x"true"x ; t
# wait for remaining drkonqi instances with timeout (in seconds) # wait for remaining drkonqi instances with timeout (in seconds)
wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900` wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
wait_drkonqi_counter=0 wait_drkonqi_counter=0
@ -96,10 +95,9 @@ index 54e2850..2c050b8 100644
done done
break break
fi fi
diff --git a/startkde/startplasma.cmake b/startkde/startplasma.cmake diff -up plasma-workspace-5.12.5/startkde/startplasma.cmake.startkde plasma-workspace-5.12.5/startkde/startplasma.cmake
index a5d09fa..a73cb90 100644 --- plasma-workspace-5.12.5/startkde/startplasma.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
--- a/startkde/startplasma.cmake +++ plasma-workspace-5.12.5/startkde/startplasma.cmake 2018-05-06 21:11:54.749023404 -0500
+++ b/startkde/startplasma.cmake
@@ -140,7 +140,8 @@ if test $? -ne 0; then @@ -140,7 +140,8 @@ if test $? -ne 0; then
exit 1 exit 1
fi fi
@ -110,7 +108,7 @@ index a5d09fa..a73cb90 100644
# finally, give the session control to the session manager # finally, give the session control to the session manager
# see kdebase/ksmserver for the description of the rest of the startup sequence # see kdebase/ksmserver for the description of the rest of the startup sequence
@@ -169,13 +170,13 @@ if test x"$wait_drkonqi"x = x"true"x ; then @@ -169,13 +170,13 @@ if test x"$wait_drkonqi"x = x"true"x ; t
# wait for remaining drkonqi instances with timeout (in seconds) # wait for remaining drkonqi instances with timeout (in seconds)
wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900` wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
wait_drkonqi_counter=0 wait_drkonqi_counter=0
@ -127,10 +125,9 @@ index a5d09fa..a73cb90 100644
done done
break break
fi fi
diff --git a/startkde/startplasmacompositor.cmake b/startkde/startplasmacompositor.cmake diff -up plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake.startkde plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake
index 8ac47aa..a4ddfb3 100644 --- plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
--- a/startkde/startplasmacompositor.cmake +++ plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake 2018-05-06 21:11:54.749023404 -0500
+++ b/startkde/startplasmacompositor.cmake
@@ -3,6 +3,8 @@ @@ -3,6 +3,8 @@
# DEFAULT Plasma STARTUP SCRIPT ( @PROJECT_VERSION@ ) # DEFAULT Plasma STARTUP SCRIPT ( @PROJECT_VERSION@ )
# #

Loading…
Cancel
Save