epel9
Marc Deop 3 years ago
parent f18a1eb0fc
commit 6acbc2b38f

1
.gitignore vendored

@ -77,3 +77,4 @@
/plasma-workspace-5.24.3.tar.xz /plasma-workspace-5.24.3.tar.xz
/plasma-workspace-5.24.4.tar.xz /plasma-workspace-5.24.4.tar.xz
/plasma-workspace-5.24.5.tar.xz /plasma-workspace-5.24.5.tar.xz
/plasma-workspace-5.24.90.tar.xz

@ -1,7 +1,6 @@
diff --git a/shell/packageplugins/lookandfeel/lookandfeel.cpp b/shell/packageplugins/lookandfeel/lookandfeel.cpp diff -Nurr plasma-workspace-5.24.90/shell/packageplugins/lookandfeel/lookandfeel.cpp plasma-workspace-5.24.90-new/shell/packageplugins/lookandfeel/lookandfeel.cpp
index d50b3e96f..556877af6 100644 --- plasma-workspace-5.24.90/shell/packageplugins/lookandfeel/lookandfeel.cpp 2022-05-19 12:38:19.000000000 +0200
--- a/shell/packageplugins/lookandfeel/lookandfeel.cpp +++ plasma-workspace-5.24.90-new/shell/packageplugins/lookandfeel/lookandfeel.cpp 2022-05-21 17:44:56.201054375 +0200
+++ b/shell/packageplugins/lookandfeel/lookandfeel.cpp
@@ -10,7 +10,7 @@ @@ -10,7 +10,7 @@
#include <KLocalizedString> #include <KLocalizedString>
#include <KPackage/PackageLoader> #include <KPackage/PackageLoader>
@ -11,16 +10,15 @@ index d50b3e96f..556877af6 100644
void LookAndFeelPackage::initPackage(KPackage::Package *package) void LookAndFeelPackage::initPackage(KPackage::Package *package)
{ {
diff --git a/startkde/startplasma.cpp b/startkde/startplasma.cpp diff -Nurr plasma-workspace-5.24.90/startkde/startplasma.cpp plasma-workspace-5.24.90-new/startkde/startplasma.cpp
index bd848dda0..43978a712 100644 --- plasma-workspace-5.24.90/startkde/startplasma.cpp 2022-05-19 12:38:19.000000000 +0200
--- a/startkde/startplasma.cpp +++ plasma-workspace-5.24.90-new/startkde/startplasma.cpp 2022-05-21 17:44:53.033054894 +0200
+++ b/startkde/startplasma.cpp @@ -350,7 +350,7 @@
@@ -365,7 +365,7 @@ void setupPlasmaEnvironment() qputenv("XDG_CONFIG_DIRS", QFile::encodeName(extraConfigDir) + ':' + currentConfigDirs);
qputenv("XDG_CONFIG_DIRS", extraConfigDir + ":" + currentConfigDirs);
const KConfig globals; const KConfig globals;
- const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("org.kde.breeze.desktop")); - const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("org.kde.breeze.desktop"));
+ const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("@DEFAULT_LOOKANDFEEL@")); + const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("@DEFAULT_LOOKANDFEEL@"));
QFile activeLnf(QString::fromUtf8(extraConfigDir + "/package")); QFile activeLnf(extraConfigDir + QLatin1String("/package"));
activeLnf.open(QIODevice::ReadOnly); activeLnf.open(QIODevice::ReadOnly);
if (activeLnf.readLine() != currentLnf.toUtf8()) { if (activeLnf.readLine() != currentLnf.toUtf8()) {

@ -1,8 +1,7 @@
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/CMakeLists.txt.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/CMakeLists.txt diff -Nurr plasma-workspace-5.24.90-new/containmentactions/contextmenu/menu.cpp plasma-workspace-5.24.90/containmentactions/contextmenu/menu.cpp
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp --- plasma-workspace-5.24.90-new/containmentactions/contextmenu/menu.cpp 2022-05-21 16:42:05.980661922 +0200
--- plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsole-in-contextmenu 2022-01-13 07:19:17.000000000 -0600 +++ plasma-workspace-5.24.90/containmentactions/contextmenu/menu.cpp 2022-05-21 16:47:43.503606798 +0200
+++ plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp 2022-01-19 16:09:26.778355795 -0600 @@ -17,6 +17,7 @@
@@ -16,6 +16,7 @@
#include <KGlobalAccel> #include <KGlobalAccel>
#include <KIO/CommandLauncherJob> #include <KIO/CommandLauncherJob>
#include <KLocalizedString> #include <KLocalizedString>
@ -11,14 +10,14 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsol
#include <QIcon> #include <QIcon>
@@ -29,6 +30,7 @@ @@ -29,6 +30,7 @@
ContextMenu::ContextMenu(QObject *parent, const QVariantList &args) ContextMenu::ContextMenu(QObject *parent, const QVariantList &args)
: Plasma::ContainmentActions(parent, args) : Plasma::ContainmentActions(parent, args)
, m_runCommandAction(nullptr)
+ , m_runKonsoleAction(nullptr) + , m_runKonsoleAction(nullptr)
, m_lockScreenAction(nullptr) , m_session(new SessionManagement(this))
, m_logoutAction(nullptr) {
, m_configureDisplaysAction(nullptr) }
@@ -68,6 +70,7 @@ void ContextMenu::restore(const KConfigG @@ -61,6 +63,7 @@
<< QStringLiteral("configure shortcuts") << QStringLiteral("configure shortcuts")
<< QStringLiteral("_sep1") << QStringLiteral("_sep1")
<< QStringLiteral("_context") << QStringLiteral("_context")
@ -26,7 +25,7 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsol
<< QStringLiteral("_run_command") << QStringLiteral("_run_command")
<< QStringLiteral("add widgets") << QStringLiteral("add widgets")
<< QStringLiteral("_add panel") << QStringLiteral("_add panel")
@@ -102,6 +105,10 @@ void ContextMenu::restore(const KConfigG @@ -97,6 +100,10 @@
m_runCommandAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("krunner.desktop"), QStringLiteral("_launch")).value(0)); m_runCommandAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("krunner.desktop"), QStringLiteral("_launch")).value(0));
connect(m_runCommandAction, &QAction::triggered, this, &ContextMenu::runCommand); connect(m_runCommandAction, &QAction::triggered, this, &ContextMenu::runCommand);
@ -37,7 +36,7 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsol
m_lockScreenAction = new QAction(i18nc("plasma_containmentactions_contextmenu", "Lock Screen"), this); m_lockScreenAction = new QAction(i18nc("plasma_containmentactions_contextmenu", "Lock Screen"), this);
m_lockScreenAction->setIcon(QIcon::fromTheme(QStringLiteral("system-lock-screen"))); m_lockScreenAction->setIcon(QIcon::fromTheme(QStringLiteral("system-lock-screen")));
m_lockScreenAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("ksmserver"), QStringLiteral("Lock Session")).value(0)); m_lockScreenAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("ksmserver"), QStringLiteral("Lock Session")).value(0));
@@ -184,6 +191,8 @@ QAction *ContextMenu::action(const QStri @@ -179,6 +186,8 @@
if (KAuthorized::authorizeAction(QStringLiteral("run_command")) && KAuthorized::authorize(QStringLiteral("run_command"))) { if (KAuthorized::authorizeAction(QStringLiteral("run_command")) && KAuthorized::authorize(QStringLiteral("run_command"))) {
return m_runCommandAction; return m_runCommandAction;
} }
@ -46,7 +45,7 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsol
} else if (name == QLatin1String("_lock_screen")) { } else if (name == QLatin1String("_lock_screen")) {
if (KAuthorized::authorizeAction(QStringLiteral("lock_screen"))) { if (KAuthorized::authorizeAction(QStringLiteral("lock_screen"))) {
return m_lockScreenAction; return m_lockScreenAction;
@@ -211,6 +220,13 @@ QAction *ContextMenu::action(const QStri @@ -212,6 +221,13 @@
return nullptr; return nullptr;
} }
@ -60,10 +59,10 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsol
void ContextMenu::runCommand() void ContextMenu::runCommand()
{ {
if (!KAuthorized::authorizeAction(QStringLiteral("run_command"))) { if (!KAuthorized::authorizeAction(QStringLiteral("run_command"))) {
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h diff -Nurr plasma-workspace-5.24.90-new/containmentactions/contextmenu/menu.h plasma-workspace-5.24.90/containmentactions/contextmenu/menu.h
--- plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h.konsole-in-contextmenu 2022-01-19 16:07:20.060556636 -0600 --- plasma-workspace-5.24.90-new/containmentactions/contextmenu/menu.h 2022-05-21 16:42:05.980661922 +0200
+++ plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h 2022-01-19 16:08:43.055454606 -0600 +++ plasma-workspace-5.24.90/containmentactions/contextmenu/menu.h 2022-05-21 16:48:39.122597718 +0200
@@ -29,11 +29,13 @@ public: @@ -29,11 +29,13 @@
public Q_SLOTS: public Q_SLOTS:
void runCommand(); void runCommand();
@ -72,8 +71,8 @@ diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h.konsole-
void configureDisplays(); void configureDisplays();
private: private:
QAction *m_runCommandAction; QAction *m_runCommandAction = nullptr;
+ QAction *m_runKonsoleAction; + QAction *m_runKonsoleAction = nullptr;
QAction *m_lockScreenAction; QAction *m_lockScreenAction = nullptr;
QAction *m_logoutAction; QAction *m_logoutAction = nullptr;
QAction *m_configureDisplaysAction; QAction *m_configureDisplaysAction = nullptr;

@ -2,7 +2,7 @@
# repo or arch where there's no package that would provide plasmashell # repo or arch where there's no package that would provide plasmashell
#global bootstrap 1 #global bootstrap 1
%global kf5_version_min 5.82.0 %global kf5_version_min 5.91.0
# Control wayland by default # Control wayland by default
%if (0%{?rhel} && 0%{?rhel} < 9) %if (0%{?rhel} && 0%{?rhel} < 9)
@ -27,8 +27,8 @@
Name: plasma-workspace Name: plasma-workspace
Summary: Plasma workspace, applications and applets Summary: Plasma workspace, applications and applets
Version: 5.24.5 Version: 5.24.90
Release: 3%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
URL: https://invent.kde.org/plasma/%{name} URL: https://invent.kde.org/plasma/%{name}
@ -163,7 +163,7 @@ BuildRequires: kf5-kwallet-devel >= %{kf5_version_min}
BuildRequires: kf5-kxmlrpcclient-devel >= %{kf5_version_min} BuildRequires: kf5-kxmlrpcclient-devel >= %{kf5_version_min}
BuildRequires: kf5-networkmanager-qt-devel >= %{kf5_version_min} BuildRequires: kf5-networkmanager-qt-devel >= %{kf5_version_min}
BuildRequires: kf5-plasma-devel >= %{kf5_version_min} BuildRequires: kf5-plasma-devel >= %{kf5_version_min}
Requires: kf5-plasma%{?_isa} >= %{_kf5_version} Requires: kf5-plasma%{?_isa} >= %{kf5_version_min}
BuildRequires: kf5-threadweaver-devel >= %{kf5_version_min} BuildRequires: kf5-threadweaver-devel >= %{kf5_version_min}
BuildRequires: kf5-kded-devel >= %{kf5_version_min} BuildRequires: kf5-kded-devel >= %{kf5_version_min}
BuildRequires: kf5-kirigami2-devel >= %{kf5_version_min} BuildRequires: kf5-kirigami2-devel >= %{kf5_version_min}
@ -387,7 +387,7 @@ Requires: %{name}-geolocation = %{version}-%{release}
Summary: SDDM breeze theme Summary: SDDM breeze theme
# upgrade path, when sddm-breeze was split out # upgrade path, when sddm-breeze was split out
Obsoletes: plasma-workspace < 5.3.2-8 Obsoletes: plasma-workspace < 5.3.2-8
Requires: kf5-plasma >= %{_kf5_version} Requires: kf5-plasma >= %{kf5_version_min}
# Background.qml:import QtQuick # Background.qml:import QtQuick
Requires: qt5-qtquickcontrols Requires: qt5-qtquickcontrols
# on-screen keyboard # on-screen keyboard
@ -802,6 +802,9 @@ fi
%changelog %changelog
* Fri May 20 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.24.90-1
- 5.24.90
* Tue May 17 2022 Jan Grulich <jgrulich@redhat.com> - 5.24.5-3 * Tue May 17 2022 Jan Grulich <jgrulich@redhat.com> - 5.24.5-3
- Rebuild (qt5) - Rebuild (qt5)

@ -1,3 +1,3 @@
SHA512 (breeze-fedora-0.2.tar.gz) = ff800e686b0dcb498f321bb94d3a8274c89c092f5408ef1ec3fc65333f046aea43444144ecaf166792f807014383af87b1180dc7540905fc10dc375309f8b2a8 SHA512 (breeze-fedora-0.2.tar.gz) = ff800e686b0dcb498f321bb94d3a8274c89c092f5408ef1ec3fc65333f046aea43444144ecaf166792f807014383af87b1180dc7540905fc10dc375309f8b2a8
SHA512 (sddm-theme-5.24.80~pre.tar.gz) = 3b04c739d6054ecd9149178cafd3d7f53214a48fea834092707c5fd309018ea4986d4a955db7a2888a428c9b264e40403c36adae5f079d51979fe37912895344 SHA512 (sddm-theme-5.24.80~pre.tar.gz) = 3b04c739d6054ecd9149178cafd3d7f53214a48fea834092707c5fd309018ea4986d4a955db7a2888a428c9b264e40403c36adae5f079d51979fe37912895344
SHA512 (plasma-workspace-5.24.5.tar.xz) = ae40fe545b03e42e9f8fe2e8885d3853f4b52d4fd2ed3ecf7d24fa59b4924b8f8b389e8713ec6a3a875bc66df3952de9157d4a5631b283105a9329a1a1825996 SHA512 (plasma-workspace-5.24.90.tar.xz) = 5ec2c91b5e9a1c4e0634245a53f9c38aeeaaa2bc80d8e1ed259d9b7f5d342da007562574f281aee694b74d14b6c0e8a2da5d508b1cd570faadf106d0c6958fce

Loading…
Cancel
Save