Merge branch f37 into epel9-next

epel9
Troy Dawson 2 years ago
commit 0e2895800f

15
.gitignore vendored

@ -77,4 +77,17 @@
/plasma-workspace-5.24.3.tar.xz
/plasma-workspace-5.24.4.tar.xz
/plasma-workspace-5.24.5.tar.xz
/plasma-workspace-5.24.6.tar.xz
/plasma-workspace-5.24.90.tar.xz
/plasma-workspace-5.25.0.tar.xz
/plasma-workspace-5.25.1.tar.xz
/plasma-workspace-5.25.2.tar.xz
/plasma-workspace-5.25.3.tar.xz
/plasma-workspace-5.25.3.1.tar.xz
/plasma-workspace-5.25.4.tar.xz
/plasma-workspace-5.25.5.tar.xz
/plasma-workspace-5.25.90.tar.xz
/plasma-workspace-5.26.0.tar.xz
/plasma-workspace-5.26.1.tar.xz
/plasma-workspace-5.26.2.tar.xz
/plasma-workspace-5.26.3.tar.xz
/plasma-workspace-5.26.4.1.tar.xz

@ -0,0 +1,69 @@
From 1be046edd455969b74417ded6871d25eba8a1112 Mon Sep 17 00:00:00 2001
From: David Edmundson <kde@davidedmundson.co.uk>
Date: Mon, 27 Jun 2022 17:12:09 +0200
Subject: [PATCH] Disable toplevel fixed positions on Wayland
Given that the wayland protocol does not have window positions a recent
change to Qt development branch avoids having a mismatch of positions
and tells client code the window is at the topleft of the screen. This
fixes multiple bugs.
Unfortuantely this breaks a few usages within plasma where a
side-channel sends that absolute positional information over a bespoke
protocol. Currently we proxy this all through QWindow geometry where the
new Qt behaviour will throw is askew.
Whilst our longterm plans are to find future options away from the
plasmashell protocol we may as well have our Qt6
build work given the patch is trivial and harmless.
It also allows for potential backporting if our software is
already secured against issues.
---
krunner/main.cpp | 2 ++
shell/main.cpp | 3 +++
2 files changed, 5 insertions(+)
diff --git a/krunner/main.cpp b/krunner/main.cpp
index a05402a01..f19382cad 100644
--- a/krunner/main.cpp
+++ b/krunner/main.cpp
@@ -34,6 +34,7 @@ int main(int argc, char **argv)
QCoreApplication::setAttribute(Qt::AA_DisableHighDpiScaling);
}
+ qputenv("QT_WAYLAND_DISABLE_FIXED_POSITIONS", {});
const bool qpaVariable = qEnvironmentVariableIsSet("QT_QPA_PLATFORM");
KWorkSpace::detectPlatform(argc, argv);
QQuickWindow::setDefaultAlphaBuffer(true);
@@ -42,6 +43,7 @@ int main(int argc, char **argv)
// don't leak the env variable to processes we start
qunsetenv("QT_QPA_PLATFORM");
}
+ qunsetenv("QT_WAYLAND_DISABLE_FIXED_POSITIONS");
KLocalizedString::setApplicationDomain("krunner");
// TODO: Make it a QGuiApplication once we don't depend on KDELibs4Support
diff --git a/shell/main.cpp b/shell/main.cpp
index 26e4ecede..147483df4 100644
--- a/shell/main.cpp
+++ b/shell/main.cpp
@@ -79,6 +79,7 @@ int main(int argc, char *argv[])
oldCategoryFilter = QLoggingCategory::installFilter(filterConnectionSyntaxWarning);
+ qputenv("QT_WAYLAND_DISABLE_FIXED_POSITIONS", {});
const bool qpaVariable = qEnvironmentVariableIsSet("QT_QPA_PLATFORM");
KWorkSpace::detectPlatform(argc, argv);
QApplication app(argc, argv);
@@ -86,6 +87,8 @@ int main(int argc, char *argv[])
// don't leak the env variable to processes we start
qunsetenv("QT_QPA_PLATFORM");
}
+ qunsetenv("QT_WAYLAND_DISABLE_FIXED_POSITIONS");
+
KLocalizedString::setApplicationDomain("plasmashell");
// The executable's path is added to the library/plugin paths.
--
GitLab

@ -1,6 +1,7 @@
diff -up plasma-workspace-5.21.90/lookandfeel/contents/defaults.folderview_layout plasma-workspace-5.21.90/lookandfeel/contents/defaults
--- plasma-workspace-5.21.90/lookandfeel/contents/defaults.folderview_layout 2021-05-14 16:15:40.647354536 -0500
+++ plasma-workspace-5.21.90/lookandfeel/contents/defaults 2021-05-14 16:16:21.580720452 -0500
diff --git a/lookandfeel/org.kde.breeze/contents/defaults b/lookandfeel/org.kde.breeze/contents/defaults
index d8df939b3..b050a7a87 100644
--- a/lookandfeel/org.kde.breeze/contents/defaults
+++ b/lookandfeel/org.kde.breeze/contents/defaults
@@ -27,3 +27,7 @@ library=org.kde.breeze
[KSplash]

@ -1,26 +0,0 @@
diff --git a/shell/packageplugins/lookandfeel/lookandfeel.cpp b/shell/packageplugins/lookandfeel/lookandfeel.cpp
index d50b3e96f..556877af6 100644
--- a/shell/packageplugins/lookandfeel/lookandfeel.cpp
+++ b/shell/packageplugins/lookandfeel/lookandfeel.cpp
@@ -10,7 +10,7 @@
#include <KLocalizedString>
#include <KPackage/PackageLoader>
-#define DEFAULT_LOOKANDFEEL "org.kde.breeze.desktop"
+#define DEFAULT_LOOKANDFEEL "@DEFAULT_LOOKANDFEEL@"
void LookAndFeelPackage::initPackage(KPackage::Package *package)
{
diff --git a/startkde/startplasma.cpp b/startkde/startplasma.cpp
index bd848dda0..43978a712 100644
--- a/startkde/startplasma.cpp
+++ b/startkde/startplasma.cpp
@@ -365,7 +365,7 @@ void setupPlasmaEnvironment()
qputenv("XDG_CONFIG_DIRS", extraConfigDir + ":" + currentConfigDirs);
const KConfig globals;
- const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("org.kde.breeze.desktop"));
+ const QString currentLnf = KConfigGroup(&globals, QStringLiteral("KDE")).readEntry("LookAndFeelPackage", QStringLiteral("@DEFAULT_LOOKANDFEEL@"));
QFile activeLnf(QString::fromUtf8(extraConfigDir + "/package"));
activeLnf.open(QIODevice::ReadOnly);
if (activeLnf.readLine() != currentLnf.toUtf8()) {

@ -0,0 +1,38 @@
From d6d47393bab32dc60b43e0eeac16c035000a0358 Mon Sep 17 00:00:00 2001
From: Eugene Popov <popov895@ukr.net>
Date: Sun, 24 Jul 2022 00:18:44 +0000
Subject: [PATCH] [FIX] Unable to remove manually added wallpaper
It's not necessary to assign m_removableWallpapers asynchronously, because the value assigned to it doesn't depend on the result of that asynch function.
!!! This MR is for the Plasma/5.25 branch only and it SHOULD NOT be cherry-picket into the master branch.
BUG: 457019
---
wallpapers/image/plugin/backgroundlistmodel.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/wallpapers/image/plugin/backgroundlistmodel.cpp b/wallpapers/image/plugin/backgroundlistmodel.cpp
index 8c5630712..0b12470a5 100644
--- a/wallpapers/image/plugin/backgroundlistmodel.cpp
+++ b/wallpapers/image/plugin/backgroundlistmodel.cpp
@@ -107,6 +107,8 @@ void BackgroundListModel::reload(const QStringList &selected)
return;
}
+ m_removableWallpapers = QSet<QString>(selected.constBegin(), selected.constEnd());
+
const QStringList dirs = QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("wallpapers/"), QStandardPaths::LocateDirectory);
BackgroundFinder *finder = new BackgroundFinder(m_wallpaper.data(), dirs);
@@ -117,7 +119,6 @@ void BackgroundListModel::reload(const QStringList &selected)
}
processPaths(selected + wallpapersFound);
- m_removableWallpapers = QSet<QString>(selected.constBegin(), selected.constEnd());
});
m_findToken = token;
finder->start();
--
GitLab

@ -0,0 +1,29 @@
From 6f6a8771afdaa27208d3aea63525f62cafe787cf Mon Sep 17 00:00:00 2001
From: Neal Gompa <ngompa@fedoraproject.org>
Date: Sun, 25 Sep 2022 16:46:47 -0400
Subject: [PATCH] containmentactions/contextmenu: Enable lock/logout
actions by default
Fedora users expect these items to exist in the desktop context menu
by default unless they've been manually disabled or removed via the
Kiosk mode.
---
containmentactions/contextmenu/menu.cpp | 2 --
1 file changed, 2 deletions(-)
diff --git a/containmentactions/contextmenu/menu.cpp b/containmentactions/contextmenu/menu.cpp
index 4392d50f5..80769e615 100644
--- a/containmentactions/contextmenu/menu.cpp
+++ b/containmentactions/contextmenu/menu.cpp
@@ -78,8 +78,6 @@ void ContextMenu::restore(const KConfigGroup &config)
disabled.insert(QStringLiteral("configure shortcuts"));
disabled.insert(QStringLiteral("_run_command"));
disabled.insert(QStringLiteral("run associated application"));
- disabled.insert(QStringLiteral("_lock_screen"));
- disabled.insert(QStringLiteral("_logout"));
}
// clang-format on
--
2.36.1

@ -0,0 +1,28 @@
From 9788427b7f4f8802ccc2d4de7fad02b19488c2c8 Mon Sep 17 00:00:00 2001
From: Neal Gompa <ngompa@fedoraproject.org>
Date: Sun, 25 Sep 2022 16:45:07 -0400
Subject: [PATCH] containmentactions/contextmenu: Enable "Open Terminal" by
default
Fedora users expect this item to exist in the desktop context menu
by default unless it has been manually disabled or removed via the
Kiosk mode.
---
containmentactions/contextmenu/menu.cpp | 1 -
1 file changed, 1 deletion(-)
diff --git a/containmentactions/contextmenu/menu.cpp b/containmentactions/contextmenu/menu.cpp
index 6bad29751..4392d50f5 100644
--- a/containmentactions/contextmenu/menu.cpp
+++ b/containmentactions/contextmenu/menu.cpp
@@ -76,7 +76,6 @@ void ContextMenu::restore(const KConfigGroup &config)
<< QStringLiteral("_sep3")
<< QStringLiteral("_wallpaper");
disabled.insert(QStringLiteral("configure shortcuts"));
- disabled.insert(QStringLiteral("_open_terminal"));
disabled.insert(QStringLiteral("_run_command"));
disabled.insert(QStringLiteral("run associated application"));
disabled.insert(QStringLiteral("_lock_screen"));
--
2.36.1

@ -1,79 +0,0 @@
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/CMakeLists.txt.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/CMakeLists.txt
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp
--- plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp.konsole-in-contextmenu 2022-01-13 07:19:17.000000000 -0600
+++ plasma-workspace-5.23.90/containmentactions/contextmenu/menu.cpp 2022-01-19 16:09:26.778355795 -0600
@@ -16,6 +16,7 @@
#include <KGlobalAccel>
#include <KIO/CommandLauncherJob>
#include <KLocalizedString>
+#include <KTerminalLauncherJob>
#include <QDebug>
#include <QIcon>
@@ -29,6 +30,7 @@
ContextMenu::ContextMenu(QObject *parent, const QVariantList &args)
: Plasma::ContainmentActions(parent, args)
, m_runCommandAction(nullptr)
+ , m_runKonsoleAction(nullptr)
, m_lockScreenAction(nullptr)
, m_logoutAction(nullptr)
, m_configureDisplaysAction(nullptr)
@@ -68,6 +70,7 @@ void ContextMenu::restore(const KConfigG
<< QStringLiteral("configure shortcuts")
<< QStringLiteral("_sep1")
<< QStringLiteral("_context")
+ << QStringLiteral("_run_konsole")
<< QStringLiteral("_run_command")
<< QStringLiteral("add widgets")
<< QStringLiteral("_add panel")
@@ -102,6 +105,10 @@ void ContextMenu::restore(const KConfigG
m_runCommandAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("krunner.desktop"), QStringLiteral("_launch")).value(0));
connect(m_runCommandAction, &QAction::triggered, this, &ContextMenu::runCommand);
+ m_runKonsoleAction = new QAction(i18n("Konsole"), this);
+ m_runKonsoleAction->setIcon(QIcon::fromTheme("utilities-terminal"));
+ connect(m_runKonsoleAction, &QAction::triggered, this, &ContextMenu::runKonsole);
+
m_lockScreenAction = new QAction(i18nc("plasma_containmentactions_contextmenu", "Lock Screen"), this);
m_lockScreenAction->setIcon(QIcon::fromTheme(QStringLiteral("system-lock-screen")));
m_lockScreenAction->setShortcut(KGlobalAccel::self()->globalShortcut(QStringLiteral("ksmserver"), QStringLiteral("Lock Session")).value(0));
@@ -184,6 +191,8 @@ QAction *ContextMenu::action(const QStri
if (KAuthorized::authorizeAction(QStringLiteral("run_command")) && KAuthorized::authorize(QStringLiteral("run_command"))) {
return m_runCommandAction;
}
+ } else if (name == QLatin1String("_run_konsole")) {
+ return m_runKonsoleAction;
} else if (name == QLatin1String("_lock_screen")) {
if (KAuthorized::authorizeAction(QStringLiteral("lock_screen"))) {
return m_lockScreenAction;
@@ -211,6 +220,13 @@ QAction *ContextMenu::action(const QStri
return nullptr;
}
+void ContextMenu::runKonsole()
+{
+ auto job = new KTerminalLauncherJob(QString());
+ job->setWorkingDirectory(QDir::homePath());
+ job->start();
+}
+
void ContextMenu::runCommand()
{
if (!KAuthorized::authorizeAction(QStringLiteral("run_command"))) {
diff -up plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h.konsole-in-contextmenu plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h
--- plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h.konsole-in-contextmenu 2022-01-19 16:07:20.060556636 -0600
+++ plasma-workspace-5.23.90/containmentactions/contextmenu/menu.h 2022-01-19 16:08:43.055454606 -0600
@@ -29,11 +29,13 @@ public:
public Q_SLOTS:
void runCommand();
+ void runKonsole();
void startLogout();
void configureDisplays();
private:
QAction *m_runCommandAction;
+ QAction *m_runKonsoleAction;
QAction *m_lockScreenAction;
QAction *m_logoutAction;
QAction *m_configureDisplaysAction;

@ -2,7 +2,7 @@
# repo or arch where there's no package that would provide plasmashell
#global bootstrap 1
%global kf5_version_min 5.82.0
%global kf5_version_min 5.98.0
# Control wayland by default
%if (0%{?rhel} && 0%{?rhel} < 9)
@ -12,7 +12,7 @@
%endif
# Control sddm wayland by default
%if (0%{?fedora} && 0%{?fedora} < 37) || (0%{?rhel} && 0%{?rhel} < 9)
%if (0%{?fedora} && 0%{?fedora} < 38) || (0%{?rhel} && 0%{?rhel} < 9)
%bcond_with sddm_wayland_default
%else
%bcond_without sddm_wayland_default
@ -27,8 +27,8 @@
Name: plasma-workspace
Summary: Plasma workspace, applications and applets
Version: 5.24.6
Release: 2%{?dist}
Version: 5.26.4.1
Release: 1%{?dist}
License: GPLv2+
URL: https://invent.kde.org/plasma/%{name}
@ -52,10 +52,6 @@ Source10: kde
Source11: startkderc
Source15: fedora.desktop
# backported breeze sddm from plasma 5.24.80~pre
# lets us apply patches to fix the sddm theme
Source19: sddm-theme-5.24.80~pre.tar.gz
# breeze fedora sddm theme components
# includes f25-based preview (better than breeze or nothing at least)
Source20: breeze-fedora-0.2.tar.gz
@ -71,13 +67,15 @@ Source41: spice-vdagent.conf
## upstreamable Patches
## downstream Patches
Patch100: plasma-workspace-konsole-in-contextmenu.patch
Patch101: plasma-workspace-5.24.0-set-fedora-default-look-and-feel.patch
# default to folderview (instead of desktop) containment, see also
# https://mail.kde.org/pipermail/distributions/2016-July/000133.html
# and example,
# https://github.com/notmart/artwork-lnf-netrunner-core/blob/master/usr/share/plasma/look-and-feel/org.kde.netrunner-core.desktop/contents/defaults
Patch105: plasma-workspace-5.21.90-folderview_layout.patch
# default to enable open terminal action
Patch106: plasma-workspace-5.25.90-enable-open-terminal-action.patch
# default to enable the lock/logout actions
Patch107: plasma-workspace-5.25.90-enable-lock-logout-action.patch
# udev
BuildRequires: zlib-devel
@ -120,16 +118,18 @@ BuildRequires: libqalculate-devel
%global kf5_pim 1
BuildRequires: kf5-kholidays-devel
BuildRequires: kf5-prison-devel
BuildRequires: libicu-devel
BuildRequires: qt5-qtbase-devel >= 5.15
BuildRequires: qt5-qtbase-private-devel
%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
BuildRequires: qt5-qtx11extras-devel
BuildRequires: qt5-qtscript-devel
BuildRequires: qt5-qtdeclarative-devel
BuildRequires: qt5-qtsvg-devel
BuildRequires: qt5-qtwayland-devel
BuildRequires: phonon-qt5-devel
BuildRequires: polkit-qt5-1-devel
BuildRequires: kf5-rpm-macros >= %{kf5_version_min}
BuildRequires: systemd-rpm-macros
@ -148,7 +148,6 @@ BuildRequires: kf5-kguiaddons-devel >= %{kf5_version_min}
BuildRequires: kf5-kidletime-devel >= %{kf5_version_min}
BuildRequires: kf5-kinit-devel >= %{kf5_version_min}
BuildRequires: kf5-kitemmodels-devel >= %{kf5_version_min}
# konsole patch
BuildRequires: kf5-kio-devel >= %{kf5_version_min}
BuildRequires: kf5-kjsembed-devel >= %{kf5_version_min}
BuildRequires: kf5-knewstuff-devel >= %{kf5_version_min}
@ -163,7 +162,7 @@ BuildRequires: kf5-kwallet-devel >= %{kf5_version_min}
BuildRequires: kf5-kxmlrpcclient-devel >= %{kf5_version_min}
BuildRequires: kf5-networkmanager-qt-devel >= %{kf5_version_min}
BuildRequires: kf5-plasma-devel >= %{kf5_version_min}
Requires: kf5-plasma%{?_isa} >= %{_kf5_version}
Requires: kf5-plasma%{?_isa} >= %{kf5_version_min}
BuildRequires: kf5-threadweaver-devel >= %{kf5_version_min}
BuildRequires: kf5-kded-devel >= %{kf5_version_min}
BuildRequires: kf5-kirigami2-devel >= %{kf5_version_min}
@ -187,7 +186,11 @@ BuildRequires: qt5-qtbase-static
BuildRequires: kuserfeedback-devel
BuildRequires: plasma-wayland-protocols-devel
BuildRequires: plasma-breeze-devel >= %{version}
# Commented out and hardcoded on the next line exclusively due to a re-spin
# with an extra .1 in the version
# Revert when possible (possibly on the next plasma-workspace release)
#BuildRequires: plasma-breeze-devel >= %{version}
BuildRequires: plasma-breeze-devel >= 5.25.3
BuildRequires: chrpath
BuildRequires: desktop-file-utils
@ -261,14 +264,12 @@ Requires: iceauth xrdb xprop
Requires: kde-settings-plasma
# Default look-and-feel theme
%global default_lookandfeel org.fedoraproject.fedora.desktop
Requires: plasma-lookandfeel-fedora = %{version}-%{release}
Requires: desktop-backgrounds-compat
Requires: systemd
# Oxygen
Requires: oxygen-sound-theme >= %{majmin_ver}
Requires: oxygen-sounds >= %{majmin_ver}
# PolicyKit authentication agent
Requires: polkit-kde >= %{majmin_ver}
@ -280,6 +281,10 @@ Requires: maliit-keyboard
Requires: (uresourced if systemd-oomd-defaults)
%endif
# needed for task manager thumbnails under wayland and for things like
# screenshare portal
BuildRequires: kpipewire-devel
# Require any plasmashell (plasma-desktop provides plasmashell(desktop))
%if 0%{?bootstrap}
Provides: plasmashell = %{version}
@ -383,7 +388,7 @@ Requires: %{name}-geolocation = %{version}-%{release}
Summary: SDDM breeze theme
# upgrade path, when sddm-breeze was split out
Obsoletes: plasma-workspace < 5.3.2-8
Requires: kf5-plasma >= %{_kf5_version}
Requires: kf5-plasma >= %{kf5_version_min}
# Background.qml:import QtQuick
Requires: qt5-qtquickcontrols
# on-screen keyboard
@ -393,8 +398,10 @@ Recommends: qt5-qtvirtualkeyboard
# org.kde.plasma.workspace.keyboardlayout
Requires: %{name} = %{version}-%{release}
# /usr/share/backgrounds/default.png
%if 0%{?fedora}
BuildRequires: desktop-backgrounds-compat
Requires: desktop-backgrounds-compat
%endif
%if 0%{?rhel}
Requires: system-logos
%endif
@ -462,27 +469,15 @@ BuildArch: noarch
%prep
%setup -q -a 19 -a 20
## upstream patches
## upstreamable patches
## downstream patches
%patch100 -p1 -b .konsole-in-contextmenu
# XXX: This is horribly broken and needs fixes upstream -- ngompa
%patch101 -p1 -b .set-fedora-default-look-and-feel
sed -i -e "s|@DEFAULT_LOOKANDFEEL@|%{?default_lookandfeel}%{!?default_lookandfeel:org.kde.breeze.desktop}|g" \
shell/packageplugins/lookandfeel/lookandfeel.cpp startkde/startplasma.cpp
%patch105 -p1
%autosetup -a 20 -p1
# Populate initial lookandfeel package
cp -a lookandfeel lookandfeel.fedora
cp -a lookandfeel/org.kde.breeze lookandfeel/org.fedoraproject.fedora
# Overwrite settings to configure twilight mode
cp -a lookandfeel.twilight/* lookandfeel.fedora
install -m 0644 %{SOURCE15} lookandfeel.fedora/metadata.desktop
cat >> CMakeLists.txt <<EOL
plasma_install_package(lookandfeel.fedora org.fedoraproject.fedora.desktop look-and-feel lookandfeel)
cp -a lookandfeel/org.kde.breezetwilight/* lookandfeel/org.fedoraproject.fedora
install -m 0644 %{SOURCE15} lookandfeel/org.fedoraproject.fedora/metadata.desktop
cat >> lookandfeel/CMakeLists.txt <<EOL
plasma_install_package(org.fedoraproject.fedora org.fedoraproject.fedora.desktop look-and-feel lookandfeel)
EOL
@ -518,11 +513,9 @@ ln -sf %{_datadir}/backgrounds/default.png \
%{buildroot}%{_datadir}/sddm/themes/01-breeze-fedora/components/artwork/background.png
install -m644 -p breeze-fedora/* \
%{buildroot}%{_datadir}/sddm/themes/01-breeze-fedora/
%if 0%{?fedora} >= 34
# Set Fedora distro vendor logo
sed -i -e 's|^showlogo=.*$|showlogo=shown|g' %{buildroot}%{_datadir}/sddm/themes/01-breeze-fedora/theme.conf
sed -i -e 's|^logo=.*$|logo=%{_datadir}/pixmaps/fedora_whitelogo.svg|g' %{buildroot}%{_datadir}/sddm/themes/01-breeze-fedora/theme.conf
%endif
# move sddm configuration snippet to the right place
mkdir -p %{buildroot}%{_prefix}/lib/sddm
@ -580,6 +573,7 @@ fi
%{_kf5_bindir}/plasma_session
%{_kf5_bindir}/plasma-apply-*
%{_kf5_bindir}/plasma-interactiveconsole
%{_kf5_bindir}/plasma-localegen-helper
%{_kf5_bindir}/plasma-shutdown
%{_kf5_bindir}/plasma_waitforname
%{_kf5_bindir}/systemmonitor
@ -596,8 +590,8 @@ fi
%{_libexecdir}/kfontprint
%{_libexecdir}/plasma-changeicons
%{_libexecdir}/plasma-dbus-run-session-if-needed
%{_kf5_datadir}/ksplash/
%{_kf5_datadir}/plasma/avatars/
%{_kf5_datadir}/plasma/nightcolor/
%{_kf5_datadir}/plasma/plasmoids/
%{_kf5_datadir}/plasma/services/
%{_kf5_datadir}/plasma/wallpapers/
@ -616,7 +610,9 @@ fi
%{_datadir}/desktop-directories/*.directory
%{_datadir}/dbus-1/services/*.service
%{_datadir}/dbus-1/system-services/org.kde.fontinst.service
%{_datadir}/dbus-1/system-services/org.kde.localegenhelper.service
%{_datadir}/dbus-1/system.d/org.kde.fontinst.conf
%{_datadir}/dbus-1/system.d/org.kde.localegenhelper.conf
%{_datadir}/knsrcfiles/*.knsrc
%{_datadir}/kfontinst/icons/hicolor/*/actions/*font*.png
%{_datadir}/konqsidebartng/virtual_folders/services/fonts.desktop
@ -624,7 +620,7 @@ fi
%{_datadir}/kxmlgui5/kfontview/kfontviewpart.rc
%{_datadir}/kxmlgui5/kfontview/kfontviewui.rc
%{_kf5_datadir}/kservices5/ServiceMenus/installfont.desktop
%{_kf5_datadir}/kservices5/ServiceMenus/setaswallpaper.desktop
%{_kf5_datadir}/kio/servicemenus/setaswallpaper.desktop
%{_kf5_datadir}/kservices5/*.desktop
%{_kf5_datadir}/kservicetypes5/*.desktop
%{_kf5_datadir}/knotifications5/*.notifyrc
@ -646,7 +642,6 @@ fi
%{_kf5_datadir}/qlogging-categories5/*.categories
%{_sysconfdir}/xdg/plasmanotifyrc
%{_kf5_datadir}/kpackage/kcms/kcm_autostart/
%{_kf5_datadir}/kpackage/kcms/kcm_translations/
%{_kf5_datadir}/kpackage/kcms/kcm_colors/
%{_kf5_datadir}/kpackage/kcms/kcm_cursortheme/
%{_kf5_datadir}/kpackage/kcms/kcm_desktoptheme/
@ -655,11 +650,12 @@ fi
%{_kf5_datadir}/kpackage/kcms/kcm_lookandfeel/
%{_kf5_datadir}/kpackage/kcms/kcm_nightcolor/
%{_kf5_datadir}/kpackage/kcms/kcm_notifications/
%{_kf5_datadir}/kpackage/kcms/kcm_regionandlang/
%{_kf5_datadir}/kpackage/kcms/kcm_style/
%{_kf5_datadir}/kpackage/kcms/kcm_users/
%{_kf5_datadir}/kpackage/kcms/kcm_icons/
%{_kf5_datadir}/kpackage/kcms/kcm_formats/
%{_kf5_datadir}/polkit-1/actions/org.kde.fontinst.policy
%{_kf5_datadir}/polkit-1/actions/org.kde.localegenhelper.policy
%{_userunitdir}/*.service
%{_userunitdir}/plasma-core.target
%dir %{_userunitdir}/plasma-core.target.d/
@ -786,14 +782,97 @@ fi
%changelog
* Fri Jul 29 2022 Troy Dawson <tdawson@redhat.com> - 5.24.6-2
- Build plasma-lookandfeel-fedora on everything
* Tue Nov 29 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.4.1-1
- 5.26.4.1
* Tue Nov 29 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.4-1
- 5.26.4
* Wed Nov 09 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.3-1
- 5.26.3
* Mon Nov 07 2022 Marc Deop marcdeop@fedoraproject.org - 5.26.2-3
- BuildRequires for kpipewire-devel
* Sat Nov 05 2022 Marc Deop marcdeop@fedoraproject.org - 5.26.2-2
- Require kpipewire
* Wed Oct 26 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.2-1
- 5.26.2
* Tue Oct 18 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.1-1
- 5.26.1
* Thu Oct 06 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.26.0-1
- 5.26.0
* Sun Sep 25 2022 Neal Gompa <ngompa@fedoraproject.org> - 5.25.90-2
- Add Fedora patches to change default desktop context menu configuration
+ Enable "Open Terminal" action
+ Enable "Lock" and "Logout" actions
* Sat Sep 17 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.90-1
- 5.25.90
* Wed Sep 07 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.5-1
- 5.25.5
* Wed Jul 13 2022 Troy Dawson <tdawson@redhat.com> - 5.24.6-1
- Update to 5.24.6
* Fri Aug 26 2022 Adam Williamson <awilliam@redhat.com> - 5.25.4-2
- Disable sddm-on-wayland for F37 (#2110801)
* Wed Aug 03 2022 Justin Zobel <justin@1707.io> - 5.25.4-1
- Update to 5.25.4
* Mon Aug 01 2022 Frantisek Zatloukal <fzatlouk@redhat.com> - 5.25.3.1-8
- Rebuilt for ICU 71.1
* Wed Jul 27 2022 Troy Dawson <tdawson@redhat.com> - 5.25.3.1-7
- Add BuildRequires libicu-devel - enables this code
https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1725
* Mon Jul 25 2022 Jan Grulich <jgrulich@redhat.com> - 5.25.3.1-6
- Rebuild (qt5)
* Sun Jul 24 2022 Yaroslav Sidlovsky <zawertun@gmail.com> - 5.25.3.1-5
- Added patch to fix #457019
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5.25.3.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Wed Jul 20 2022 Jan Grulich <jgrulich@redhat.com> - 5.25.3.1-3
- Disable toplevel fixed positions on Wayland
* Thu Jul 14 2022 Jan Grulich <jgrulich@redhat.com> - 5.25.3.1-2
- Rebuild (qt5)
* Tue Jul 12 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.3.1-1
- 5.25.3.1
* Tue Jul 12 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.3-1
- 5.25.3
* Tue Jun 28 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.2-1
- 5.25.2
* Tue Jun 21 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.1-1
- 5.25.1
* Tue Jun 14 2022 Neal Gompa <ngompa@fedoraproject.org> - 5.25.0-2
- Remove broken mechanism for setting default look and feel
- Always ship Fedora look and feel theme
- Drop unneeded sddm theme snapshot and patches
* Thu Jun 09 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.25.0-1
- 5.25.0
* Fri May 20 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.24.90-1
- 5.24.90
* Tue May 17 2022 Jan Grulich <jgrulich@redhat.com> - 5.24.5-3
- Rebuild (qt5)
* Thu Jun 16 2022 Troy Dawson <tdawson@redhat.com> - 5.24.5-1.1
- Enable selinuxuser_execmod (#2058657)
* Fri May 06 2022 Mamoru TASAKA <mtasaka@fedoraproject.org> - 5.24.5-2
- Rebuild for new gpsd
* Tue May 03 2022 Marc Deop <marcdeop@fedoraproject.org> - 5.24.5-1
- 5.24.5

@ -1,3 +1,2 @@
SHA512 (breeze-fedora-0.2.tar.gz) = ff800e686b0dcb498f321bb94d3a8274c89c092f5408ef1ec3fc65333f046aea43444144ecaf166792f807014383af87b1180dc7540905fc10dc375309f8b2a8
SHA512 (plasma-workspace-5.24.6.tar.xz) = 4e49f59d565e0b84951122155158966a54c05a6999ff99503bfff667c780fac6cfc076326f0cac7d53629bfc1d81599b30e919848168f6beb79a4dc7cf7c5560
SHA512 (sddm-theme-5.24.80~pre.tar.gz) = 3b04c739d6054ecd9149178cafd3d7f53214a48fea834092707c5fd309018ea4986d4a955db7a2888a428c9b264e40403c36adae5f079d51979fe37912895344
SHA512 (plasma-workspace-5.26.4.1.tar.xz) = d4cef07da2802711265e04b1e5ebe284c59ab507e306041e290fd91687179141e42be678a4cd6473b59edfaefcd3edf603ae5cab1f7e85508f6e3d1abaa76784

@ -0,0 +1 @@
SHA512 (breeze-fedora-0.2.tar.gz) = ff800e686b0dcb498f321bb94d3a8274c89c092f5408ef1ec3fc65333f046aea43444144ecaf166792f807014383af87b1180dc7540905fc10dc375309f8b2a8

@ -0,0 +1,114 @@
diff -up plasma-workspace-5.12.5/startkde/startkde.cmake.startkde plasma-workspace-5.12.5/startkde/startkde.cmake
--- plasma-workspace-5.12.5/startkde/startkde.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
+++ plasma-workspace-5.12.5/startkde/startkde.cmake 2018-05-06 21:12:49.592504191 -0500
@@ -279,22 +237,21 @@ if test $? -ne 0; then
# Startup error
echo 'startkde: Could not sync environment to dbus.' 1>&2
test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
- xmessage -geometry 500x100 "Could not sync environment to dbus."
+ xmessage "Could not sync environment to dbus."
exit 1
fi
-# We set LD_BIND_NOW to increase the efficiency of kdeinit.
-# kdeinit unsets this variable before loading applications.
-LD_BIND_NOW=true @CMAKE_INSTALL_FULL_LIBEXECDIR_KF5@/start_kdeinit_wrapper --kded +kcminit_startup
+@CMAKE_INSTALL_FULL_LIBEXECDIR_KF5@/start_kdeinit_wrapper --kded +kcminit_startup
if test $? -ne 0; then
# Startup error
echo 'startkde: Could not start kdeinit5. Check your installation.' 1>&2
test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
- xmessage -geometry 500x100 "Could not start kdeinit5. Check your installation."
+ xmessage "Could not start kdeinit5. Check your installation."
exit 1
fi
-qdbus org.kde.KSplash /KSplash org.kde.KSplash.setStage kinit &
+qdbus=qdbus-qt5
+$qdbus org.kde.KSplash /KSplash org.kde.KSplash.setStage kinit &
# finally, give the session control to the session manager
# see kdebase/ksmserver for the description of the rest of the startup sequence
@@ -327,13 +284,13 @@ if test x"$wait_drkonqi"x = x"true"x ; t
# wait for remaining drkonqi instances with timeout (in seconds)
wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
wait_drkonqi_counter=0
- while qdbus | grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
+ while $qdbus | grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
sleep 5
wait_drkonqi_counter=$((wait_drkonqi_counter+5))
if test "$wait_drkonqi_counter" -ge "$wait_drkonqi_timeout" ; then
# ask remaining drkonqis to die in a graceful way
- qdbus | grep 'org.kde.drkonqi-' | while read address ; do
- qdbus "$address" "/MainApplication" "quit"
+ $qdbus | grep 'org.kde.drkonqi-' | while read address ; do
+ $qdbus "$address" "/MainApplication" "quit"
done
break
fi
diff -up plasma-workspace-5.12.5/startkde/startplasma.cmake.startkde plasma-workspace-5.12.5/startkde/startplasma.cmake
--- plasma-workspace-5.12.5/startkde/startplasma.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
+++ plasma-workspace-5.12.5/startkde/startplasma.cmake 2018-05-06 21:11:54.749023404 -0500
@@ -140,7 +140,8 @@ if test $? -ne 0; then
exit 1
fi
-qdbus org.kde.KSplash /KSplash org.kde.KSplash.setStage kinit &
+qdbus=qdbus-qt5
+$qdbus org.kde.KSplash /KSplash org.kde.KSplash.setStage kinit &
# finally, give the session control to the session manager
# see kdebase/ksmserver for the description of the rest of the startup sequence
@@ -169,13 +170,13 @@ if test x"$wait_drkonqi"x = x"true"x ; t
# wait for remaining drkonqi instances with timeout (in seconds)
wait_drkonqi_timeout=`kreadconfig5 --file startkderc --group WaitForDrKonqi --key Timeout --default 900`
wait_drkonqi_counter=0
- while qdbus | grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
+ while $qdbus | grep "^[^w]*org.kde.drkonqi" > /dev/null ; do
sleep 5
wait_drkonqi_counter=$((wait_drkonqi_counter+5))
if test "$wait_drkonqi_counter" -ge "$wait_drkonqi_timeout" ; then
# ask remaining drkonqis to die in a graceful way
- qdbus | grep 'org.kde.drkonqi-' | while read address ; do
- qdbus "$address" "/MainApplication" "quit"
+ $qdbus | grep 'org.kde.drkonqi-' | while read address ; do
+ $qdbus "$address" "/MainApplication" "quit"
done
break
fi
diff -up plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake.startkde plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake
--- plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake.startkde 2018-05-01 08:03:40.000000000 -0500
+++ plasma-workspace-5.12.5/startkde/startplasmacompositor.cmake 2018-05-06 21:11:54.749023404 -0500
@@ -3,6 +3,8 @@
# DEFAULT Plasma STARTUP SCRIPT ( @PROJECT_VERSION@ )
#
+qdbus=qdbus-qt5
+
# We need to create config folder so we can write startupconfigkeys
if [ ${XDG_CONFIG_HOME} ]; then
configDir=$XDG_CONFIG_HOME;
@@ -120,12 +122,12 @@ fi
# Get a property value from org.freedesktop.locale1
queryLocale1() {
- qdbus --system org.freedesktop.locale1 /org/freedesktop/locale1 "$1"
+ $qdbus --system org.freedesktop.locale1 /org/freedesktop/locale1 "$1"
}
# Query whether org.freedesktop.locale1 is available. If it is, try to
# set XKB_DEFAULT_{MODEL,LAYOUT,VARIANT,OPTIONS} accordingly.
-if qdbus --system org.freedesktop.locale1 >/dev/null 2>/dev/null; then
+if $qdbus --system org.freedesktop.locale1 >/dev/null 2>/dev/null; then
# Do not overwrite existing values. There is no point in setting only some
# of them as then they would not match anymore.
if [ -z "${XKB_DEFAULT_MODEL}" -a -z "${XKB_DEFAULT_LAYOUT}" -a \
@@ -175,7 +177,7 @@ fi
export XDG_DATA_DIRS
# Make sure that D-Bus is running
-if qdbus >/dev/null 2>/dev/null; then
+if $qdbus >/dev/null 2>/dev/null; then
: # ok
else
echo 'startplasmacompositor: Could not start D-Bus. Can you call qdbus?' 1>&2
Loading…
Cancel
Save