parent
798e6086d6
commit
7cfd4728c3
@ -1 +1 @@
|
|||||||
/plasma-desktop-5.6.5.tar.xz
|
/plasma-desktop-5.6.95.tar.xz
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
From 64bb8e4206f6d82f5a51bfee43217512df206787 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rex Dieter <rdieter@math.unl.edu>
|
|
||||||
Date: Mon, 18 Apr 2016 14:50:45 -0500
|
|
||||||
Subject: [PATCH 65/65] muon-discover => plasma-discover
|
|
||||||
|
|
||||||
---
|
|
||||||
applets/kickoff/package/contents/config/main.xml | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/applets/kickoff/package/contents/config/main.xml b/applets/kickoff/package/contents/config/main.xml
|
|
||||||
index ec222dd..2de73ba 100644
|
|
||||||
--- a/applets/kickoff/package/contents/config/main.xml
|
|
||||||
+++ b/applets/kickoff/package/contents/config/main.xml
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
</entry>
|
|
||||||
|
|
||||||
<entry name="removeApplicationCommand" type="String">
|
|
||||||
- <default>muon-discover --application</default>
|
|
||||||
+ <default>plasma-discover --application</default>
|
|
||||||
</entry>
|
|
||||||
|
|
||||||
</group>
|
|
||||||
--
|
|
||||||
2.7.3
|
|
||||||
|
|
@ -1,116 +0,0 @@
|
|||||||
https://bugs.kde.org/show_bug.cgi?id=361952
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index dfd7822..9c849ae 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -48,6 +48,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
|
|
||||||
Declarative
|
|
||||||
People
|
|
||||||
DBusAddons
|
|
||||||
+ ActivitiesStats
|
|
||||||
)
|
|
||||||
|
|
||||||
find_package(LibKWorkspace CONFIG REQUIRED)
|
|
||||||
diff --git a/applets/kicker/CMakeLists.txt b/applets/kicker/CMakeLists.txt
|
|
||||||
index 6aa9d8d..2e112e4 100644
|
|
||||||
--- a/applets/kicker/CMakeLists.txt
|
|
||||||
+++ b/applets/kicker/CMakeLists.txt
|
|
||||||
@@ -63,7 +63,7 @@ target_link_libraries(kickerplugin
|
|
||||||
Qt5::Quick
|
|
||||||
Qt5::X11Extras
|
|
||||||
KF5::Activities
|
|
||||||
- KF5::ActivitiesExperimentalStats
|
|
||||||
+ KF5::ActivitiesStats
|
|
||||||
KF5::ConfigCore
|
|
||||||
KF5::CoreAddons
|
|
||||||
KF5::I18n
|
|
||||||
diff --git a/applets/kicker/package/contents/ui/CompactRepresentation.qml b/applets/kicker/package/contents/ui/CompactRepresentation.qml
|
|
||||||
index 6d84b14..ed4c4e5 100644
|
|
||||||
--- a/applets/kicker/package/contents/ui/CompactRepresentation.qml
|
|
||||||
+++ b/applets/kicker/package/contents/ui/CompactRepresentation.qml
|
|
||||||
@@ -103,7 +103,7 @@ Item {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- visible: plasmoid.configuration.useCustomButtonImage && plasmoid.configuration.customButtonImage
|
|
||||||
+ visible: plasmoid.configuration.useCustomButtonImage && (plasmoid.configuration.customButtonImage != "")
|
|
||||||
source: plasmoid.configuration.customButtonImage
|
|
||||||
fillMode: Image.PreserveAspectFit
|
|
||||||
smooth: true
|
|
||||||
diff --git a/applets/kicker/plugin/actionlist.cpp b/applets/kicker/plugin/actionlist.cpp
|
|
||||||
index 57f2a2c..2aa97d9 100644
|
|
||||||
--- a/applets/kicker/plugin/actionlist.cpp
|
|
||||||
+++ b/applets/kicker/plugin/actionlist.cpp
|
|
||||||
@@ -27,13 +27,13 @@
|
|
||||||
#include <KPropertiesDialog>
|
|
||||||
#include <KRun>
|
|
||||||
|
|
||||||
-#include <KActivitiesExperimentalStats/Cleaning>
|
|
||||||
-#include <KActivitiesExperimentalStats/ResultSet>
|
|
||||||
-#include <KActivitiesExperimentalStats/Terms>
|
|
||||||
+#include <KActivities/Stats/Cleaning>
|
|
||||||
+#include <KActivities/Stats/ResultSet>
|
|
||||||
+#include <KActivities/Stats/Terms>
|
|
||||||
|
|
||||||
#include "containmentinterface.h"
|
|
||||||
|
|
||||||
-namespace KAStats = KActivities::Experimental::Stats;
|
|
||||||
+namespace KAStats = KActivities::Stats;
|
|
||||||
|
|
||||||
using namespace KAStats;
|
|
||||||
using namespace KAStats::Terms;
|
|
||||||
diff --git a/applets/kicker/plugin/recentcontactsmodel.cpp b/applets/kicker/plugin/recentcontactsmodel.cpp
|
|
||||||
index 182b7d0..1d2c9f5 100644
|
|
||||||
--- a/applets/kicker/plugin/recentcontactsmodel.cpp
|
|
||||||
+++ b/applets/kicker/plugin/recentcontactsmodel.cpp
|
|
||||||
@@ -26,14 +26,14 @@
|
|
||||||
|
|
||||||
#include <KLocalizedString>
|
|
||||||
|
|
||||||
-#include <KActivitiesExperimentalStats/ResultModel>
|
|
||||||
-#include <KActivitiesExperimentalStats/Terms>
|
|
||||||
+#include <KActivities/Stats/ResultModel>
|
|
||||||
+#include <KActivities/Stats/Terms>
|
|
||||||
|
|
||||||
#include <kpeople/widgets/actions.h> //FIXME TODO: Pretty include in KPeople broken.
|
|
||||||
#include <kpeople/widgets/persondetailsdialog.h>
|
|
||||||
#include <KPeople/PersonData>
|
|
||||||
|
|
||||||
-namespace KAStats = KActivities::Experimental::Stats;
|
|
||||||
+namespace KAStats = KActivities::Stats;
|
|
||||||
|
|
||||||
using namespace KAStats;
|
|
||||||
using namespace KAStats::Terms;
|
|
||||||
diff --git a/applets/kicker/plugin/recentusagemodel.cpp b/applets/kicker/plugin/recentusagemodel.cpp
|
|
||||||
index d6fe840..85fd607 100644
|
|
||||||
--- a/applets/kicker/plugin/recentusagemodel.cpp
|
|
||||||
+++ b/applets/kicker/plugin/recentusagemodel.cpp
|
|
||||||
@@ -37,11 +37,11 @@
|
|
||||||
#include <KService>
|
|
||||||
#include <KStartupInfo>
|
|
||||||
|
|
||||||
-#include <KActivitiesExperimentalStats/Cleaning>
|
|
||||||
-#include <KActivitiesExperimentalStats/ResultModel>
|
|
||||||
-#include <KActivitiesExperimentalStats/Terms>
|
|
||||||
+#include <KActivities/Stats/Cleaning>
|
|
||||||
+#include <KActivities/Stats/ResultModel>
|
|
||||||
+#include <KActivities/Stats/Terms>
|
|
||||||
|
|
||||||
-namespace KAStats = KActivities::Experimental::Stats;
|
|
||||||
+namespace KAStats = KActivities::Stats;
|
|
||||||
|
|
||||||
using namespace KAStats;
|
|
||||||
using namespace KAStats::Terms;
|
|
||||||
diff --git a/applets/kicker/plugin/runnermodel.cpp b/applets/kicker/plugin/runnermodel.cpp
|
|
||||||
index 732d047..88b3670 100644
|
|
||||||
--- a/applets/kicker/plugin/runnermodel.cpp
|
|
||||||
+++ b/applets/kicker/plugin/runnermodel.cpp
|
|
||||||
@@ -261,6 +261,7 @@ void RunnerModel::matchesChanged(const QList<Plasma::QueryMatch> &matches)
|
|
||||||
m_models.removeAt(row);
|
|
||||||
delete matchesModel;
|
|
||||||
endRemoveRows();
|
|
||||||
+ emit countChanged();
|
|
||||||
} else {
|
|
||||||
matchesModel->setMatches(matches);
|
|
||||||
}
|
|
Loading…
Reference in new issue