only xine-backend

epel9
Than Ngo 16 years ago
parent 1c4266d458
commit 15d049a47e

@ -0,0 +1,29 @@
diff -up phonon-4.3.1/CMakeLists.txt.orig phonon-4.3.1/CMakeLists.txt
--- phonon-4.3.1/CMakeLists.txt.orig 2009-06-05 16:16:00.000000000 +0200
+++ phonon-4.3.1/CMakeLists.txt 2009-06-05 16:22:48.000000000 +0200
@@ -248,25 +248,8 @@ if(APPLE)
set(CMAKE_INSTALL_NAME_DIR ${LIB_INSTALL_DIR})
endif(APPLE)
-
-add_subdirectory(cmake)
-add_subdirectory(phonon)
-add_subdirectory(includes)
-if (Q_WS_MAC AND BUILD_PHONON_QT7)
- add_subdirectory(qt7)
-endif (Q_WS_MAC AND BUILD_PHONON_QT7)
-if (Q_WS_WIN)
- add_subdirectory(ds9)
-endif (Q_WS_WIN)
-
if (Q_WS_X11)
- add_subdirectory(gstreamer)
add_subdirectory(xine)
endif (Q_WS_X11)
-if(NOT WIN32) # pkgconfig file
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-endif(NOT WIN32)
-
macro_display_feature_log()

@ -1,85 +1,38 @@
Summary: Multimedia framework api Summary: Multimedia framework api
Name: phonon Name: phonon
Version: 4.3.1 Version: 4.3.1
Release: 6%{?dist} Release: 7%{?dist}
Group: System Environment/Libraries Group: Applications/Multimedia
License: LGPLv2+ License: LGPLv2+
URL: http://phonon.kde.org/ URL: http://phonon.kde.org/
#Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/%{version}/%{name}-%{version}.tar.bz2
Source0: ftp://ftp.kde.org/pub/kde/stable/4.2.1/phonon-%{version}.tar.bz2 Source0: ftp://ftp.kde.org/pub/kde/stable/4.2.1/phonon-%{version}.tar.bz2
Source1: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# Make PulseAudio the default again when listed by the backend. Patch0: phonon-4.3.1-xineonly.patch
# Note that this currently only works for the Xine backend. Device selection in
# the GStreamer backend is weird: there is a setting for "sink" which cannot be
# set through systemsettings, and listed devices are only those supported by the
# "sink". So it never lists "PulseAudio" as a supported device, you have to pick
# it as a "sink", and then the device setting is ignored entirely.
Patch0: phonon-4.2.96-pulseaudio.patch
Patch1: phonon-4.2.96-xine-pulseaudio.patch
## Upstream patches
Patch100: phonon-4.3.2-gstreamer-utf8-url.patch
Patch101: phonon-4.3.2-gstreamer-volumefader.patch
# fix for non-ascii filenames in xine backend
Patch102: phonon-4.3.2-kdebug#172242.patch
BuildRequires: automoc4 >= 0.9.86 BuildRequires: automoc4 >= 0.9.86
BuildRequires: cmake >= 2.6.0 BuildRequires: cmake >= 2.6.0
BuildRequires: glib2-devel BuildRequires: glib2-devel
BuildRequires: gstreamer-devel
BuildRequires: gstreamer-plugins-base-devel
BuildRequires: GraphicsMagick
BuildRequires: kde-filesystem BuildRequires: kde-filesystem
BuildRequires: libxcb-devel BuildRequires: libxcb-devel
BuildRequires: libxml2-devel BuildRequires: libxml2-devel
BuildRequires: pkgconfig BuildRequires: pkgconfig
BuildRequires: qt4-devel >= 4.4.0 BuildRequires: qt4-devel >= 4.5.1
BuildRequires: xine-lib-devel BuildRequires: xine-lib-devel
Requires: phonon-backend%{?_isa} >= %{version}
## hard-code phonon-backend-xine, if yum chooses -gstreamer by default
#Requires(hint): phonon-backend-xine%{?_isa} >= %{version}
%description %description
%{summary}. %{summary}.
%package backend-gstreamer
Summary: Gstreamer phonon backend
Group: Applications/Multimedia
Requires: %{name} = %{version}-%{release}
Provides: phonon-backend%{?_isa} = %{version}-%{release}
Obsoletes: %{name}-backend-gst < 4.2.0-4
Provides: %{name}-backend-gst = %{version}-%{release}
%description backend-gstreamer
%{summary}.
%package backend-xine %package backend-xine
Summary: xine phonon backend Summary: xine phonon backend
Group: Applications/Multimedia Group: Applications/Multimedia
Requires: %{name} = %{version}-%{release}
Provides: phonon-backend%{?_isa} = %{version}-%{release} Provides: phonon-backend%{?_isa} = %{version}-%{release}
%description backend-xine %description backend-xine
%{summary}. %{summary}.
%package devel
Summary: Developer files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: qt4-devel
Requires: pkgconfig
%description devel
%{summary}.
%prep %prep
%setup -q -n phonon-%{version}%{?alphatag} %setup -q -n phonon-%{version}%{?alphatag}
%patch0 -p1 -b .pulseaudio %patch0 -p1 -b .xineonly
%patch1 -p1 -b .xine-pulseaudio
%patch100 -p0 -b .gstreamer-utf8-url
%patch101 -p0 -b .gstreamer-volumefader
%patch102 -p1 -b .xine_nonascii
%build %build
@ -97,44 +50,18 @@ rm -rf %{buildroot}
make install/fast DESTDIR=%{buildroot} -C %{_target_platform} make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
# move the oxygen-only phonon-xine icons to hicolor # move the oxygen-only phonon-xine icons to hicolor
test -d %{buildroot}%{_datadir}/icons/hicolor && exit 0 if [ ! -d %{buildroot}%{_datadir}/icons/hicolor ] ; then
mv %{buildroot}%{_datadir}/icons/oxygen \ mv %{buildroot}%{_datadir}/icons/oxygen \
%{buildroot}%{_datadir}/icons/hicolor %{buildroot}%{_datadir}/icons/hicolor
fi
install -D -m 0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
for i in 16 22 32 48 64 128; do
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
gm convert -background None -geometry ${i}x${i} %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/phonon-gstreamer.png
touch --reference %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/phonon-gstreamer.png
done
%clean %clean
rm -rf %{buildroot} rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post backend-gstreamer
touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||:
%post backend-xine %post backend-xine
touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||: touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||:
%posttrans backend-gstreamer
gtk-update-icon-cache %{_kde4_iconsdir}/hicolor &> /dev/null ||:
%posttrans backend-xine
gtk-update-icon-cache %{_kde4_iconsdir}/hicolor &> /dev/null ||:
%postun backend-gstreamer
if [ $1 -eq 0 ] ; then
touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||:
gtk-update-icon-cache %{_kde4_iconsdir}/hicolor &> /dev/null ||:
fi
%postun backend-xine %postun backend-xine
if [ $1 -eq 0 ] ; then if [ $1 -eq 0 ] ; then
touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||: touch --no-create %{_kde4_iconsdir}/hicolor &> /dev/null ||:
@ -142,37 +69,18 @@ if [ $1 -eq 0 ] ; then
fi fi
%files %files backend-xine
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc COPYING.LIB %doc COPYING.LIB
%{_libdir}/libphonon*.so.4*
%{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
# kde4-specific dirs
%dir %{_kde4_libdir}/kde4/plugins/phonon_backend/
%dir %{_kde4_datadir}/kde4/services/phononbackends/
%files backend-gstreamer
%defattr(-,root,root,-)
%{_kde4_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
%{_kde4_datadir}/kde4/services/phononbackends/gstreamer.desktop
%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
%files backend-xine
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_kde4_libdir}/kde4/plugins/phonon_backend/phonon_xine.so %{_kde4_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
%{_kde4_datadir}/kde4/services/phononbackends/xine.desktop %{_kde4_datadir}/kde4/services/phononbackends/xine.desktop
%{_datadir}/icons/hicolor/*/apps/phonon-xine.* %{_datadir}/icons/hicolor/*/apps/phonon-xine.*
%files devel
%defattr(-,root,root,-)
%dir %{_includedir}/KDE
%{_includedir}/KDE/Phonon/
%{_includedir}/phonon/
%{_libdir}/pkgconfig/phonon.pc
%{_libdir}/libphonon*.so
%changelog %changelog
* Fri Jun 05 2009 Than Ngo <than@redhat.com> - 4.3.1-7
- only xine-backend
* Wed May 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-6 * Wed May 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-6
- phonon-backend-gstreamer multilib conflict (#501816) - phonon-backend-gstreamer multilib conflict (#501816)

Loading…
Cancel
Save