Fix building on Perl without "." in @INC

f38
Petr Písař 8 years ago
parent 29e48048b4
commit cbb6c1fec8

@ -0,0 +1,25 @@
From d775d167582eb5a0a8b26d3c0e91144666dd54b3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 16 May 2017 14:13:42 +0200
Subject: [PATCH] Fix building on Perl without "." in @INC
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile.PL b/Makefile.PL
index f75a264..23717c4 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,4 @@
+BEGIN { push @INC, '.'; }
use inc::Module::Install;
name 'Test-Script-Run';
--
2.9.4

@ -1,11 +1,13 @@
Name: perl-Test-Script-Run Name: perl-Test-Script-Run
Version: 0.08 Version: 0.08
Release: 4%{?dist} Release: 5%{?dist}
Summary: Test the script with run Summary: Test the script with run
License: GPL+ or Artistic License: GPL+ or Artistic
Group: Development/Libraries Group: Development/Libraries
URL: http://search.cpan.org/dist/Test-Script-Run/ URL: http://search.cpan.org/dist/Test-Script-Run/
Source0: http://www.cpan.org/authors/id/S/SU/SUNNAVY/Test-Script-Run-%{version}.tar.gz Source0: http://www.cpan.org/authors/id/S/SU/SUNNAVY/Test-Script-Run-%{version}.tar.gz
# Fix building on Perl without "." in @INC, CPAN RT#121704
Patch0: Test-Script-Run-0.08-Fix-building-on-Perl-without-.-in-INC.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch BuildArch: noarch
BuildRequires: coreutils BuildRequires: coreutils
@ -40,6 +42,7 @@ distribution's bin/ directory, if the script path is not absolute.
%prep %prep
%setup -q -n Test-Script-Run-%{version} %setup -q -n Test-Script-Run-%{version}
%patch0 -p1
%build %build
%{__perl} Makefile.PL INSTALLDIRS=vendor %{__perl} Makefile.PL INSTALLDIRS=vendor
@ -66,6 +69,9 @@ make test
%{_mandir}/man3/Test::Script::Run.3pm* %{_mandir}/man3/Test::Script::Run.3pm*
%changelog %changelog
* Tue May 16 2017 Petr Pisar <ppisar@redhat.com> - 0.08-5
- Fix building on Perl without "." in @INC (CPAN RT#121704)
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.08-4 * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.08-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

Loading…
Cancel
Save