0.08 bump; Modernize spec file

epel9
Jitka Plesnikova 7 years ago
parent cdbb6f3a4c
commit 625554a1c6

1
.gitignore vendored

@ -1 +1,2 @@
Test-Object-0.07.tar.gz
/Test-Object-0.08.tar.gz

@ -1,25 +0,0 @@
From d43f322d24db7505125624a1b137a3d0e4253a2d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 16 May 2017 14:24:13 +0200
Subject: [PATCH] Fix building on Perl without "." in @INC
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile.PL b/Makefile.PL
index ebceb46..d4c9ffa 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,4 @@
+BEGIN { push @INC, '.'; }
use inc::Module::Install;
name 'Test-Object';
--
2.9.4

@ -1,30 +1,33 @@
Name: perl-Test-Object
Version: 0.07
Release: 29%{?dist}
Version: 0.08
Release: 1%{?dist}
Summary: Thoroughly testing objects via registered handlers
Group: Development/Libraries
License: GPL+ or Artistic
URL: http://search.cpan.org/dist/Test-Object/
Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/Test-Object-%{version}.tar.gz
# Fix building on Perl without "." in @INC, CPAN RT#120413
Patch0: Test-Object-0.07-Fix-building-on-Perl-without-.-in-INC.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://www.cpan.org/authors/id/E/ET/ETHER/Test-Object-%{version}.tar.gz
BuildArch: noarch
BuildRequires: make
BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl(:VERSION) >= 5.6
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(strict)
BuildRequires: perl(warnings)
# Run-time
BuildRequires: perl(Carp)
BuildRequires: perl(Cwd)
BuildRequires: perl(Exporter)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(File::Path)
BuildRequires: perl(File::Spec::Functions)
BuildRequires: perl(lib)
BuildRequires: perl(Scalar::Util) >= 1.16
BuildRequires: perl(Test::Builder) >= 0.33
BuildRequires: perl(Test::Builder::Tester) >= 1.02
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod) >= 1.00
BuildRequires: perl(vars)
# Tests
BuildRequires: perl(File::Spec)
BuildRequires: perl(File::Spec::Functions)
BuildRequires: perl(FindBin)
BuildRequires: perl(lib)
BuildRequires: perl(Test::Builder::Tester)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description
@ -32,40 +35,31 @@ Test::Object is a testing package designed to allow you to easily test
what you believe is a valid object against the expected behaviour of
all of the classes in its inheritance tree in one single call.
%prep
%setup -q -n Test-Object-%{version}
%patch0 -p1
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__perl} Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make pure_install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
chmod -R u+w $RPM_BUILD_ROOT/*
%{_fixperms} $RPM_BUILD_ROOT/*
%check
make test AUTOMATED_TESTING=1
%clean
rm -rf $RPM_BUILD_ROOT
make test
%files
%defattr(-,root,root,-)
%doc Changes LICENSE README
%license LICENSE
%doc Changes CONTRIBUTING README
%{perl_vendorlib}/Test/
%{_mandir}/man3/*.3pm*
%changelog
* Mon Jan 15 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.08-1
- 0.08 bump
- Modernize spec file
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.07-29
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

@ -1 +1 @@
ab71791756faaabc3b4fad5bcc1df50f Test-Object-0.07.tar.gz
SHA512 (Test-Object-0.08.tar.gz) = c528ee4d8eebb26cc336344765f1c5d402f020dae42f658164a5b2954c48975ccf33dafa768228bddff7583af5cd219959a82d037408c250cf162d59ab3a90d1

Loading…
Cancel
Save